Skip to content

Commit

Permalink
games-strategy/war1gus: Bump to 3.3.2
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Aug 10, 2022
1 parent aef41bb commit aeb3530
Show file tree
Hide file tree
Showing 2 changed files with 69 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-strategy/war1gus/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST war1gus-3.2.0.tar.gz 408417 BLAKE2B 8369d380813aa6a5c7484e7b668284ee3b59bd4a914b82b074640344af977c08727260efc284a5ffc7d5c52ef7ae0ab45b484d87d855a088198b02adf5240bac SHA512 2e3509792509730254e9292dce66491e848980a37171281dcd851aaa0662a3dd8911444d97c25486acb61fa5ad913da3bb397ddd599cd7ea1293b0afbfc88bc6
DIST war1gus-3.3.0.tar.gz 486274 BLAKE2B 90675ce44cab26079c53ebd70377ea24bef3894d1f194f45496a0df6528e1bb63184f3c93f843ab9176ad02c542a9e51fbfa9f4af3bce6018fa7085d31494998 SHA512 9e17101954f7e953ba11cebd2f62eb9e3465217897bd55699846d6290fa5d249574d144f271e08485bc38ef7dd63e5efa05437faa5191148d1ea9341157834ea
DIST war1gus-3.3.1.tar.gz 486322 BLAKE2B cdf3db536c6cae2327ba044da13f2743c299481503723d00fbfeb8103932a0065afb0771f1719264fa7ed298b876f2189bc9c1def2b4fcc6c1b4a45992d0d322 SHA512 947592a220aeae99840abc88c5086d681afb72971f25f3e42c475d416529bb0341ca409aa5459e049d1dbe4b937cf25c29c6445958c5c61e26a67c4a4dd7ccb0
DIST war1gus-3.3.2.tar.gz 486326 BLAKE2B 2ea0506bc2dabf8a1a58f52fe3bb0b110f07100b6f6ade29f2273f7718c8ef8572c642e6fba5005894383100190f3b649faa1b06286f11d4b7718cb59833eeb4 SHA512 e4c0b297cf215618edf007d2b1584f7d812607a33587b5254e1620dff6aa7a282b67b464b39eed11cd7405cae34d11f1587f42893b2ccf4ca531dc4c37375d74
68 changes: 68 additions & 0 deletions games-strategy/war1gus/war1gus-3.3.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,68 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit cmake xdg-utils

DESCRIPTION="Warcraft: Orcs & Humans for the Stratagus game engine"
HOMEPAGE="
https://stratagus.com/war1gus.html
https://github.com/Wargus/war1gus/
"
SRC_URI="
https://github.com/Wargus/war1gus/archive/v${PV}.tar.gz
-> ${P}.tar.gz
"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"

DEPEND="
=games-engines/stratagus-${PV}*[theora]
media-libs/libpng:0=
sys-libs/zlib:=
x11-libs/gtk+:2
x11-libs/libX11
"
RDEPEND="
${DEPEND}
"
BDEPEND="
virtual/pkgconfig
"

src_configure() {
local mycmakeargs=(
-DGAMEDIR="${EPREFIX}/usr/bin"
-DBINDIR="${EPREFIX}/usr/bin"
-DSTRATAGUS="${EPREFIX}/usr/bin/stratagus"
-DSHAREDIR="${EPREFIX}/usr/share/stratagus/war1gus"
-DICONDIR=/usr/share/icons/hicolor/64x64/apps
)
cmake_src_configure
}

pkg_postinst() {
elog "War1gus requires the data from the original game to run. The game"
elog "will ask you for the location of the game data and extract/convert"
elog "it automatically on the first run."

if ! has_version media-video/ffmpeg ||
! has_version media-sound/timidity++
then
elog
elog "If you did not convert the game data yet, you may want to install"
elog "the following optional dependencies:"
elog
elog "media-video/ffmpeg -- to convert game videos"
elog "media-sound/timidity++ -- to convert game music"
fi

xdg_icon_cache_update
}

pkg_postrm() {
xdg_icon_cache_update
}

0 comments on commit aeb3530

Please sign in to comment.