Skip to content

Commit

Permalink
dev-ruby/httpclient: add 2.7.0
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.20.1
  • Loading branch information
graaff committed Nov 6, 2015
1 parent 13c1441 commit aec3f06
Show file tree
Hide file tree
Showing 2 changed files with 63 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/httpclient/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST httpclient-2.5.3.2.tgz 303735 SHA256 3605a897d393e90071dab35b153dbedd844fa92c4ef8d13e43115866b2bf3867 SHA512 17db0302b958f10b4a75167d8c03b77f195786b5b429b76fc883af992cc71703500b9a42e39b832ac3421b3b742160496bdeeccd160e48ad2c377d9d8666ba89 WHIRLPOOL 162badfe5619a9ed9d42f9d29c7d34f45eeb205bbc76715d66547b5bf8e5962ba41c535ed2b53075ce6c6abef76a58062a91e172195ec1ab56282c0a2cabbfb3
DIST httpclient-2.5.3.3.tgz 300578 SHA256 852b50cd771c659e38e4c4a31ace0ac3a2ab1da732b11b01e899827b1f2b424e SHA512 929dd4dfa5719367c61845f522aeb94059dff678716a22fc78b59f7cdce3c2a5fc88a01b6e0efd0ada06f3224cf52e7475b3a4c06f25383ad3702e1514c09292 WHIRLPOOL d6091a0d910474657d5fea0f91703f575fa7ff43e10240afc9312ea0d663c288b0a7dc7518c59e9a095a0c9d81eb18c6bf586db305543ee9217f09addec9a99d
DIST httpclient-2.6.0.1.tgz 305847 SHA256 213f55639b85edf47fb32f865b59085a76d77c87355e9e13e747250f8da0f6e9 SHA512 bcb71a7b6be7d132df63c5434cb2d4be46fa9b5c585b68a8a8269e46acecde6403098555e219354c60fc193016651c1bda53bffd9d509a517a3104c9a4e04efe WHIRLPOOL 4ded5d0b5f93c3b58df1e1c2233ae3a6219d797c0fb193d4995a2863fda76bad10ef0429f79a01c9b3c7c9ae27e20879b81db34239ff901a502baea9d6436785
DIST httpclient-2.7.0.tgz 455995 SHA256 95f839dc5c54853d84dd1658846d29b3d57d08326c58b8b1afdbc09c89d60a7e SHA512 b330cec27804832140e69d335baf204e11491ee764c2abd6010d41d67717849fba4dc6f4bbf955a380ec76286f1eb73a3346403723e74e9a70fd4451b3df1f08 WHIRLPOOL c48f3129e670e31673e19dbfa432d5b80afc5508a3db3e6cc1436d260ee975e4c2a48260a368552fe1db39a5c35cc5b45729f7685bad50705f350f14f775d6d0
62 changes: 62 additions & 0 deletions dev-ruby/httpclient/httpclient-2.7.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,62 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

USE_RUBY="ruby20 ruby21 ruby22"

RUBY_FAKEGEM_TASK_TEST="-Ilib test"
RUBY_FAKEGEM_TASK_DOC="doc"

RUBY_FAKEGEM_DOCDIR="doc"

RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"

RUBY_FAKEGEM_GEMSPEC="httpclient.gemspec"

inherit ruby-fakegem

DESCRIPTION="'httpclient' gives something like the functionality of libwww-perl (LWP) in Ruby"
HOMEPAGE="https://github.com/nahi/httpclient"
SRC_URI="https://github.com/nahi/httpclient/archive/v${PV}.tar.gz -> ${P}.tgz"

LICENSE="Ruby"
SLOT="0"

KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
IUSE=""

RDEPEND="${RDEPEND}
!dev-ruby/http-access2"

ruby_add_rdepend "virtual/ruby-ssl"

ruby_add_bdepend "doc? ( dev-ruby/rdoc )"
ruby_add_bdepend "test? ( dev-ruby/http-cookie )"

all_ruby_prepare() {
rm Gemfile || die
sed -i -e '/[bB]undler/s:^:#:' Rakefile || die

# Fix documentation task
sed -i -e 's/README.txt/README.md/' Rakefile || die

# Remove mandatory CI reports since we don't need this for testing.
sed -i -e '/reporter/s:^:#:' Rakefile || die

# Remove mandatory simplecov dependency
sed -i -e '/[Ss]imple[Cc]ov/ s:^:#:' test/helper.rb || die

# Comment out test requiring network access that makes assumptions
# about the environment, bug 395155
sed -i -e '/test_async_error/,/^ end/ s:^:#:' test/test_httpclient.rb || die

# Skip tests using rack-ntlm which is not packaged. Weirdly these
# only fail on jruby.
rm test/test_auth.rb || die
}

each_ruby_test() {
${RUBY} -Ilib -S testrb test/test_*.rb || die
}

0 comments on commit aec3f06

Please sign in to comment.