Skip to content

Commit

Permalink
app-office/libalkimia: Add USE gmp, EAPI-7 bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
a17r committed Feb 24, 2019
1 parent 69bc579 commit aef4348
Showing 1 changed file with 38 additions and 0 deletions.
38 changes: 38 additions & 0 deletions app-office/libalkimia/libalkimia-7.0.2-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,38 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

KDE_TEST="forceoptional"
KMNAME="alkimia"
inherit kde5

if [[ ${KDE_BUILD_TYPE} = release ]]; then
SRC_URI="mirror://kde/stable/${KMNAME}/${PV}/${KMNAME}-${PV}.tar.xz"
KEYWORDS="~amd64 ~x86"
fi

DESCRIPTION="Library with common classes and functionality used by KDE finance applications"
HOMEPAGE="https://www.linux-apps.com/content/show.php/libalkimia?content=137323"
LICENSE="LGPL-2.1"
SLOT="0/7"
IUSE="doc gmp"

BDEPEND="
virtual/pkgconfig
doc? ( app-doc/doxygen )
"
DEPEND="
$(add_qt_dep qtdbus)
!gmp? ( sci-libs/mpir:= )
gmp? ( dev-libs/gmp:0=[cxx] )
"
RDEPEND="${DEPEND}"

src_configure() {
local mycmakeargs=(
$(cmake-utils_use_find_package doc Doxygen)
$(cmake-utils_use_find_package !gmp MPIR)
)
kde5_src_configure
}

0 comments on commit aef4348

Please sign in to comment.