Skip to content

Commit

Permalink
dev-ruby/test-unit: Version bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.26
  • Loading branch information
mrueg committed Jan 17, 2016
1 parent 30630ec commit aef6ce9
Show file tree
Hide file tree
Showing 2 changed files with 47 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/test-unit/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -3,3 +3,4 @@ DIST test-unit-2.5.5.gem 111104 SHA256 3216d6584293964c438e0573fa8f0273d12df2abb
DIST test-unit-3.1.3.gem 121856 SHA256 b34ed36148329b1f4df9b3385259172c5435457f0da3d5494e3fcd0ae1f33d79 SHA512 3b2ab5e74940c9e02ca345212858ace4fec2266137da896efed50d87f53fb6076be11dcc05603b294bfe48a68ac2458c2b6bd437ddcf45ea7b0b1959b3c7fb89 WHIRLPOOL baba9eba099c6a599c8237dccef9749075b32a187041080c5230ad36f9354f175d9c96d7d2a02f7fcc4b18bb21cf628f0e3f06bc530914fd68cd4565e6a369ab
DIST test-unit-3.1.4.gem 122368 SHA256 9af970e9106b57672cccf917af6bc252e18ceef500d026eac360559f4560c4af SHA512 9e7b3d1a83b5d296d082281cf0f177ce6ab4347351cb358c199924bfc6bc2c56ed2c9a0701aac7dc056bede29087b91389a3e51c04e7f31852bfa6d90bac6b16 WHIRLPOOL 84911bbf8427d7575456257f4ac0f2fe6cb1862a4c9e68507e185529a65c4cca6fc1980b795a813bd886c3c7a4d389ca2435393539a13eb447d4515b45e72410
DIST test-unit-3.1.5.gem 122368 SHA256 9c38357eb0342e7971b6e6c37691b1ceb5161736a0e92e314797e6cabfb4bf4b SHA512 46840108402ef6319e76fd9b5270e88aaf45d6cf99fa84f28e8a01ce2bc2d5e0e79d1fdf660807fcc5b2434540f4240bd4799ecbb7fa6231af1cd96a7c89f994 WHIRLPOOL fbec655035463fd0b10f4c514444c2448feb37dd4f072ad536fc3f834afd5f9059409da87b23f4c7b7d73f7150815b26a91cdb80a9365211d2280a5ec102b97b
DIST test-unit-3.1.7.gem 124416 SHA256 01133018f929db5290471b8e39feb5317bde2488efde1ec18e9653b2edb526f1 SHA512 fb41fdc27b0278fd272db100d76b4691468ab68d1327baf63d4e230285aec5e9faedb3b2fced4445a8a801828e9c715533ab6311dbe7a4033b6c8402e711b06e WHIRLPOOL 4d660d4c4da7329daa5ea1d4f5ac1859d150c0cfea8591adc82a5ad2ef1c08095cc29a8ef269d0f989ded7de20c903068ac1733a95c0cf7d1912887c003dd0c6
46 changes: 46 additions & 0 deletions dev-ruby/test-unit/test-unit-3.1.7.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,46 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
USE_RUBY="ruby20 ruby21 ruby22 ruby23"

RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_DOCDIR="doc"
RUBY_FAKEGEM_EXTRADOC="README.md doc/text/news.md"

inherit ruby-fakegem

# Assume for now that ruby23 is not eselected yet and only
# depend on yard for the other ruby implementations. Without this
# assumption bootstrapping ruby23 won't be possible due to the yard
# dependency tree.
USE_RUBY="${USE_RUBY/ruby23/}" ruby_add_bdepend "doc? ( dev-ruby/yard )"

DESCRIPTION="An xUnit family unit testing framework for Ruby"
HOMEPAGE="https://rubygems.org/gems/test-unit"

LICENSE="|| ( Ruby GPL-2 ) PSF-2"
SLOT="2"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="doc test"

ruby_add_rdepend "dev-ruby/power_assert"

all_ruby_compile() {
all_fakegem_compile

if use doc; then
yard doc --title ${PN} || die
fi
}

each_ruby_test() {
${RUBY} test/run-test.rb || die "testsuite failed"
}

all_ruby_install() {
all_fakegem_install

newbin "${FILESDIR}"/testrb-3 testrb-2
}

0 comments on commit aef6ce9

Please sign in to comment.