Skip to content

Commit

Permalink
app-text/evince: Bump to 3.32.1, needs appstream-glib
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/683756
Package-Manager: Portage-2.3.77, Repoman-2.3.17
Signed-off-by: Pacho Ramos <[email protected]>
  • Loading branch information
pacho2 committed Oct 20, 2019
1 parent 3493e33 commit af12932
Show file tree
Hide file tree
Showing 2 changed files with 109 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-text/evince/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST evince-3.30.2.tar.xz 2288868 BLAKE2B dd0423b7ec51daf897bfbc45afb298f9ee23b28ada3dfe5d5d2808b4515bdc7077a7e0ae46541876bb2fbfd8aa9ec44abc7aabcb3cb10b6e52912f0ac1358eeb SHA512 dfffcf15547d0720bd2379054d7b9bee02f8bea7113562162cbab62d77cf84c04f70dcc87a3e6b1ba62db38783df8f481d801854d8f0767f60e9cfabd9efc646
DIST evince-3.32.0.tar.xz 2564236 BLAKE2B 203bc6ff6b8b2a3d30ebd30f7f9be6269ded5044521da7d2732cb759db8e8ebd2d565c2ad04908e11ec1f726ec70dd2931c58c9b31951a7b3d3165c61042c87f SHA512 565298a200d9ae2f6b4cb53c3cba0d0d0e4cfbef60e4145bfb9c82a5682947ceb2371e52c27179cd69a238cd387bcfd744d3c55df814b6347f07781aec3ea658
DIST evince-3.32.1.tar.xz 2567868 BLAKE2B 8fec9ce1981fb2c5fc60c4b653f462f07f0341ebe64a5615f1e1a123533f8053c6f76a02d05da9245b4263c24df1cdd2e28aa89486b8c802a2aa14cf04faf13b SHA512 29028fedde9aff85e53a5059f63df007e1bac7d662a91fe01e1bb8c48349d5674afe3ce37f9c495e4b208fd476b22f4ecaf749c6d7c3362a03b05703400ece05
108 changes: 108 additions & 0 deletions app-text/evince/evince-3.32.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,108 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
GNOME2_LA_PUNT="yes"
GNOME2_EAUTORECONF="yes"

inherit gnome2 systemd

DESCRIPTION="Simple document viewer for GNOME"
HOMEPAGE="https://wiki.gnome.org/Apps/Evince"

LICENSE="GPL-2+ CC-BY-SA-3.0"
# subslot = evd3.(suffix of libevdocument3)-evv3.(suffix of libevview3)
SLOT="0/evd3.4-evv3.3"
IUSE="djvu dvi gstreamer gnome gnome-keyring +introspection nautilus nsplugin postscript spell t1lib tiff xps"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris"

# atk used in libview
# bundles unarr
COMMON_DEPEND="
dev-libs/atk
>=dev-libs/glib-2.36:2[dbus]
>=dev-libs/libxml2-2.5:2
sys-libs/zlib:=
>=x11-libs/gdk-pixbuf-2.36.5:2
>=x11-libs/gtk+-3.22.0:3[introspection?]
gnome-base/gsettings-desktop-schemas
>=x11-libs/cairo-1.10:=
>=app-text/poppler-0.33[cairo]
>=app-arch/libarchive-3.2.0
djvu? ( >=app-text/djvu-3.5.22:= )
dvi? (
virtual/tex-base
dev-libs/kpathsea:=
t1lib? ( >=media-libs/t1lib-5:= ) )
gstreamer? (
media-libs/gstreamer:1.0
media-libs/gst-plugins-base:1.0
media-libs/gst-plugins-good:1.0 )
gnome? ( gnome-base/gnome-desktop:3= )
gnome-keyring? ( >=app-crypt/libsecret-0.5 )
introspection? ( >=dev-libs/gobject-introspection-1:= )
nautilus? ( >=gnome-base/nautilus-2.91.4 )
postscript? ( >=app-text/libspectre-0.2:= )
spell? ( >=app-text/gspell-1.6.0:= )
tiff? ( >=media-libs/tiff-3.6:0= )
xps? ( >=app-text/libgxps-0.2.1:= )
"
RDEPEND="${COMMON_DEPEND}
gnome-base/gvfs
gnome-base/librsvg
|| (
>=x11-themes/adwaita-icon-theme-2.17.1
>=x11-themes/hicolor-icon-theme-0.10 )
"
DEPEND="${COMMON_DEPEND}
app-text/docbook-xml-dtd:4.3
dev-libs/appstream-glib
dev-util/gdbus-codegen
dev-util/glib-utils
>=dev-util/gtk-doc-am-1.13
>=dev-util/intltool-0.35
dev-util/itstool
sys-devel/gettext
virtual/pkgconfig
app-text/yelp-tools
"
# eautoreconf needs:
# app-text/yelp-tools

PATCHES=(
"${FILESDIR}"/3.30.2-internal-synctex.patch # don't automagically link to synctex from texlive-core - always use internal copy of this small parser for now; requires eautoreconf
)

src_prepare() {
gnome2_src_prepare

# Do not depend on adwaita-icon-theme, bug #326855, #391859
# https://gitlab.freedesktop.org/xdg/default-icon-theme/issues/7
sed -e 's/adwaita-icon-theme >= $ADWAITA_ICON_THEME_REQUIRED//g' \
-i configure || die "sed failed"
}

src_configure() {
gnome2_src_configure \
--disable-static \
--enable-pdf \
--enable-comics \
--enable-thumbnailer \
--with-platform=gnome \
--enable-dbus \
$(use_enable djvu) \
$(use_enable dvi) \
$(use_enable gstreamer multimedia) \
$(use_enable gnome libgnome-desktop) \
$(use_with gnome-keyring keyring) \
$(use_enable introspection) \
$(use_enable nautilus) \
$(use_enable nsplugin browser-plugin) \
$(use_enable postscript ps) \
$(use_with spell gspell) \
$(use_enable t1lib) \
$(use_enable tiff) \
$(use_enable xps) \
BROWSER_PLUGIN_DIR="${EPREFIX}"/usr/$(get_libdir)/nsbrowser/plugins \
--with-systemduserunitdir="$(systemd_get_userunitdir)"
}

0 comments on commit af12932

Please sign in to comment.