Skip to content

Commit

Permalink
dev-perl/Net-DNS-SEC: Bump to version 1.30.0
Browse files Browse the repository at this point in the history
- Communicate optdeps softly

Upstream:
- Fix tests failing in some installation configurations of Net::DNS

Package-Manager: Portage-2.3.14, Repoman-2.3.6
  • Loading branch information
kentfredric committed Dec 5, 2017
1 parent 1503f1a commit af455a0
Show file tree
Hide file tree
Showing 3 changed files with 76 additions and 12 deletions.
1 change: 1 addition & 0 deletions dev-perl/Net-DNS-SEC/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST Net-DNS-SEC-1.02.tar.gz 35915 BLAKE2B 164cd7399c98cd32dc6293feb3d331e413319c16027bed806ee7b7beb9fb60b61ceb74991a124174fd35a299a9a6d2484de3433e88393721df08175d333197cf SHA512 cbbf0a4eb6948047a991cf473b0824cfa69c7f7e2d07190fbc9fe62be79106635ebfc02ab02a559079f2936ff354f5ff9275fd16cf37d7bc2d78a87cf0b103b0
DIST Net-DNS-SEC-1.03.tar.gz 35605 BLAKE2B 8d7ab450986b4cc4f7d31ae50f3efdeb56e6a437269ff6a54d5ece26a863405f12faf16e52aff2ba991d6e8320ed5b5cd3d07fdee20a5b3db7da4683e02c6243 SHA512 17d9f2125b9ed687791941ea777927daf8cfe4a6a379d02cda499fb01a71606b1c01154a3d4f2f2ffb70f5a658aaf02e64c8e5cc308de8c8e0cc543271ee7bce
70 changes: 70 additions & 0 deletions dev-perl/Net-DNS-SEC/Net-DNS-SEC-1.30.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,70 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

DIST_AUTHOR=NLNETLABS
DIST_VERSION=1.03
inherit perl-module

DESCRIPTION="DNSSEC extensions to Net::DNS"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
IUSE="test"

RDEPEND="
>=dev-perl/Crypt-OpenSSL-Bignum-0.50.0
>=dev-perl/Crypt-OpenSSL-RSA-0.280.0
>=virtual/perl-File-Spec-0.860.0
>=virtual/perl-MIME-Base64-2.110.0
>=dev-perl/Net-DNS-1.10.0
>=virtual/perl-Digest-SHA-5.230.0
"
DEPEND="${RDEPEND}
virtual/perl-ExtUtils-MakeMaker
test? (
>=virtual/perl-Test-Simple-0.470.0
)
"

optdep_installed() {
local chr=" "
has_version "${1}" && chr="I"
printf '[%s] %s\n' "${chr}" "${1}";
}

optdep_notice() {
local i
elog "This package has several modules which may require additional dependencies"
elog "to use. However, it is up to you to install them separately if you need this"
elog "optional functionality:"

elog " - Support for DSA signature algorithm via Net::DNS::SEC::DSA"
elog " $(optdep_installed ">=dev-perl/Crypt-OpenSSL-DSA-0.150.0")"
elog
elog " - Support for ECDSA signatures via Net::DNS::SEC::ECDSA"
elog " $(optdep_installed ">=dev-perl/Crypt-OpenSSL-EC-1.10.0")"
elog " $(optdep_installed ">=dev-perl/Crypt-OpenSSL-ECDSA-0.60.0")"
elog
elog " - Support for reading Private Keys in creation of Net::DNS::RR::RRSIG"
elog " objects"
elog " $(optdep_installed ">=dev-perl/Crypt-OpenSSL-Random-0.100.0")"
elog
elog " - Support for ECC-GOST signatures via Net::DNS::SEC::ECCGOST"
elog " $(optdep_installed ">=dev-perl/Crypt-OpenSSL-EC-1.10.0")"
elog " $(optdep_installed ">=dev-perl/Crypt-OpenSSL-ECDSA-0.60.0")"
elog " $(optdep_installed ">=dev-perl/Digest-GOST-0.60.0")"
}

src_test() {
optdep_notice
elog
elog "This module will perform additional tests if these dependencies are"
elog "pre-installed"
perl-module_src_test
}

pkg_postinst() {
use test || optdep_notice
}
17 changes: 5 additions & 12 deletions dev-perl/Net-DNS-SEC/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -7,19 +7,12 @@
</maintainer>
<upstream>
<remote-id type="cpan">Net-DNS-SEC</remote-id>
<remote-id type="cpan-module">Net::DNS::Keyset</remote-id>
<remote-id type="cpan-module">Net::DNS::RR::CDNSKEY</remote-id>
<remote-id type="cpan-module">Net::DNS::RR::CDS</remote-id>
<remote-id type="cpan-module">Net::DNS::RR::DLV</remote-id>
<remote-id type="cpan-module">Net::DNS::RR::DNSKEY</remote-id>
<remote-id type="cpan-module">Net::DNS::RR::DS</remote-id>
<remote-id type="cpan-module">Net::DNS::RR::KEY</remote-id>
<remote-id type="cpan-module">Net::DNS::RR::NSEC</remote-id>
<remote-id type="cpan-module">Net::DNS::RR::NSEC3</remote-id>
<remote-id type="cpan-module">Net::DNS::RR::NSEC3PARAM</remote-id>
<remote-id type="cpan-module">Net::DNS::RR::RRSIG</remote-id>
<remote-id type="cpan-module">Net::DNS::RR::SIG</remote-id>
<remote-id type="cpan-module">Net::DNS::SEC</remote-id>
<remote-id type="cpan-module">Net::DNS::SEC::DSA</remote-id>
<remote-id type="cpan-module">Net::DNS::SEC::ECCGOST</remote-id>
<remote-id type="cpan-module">Net::DNS::SEC::ECDSA</remote-id>
<remote-id type="cpan-module">Net::DNS::SEC::Keyset</remote-id>
<remote-id type="cpan-module">Net::DNS::SEC::Private</remote-id>
<remote-id type="cpan-module">Net::DNS::SEC::RSA</remote-id>
</upstream>
</pkgmetadata>

0 comments on commit af455a0

Please sign in to comment.