Skip to content

Commit

Permalink
app-admin/awscli: Bump to 1.27.158
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Jun 22, 2023
1 parent 220e28f commit af4c1e7
Show file tree
Hide file tree
Showing 2 changed files with 81 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-admin/awscli/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -7,3 +7,4 @@ DIST aws-cli-1.27.154.gh.tar.gz 2436624 BLAKE2B 79f55cc001ba3286a125002304c350db
DIST aws-cli-1.27.155.gh.tar.gz 2437165 BLAKE2B 59a757940ec6999567f1744d147078acbb3e0bf02390e40452d8a9ad04748d29d88e8bca70a666a5d7ed33d947f8a77433028033d732ae962f927dc42a799d9e SHA512 6d1cb53fb2e7b9b724bf9ecbbaac3549fd44d33134f1060a52d67867cbca935304bce440f99c92adedbd15b2295a2753df79e83b660b0d415a95ee10c1cc52d7
DIST aws-cli-1.27.156.gh.tar.gz 2437549 BLAKE2B dd98b3605986fc9d832604bea3dc1d22daf2e5ae08637367023337dca349706edf10ad7702d914600ec02c7d137d29a9eb13d95ddaf99e402507fd45e9bdb0eb SHA512 c932a11a1ed36219f5dc22a046fd9e7e8ca8229d266fe45c626ee2ff9e6608029a733d5b335e90b6d4a38fffa04a06d1a1f84bf0b827c65fb9edf5d2f0ff8b57
DIST aws-cli-1.27.157.gh.tar.gz 2437939 BLAKE2B 628de17b0f0203e48cdecc76a1ca0cdbf111224f652f650d5501677027c486faf2ea06d9c95321b6586d50f9e042698b1ba11696f3a5ab2e0734aa004db9e9cc SHA512 87f4c790b0c49d353473fc577d6bd2568a2ecd6359a9e53165a2e14ce112113286b9f2bd34be83db219cd72c59e5dbc8098aef3e8fa98297da44f21865dffd9e
DIST aws-cli-1.27.158.gh.tar.gz 2438757 BLAKE2B 303e39d1d30f6593af1a9cb263f11b74e1d7b120a9c3c438c4b4278ff945758130179df282ade40893aea1805758ff3baa29ef7009c08a2dbc2ddf28eb278650 SHA512 04292c37e7b7338cb0103aa165d0c09f67a408711a856758dc999b976cfe6b15e50d0a57fb8ddd7ddd3f697e6b85f84a3565d993d7cb6497fc0ebd74b31e3b45
80 changes: 80 additions & 0 deletions app-admin/awscli/awscli-1.27.158.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,80 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..11} )

inherit bash-completion-r1 distutils-r1 multiprocessing

MY_P=aws-cli-${PV}
DESCRIPTION="Universal Command Line Environment for AWS"
HOMEPAGE="
https://github.com/aws/aws-cli/
https://pypi.org/project/awscli/
"
SRC_URI="
https://github.com/aws/aws-cli/archive/${PV}.tar.gz
-> ${MY_P}.gh.tar.gz
"
S=${WORKDIR}/${MY_P}

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"

# botocore is x.(y+2).z
BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
RDEPEND="
>=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
dev-python/colorama[${PYTHON_USEDEP}]
dev-python/docutils[${PYTHON_USEDEP}]
dev-python/rsa[${PYTHON_USEDEP}]
>=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
!app-admin/awscli-bin
"
BDEPEND="
test? (
dev-python/pytest-forked[${PYTHON_USEDEP}]
dev-python/pytest-xdist[${PYTHON_USEDEP}]
)
"

distutils_enable_tests pytest

src_prepare() {
# do not rely on bundled deps in botocore (sic!)
find -name '*.py' -exec sed -i \
-e 's:from botocore[.]vendored import:import:' \
-e 's:from botocore[.]vendored[.]:from :' \
{} + || die
# strip overzealous upper bounds on requirements
sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
distutils-r1_src_prepare
}

python_test() {
local EPYTEST_DESELECT=(
# TODO
tests/functional/eks/test_kubeconfig.py::TestKubeconfigLoader::test_load_simple
tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_env_only
tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_existing
tests/unit/customizations/eks/test_kubeconfig.py::TestKubeconfigValidator::test_valid
)

# integration tests require AWS credentials and Internet access
epytest tests/{functional,unit} -n "$(makeopts_jobs)" --forked
}

python_install_all() {
newbashcomp bin/aws_bash_completer aws

insinto /usr/share/zsh/site-functions
newins bin/aws_zsh_completer.sh _aws

distutils-r1_python_install_all

rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
}

0 comments on commit af4c1e7

Please sign in to comment.