Skip to content

Commit

Permalink
x11-misc/xosview: Bump to version 1.22
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Lars Wendler <[email protected]>
  • Loading branch information
Lars Wendler committed May 4, 2020
1 parent 26193c2 commit af5f0a1
Show file tree
Hide file tree
Showing 2 changed files with 58 additions and 0 deletions.
1 change: 1 addition & 0 deletions x11-misc/xosview/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST xosview-1.20.tar.gz 146373 BLAKE2B 7d53b5f2f8ce463917a1cfa65eedb60c835c6d530a19ede6bba6bfe295a01582861ca3fb7513b9a8590d9fe5111779a38db8723a2e38c911f002bce88bfc95f6 SHA512 25cd6a8cdaaff9121f0e8de7a1799d4c2706c5eb1111f3b3f8427b16e45a333fb4c675a1dec2ef6b40773e83124ff27eacc82f2b9eb6c836855930cbbf08957a
DIST xosview-1.21.tar.gz 146428 BLAKE2B 899e0cb68489bd02e035765f8f33424d41996b80a7c16651f60a2e46538cf4eac1a9377342c2ed4f35da6cb00aa3961e34802c77fe26e4743a23e2d3dc443484 SHA512 9c42247d9e9b391b94c18ffc8c38df414f5293b7426aa57d3b357e680b02e9a3a2b332299905f2f529d488c23590e957cad9e088ddf753a6904905e2dff8074b
DIST xosview-1.22.tar.gz 146459 BLAKE2B 7f4920b5b5a765f574694ab64e1d34ad6dbc33893cb816bb73119b4f72b7d23900528cb0db9302b24d20d7b8ce1738ce2d00be572c9fd4b391724f277afb02d5 SHA512 9bf37f557d9c07a300f6f9c21e197d25d4c5a4bb6e67b40af9c44a3159ea5010d7ba5bf427a9cec9729fa423da132a1364d0ac7027e9bc9bcd33f490d9e8282a
57 changes: 57 additions & 0 deletions x11-misc/xosview/xosview-1.22.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,57 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit toolchain-funcs xdg-utils

DESCRIPTION="X11 operating system viewer"
HOMEPAGE="http://www.pogo.org.uk/~mark/xosview/"
SRC_URI="http://www.pogo.org.uk/~mark/${PN}/releases/${P}.tar.gz"

LICENSE="GPL-2 BSD"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
IUSE="suid"

COMMON_DEPS="x11-libs/libX11
x11-libs/libXpm
x11-libs/libXt"
RDEPEND="${COMMON_DEPS}
media-fonts/font-misc-misc"
DEPEND="${COMMON_DEPS}
x11-base/xorg-proto"

DOCS=( CHANGES README.linux TODO )

src_prepare() {
default

sed -i -e 's:lib/X11/app:share/X11/app:g' -i ${PN}.1 || die
sed -i -e "s:Git:${PV}:g" ${PN}.cc || die
tc-export CXX
}

src_compile() {
emake OPTFLAGS=''
}

src_install() {
emake PREFIX="${D}/usr" install
use suid && fperms 4755 /usr/bin/${PN}
insinto /usr/share/X11/app-defaults
newins Xdefaults XOsview
}

pkg_postinst() {
xdg_desktop_database_update

if ! use suid ; then
ewarn "If you want to use serial meters ${PN} needs to be executed as root."
ewarn "Please see ${EPREFIX}/usr/share/doc/${PF}/README.linux for details."
fi
}

pkg_postrm() {
xdg_desktop_database_update
}

0 comments on commit af5f0a1

Please sign in to comment.