Skip to content

Commit

Permalink
dev-lang/moarvm: Fix installation to /lib re bug #639538
Browse files Browse the repository at this point in the history
This fixes the installation of libmoar.so to use /usr/lib64 etc
instead of /lib64

This additionally fixes the issue where the installation to /lib64
under EAPI7, for some reason, results in no installation of the .so,
as mentioned in bug #504720

Closes: https://bugs.gentoo.org/639538
Bug: https://bugs.gentoo.org/504720
Package-Manager: Portage-2.3.66, Repoman-2.3.16
Signed-off-by: Kent Fredric <[email protected]>
  • Loading branch information
kentfredric committed Aug 6, 2019
1 parent e9b4191 commit af79c1b
Show file tree
Hide file tree
Showing 9 changed files with 105 additions and 73 deletions.
Original file line number Diff line number Diff line change
Expand Up @@ -38,12 +38,16 @@ RESTRICT=test

src_configure() {
use doc && DOCS+=( docs/* )
local prefix="${EROOT%/}/usr"
local libdir="${EROOT%/}/usr/$(get_libdir)"
einfo "--prefix '${prefix}'"
einfo "--libdir '${libdir}'"
local myconfigargs=(
"--prefix=/usr"
"--prefix=${prefix}"
"--has-libuv"
"--has-libatomic_ops"
"--has-libffi"
"--libdir=$(get_libdir)"
"--libdir=${libdir}"
"--compiler=$(usex clang clang gcc)"
"$(usex asan --asan)"
"$(usex debug --debug --no-debug)"
Expand Down
57 changes: 0 additions & 57 deletions dev-lang/moarvm/moarvm-2018.06.ebuild

This file was deleted.

Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2018 Gentoo Foundation
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
Expand Down Expand Up @@ -38,12 +38,16 @@ RESTRICT=test

src_configure() {
use doc && DOCS+=( docs/* )
local prefix="${EROOT%/}/usr"
local libdir="${EROOT%/}/usr/$(get_libdir)"
einfo "--prefix '${prefix}'"
einfo "--libdir '${libdir}'"
local myconfigargs=(
"--prefix=/usr"
"--prefix=${prefix}"
"--has-libuv"
"--has-libatomic_ops"
"--has-libffi"
"--libdir=$(get_libdir)"
"--libdir=${libdir}"
"--compiler=$(usex clang clang gcc)"
"$(usex asan --asan)"
"$(usex debug --debug --no-debug)"
Expand Down
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2018 Gentoo Authors
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
Expand Down Expand Up @@ -38,12 +38,16 @@ RESTRICT=test

src_configure() {
use doc && DOCS+=( docs/* )
local prefix="${EROOT%/}/usr"
local libdir="${EROOT%/}/usr/$(get_libdir)"
einfo "--prefix '${prefix}'"
einfo "--libdir '${libdir}'"
local myconfigargs=(
"--prefix=/usr"
"--prefix=${prefix}"
"--has-libuv"
"--has-libatomic_ops"
"--has-libffi"
"--libdir=$(get_libdir)"
"--libdir=${libdir}"
"--compiler=$(usex clang clang gcc)"
"$(usex asan --asan)"
"$(usex debug --debug --no-debug)"
Expand Down
61 changes: 61 additions & 0 deletions dev-lang/moarvm/moarvm-2018.12-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,61 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit flag-o-matic

MY_PN="MoarVM"
if [[ ${PV} == "9999" ]]; then
EGIT_REPO_URI="https://github.com/${MY_PN}/${MY_PN}.git"
inherit git-r3
KEYWORDS=""
S="${WORKDIR}/${P}"
else
SRC_URI="http://moarvm.org/releases/${MY_PN}-${PV}.tar.gz"
KEYWORDS="~amd64 ~x86"
S="${WORKDIR}/${MY_PN}-${PV}"
fi

DESCRIPTION="A 6model-based VM for NQP and Rakudo Perl 6"
HOMEPAGE="http://moarvm.org"
LICENSE="Artistic-2"
SLOT="0"
IUSE="asan clang debug doc +jit static-libs optimize ubsan"

RDEPEND="dev-libs/libatomic_ops
dev-libs/libuv
dev-lang/lua:=
virtual/libffi"
DEPEND="${RDEPEND}
clang? ( >=sys-devel/clang-3.1 )
dev-lang/perl"

DOCS=( CREDITS README.markdown )

# Tests are conducted via nqp
RESTRICT=test

src_configure() {
use doc && DOCS+=( docs/* )
local prefix="${EROOT%/}/usr"
local libdir="${EROOT%/}/usr/$(get_libdir)"
einfo "--prefix '${prefix}'"
einfo "--libdir '${libdir}'"
local myconfigargs=(
"--prefix=${prefix}"
"--has-libuv"
"--has-libatomic_ops"
"--has-libffi"
"--libdir=${libdir}"
"--compiler=$(usex clang clang gcc)"
"$(usex asan --asan)"
"$(usex debug --debug --no-debug)"
"$(usex optimize --optimize= --no-optimize)"
"$(usex static-libs --static)"
"$(usex ubsan --ubsan)"
)
use optimize && filter-flags '-O*'

perl Configure.pl "${myconfigargs[@]}" || die
}
Original file line number Diff line number Diff line change
Expand Up @@ -38,12 +38,16 @@ RESTRICT=test

src_configure() {
use doc && DOCS+=( docs/* )
local prefix="${EROOT%/}/usr"
local libdir="${EROOT%/}/usr/$(get_libdir)"
einfo "--prefix '${prefix}'"
einfo "--libdir '${libdir}'"
local myconfigargs=(
"--prefix=/usr"
"--prefix=${prefix}"
"--has-libuv"
"--has-libatomic_ops"
"--has-libffi"
"--libdir=$(get_libdir)"
"--libdir=${libdir}"
"--compiler=$(usex clang clang gcc)"
"$(usex asan --asan)"
"$(usex debug --debug --no-debug)"
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -43,12 +43,16 @@ PATCHES="${FILESDIR}/fix-quoting.patch"

src_configure() {
use doc && DOCS+=( docs/* )
local prefix="${EROOT%/}/usr"
local libdir="${EROOT%/}/usr/$(get_libdir)"
einfo "--prefix '${prefix}'"
einfo "--libdir '${libdir}'"
local myconfigargs=(
"--prefix" "/usr"
"--prefix" "${prefix}"
"--has-libuv"
"--has-libatomic_ops"
"--has-libffi"
"--libdir" "$(get_libdir)"
"--libdir" "${libdir}"
"--compiler" "$(usex clang clang gcc)"
"$(usex asan --asan)"
"$(usex debug --debug --no-debug)"
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -49,12 +49,16 @@ src_prepare() {

src_configure() {
use doc && DOCS+=( docs/* )
local prefix="${EROOT}/usr"
local libdir="${EROOT}/usr/$(get_libdir)"
einfo "--prefix '${prefix}'"
einfo "--libdir '${libdir}'"
local myconfigargs=(
"--prefix" "/usr"
"--prefix" "${prefix}"
"--has-libuv"
"--has-libatomic_ops"
"--has-libffi"
"--libdir" "$(get_libdir)"
"--libdir" "${libdir}"
"--compiler" "$(usex clang clang gcc)"
"$(usex asan --asan)"
"$(usex debug --debug --no-debug)"
Expand Down
8 changes: 6 additions & 2 deletions dev-lang/moarvm/moarvm-9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -49,12 +49,16 @@ src_prepare() {

src_configure() {
use doc && DOCS+=( docs/* )
local prefix="${EROOT}/usr"
local libdir="${EROOT}/usr/$(get_libdir)"
einfo "--prefix '${prefix}'"
einfo "--libdir '${libdir}'"
local myconfigargs=(
"--prefix" "/usr"
"--prefix" "${prefix}"
"--has-libuv"
"--has-libatomic_ops"
"--has-libffi"
"--libdir" "$(get_libdir)"
"--libdir" "${libdir}"
"--compiler" "$(usex clang clang gcc)"
"$(usex asan --asan)"
"$(usex debug --debug --no-debug)"
Expand Down

0 comments on commit af79c1b

Please sign in to comment.