Skip to content

Commit

Permalink
app-office/kexi: Let cmake detect PostgreSQL 12
Browse files Browse the repository at this point in the history
Let's do something useful with that revbump.

Closes: https://bugs.gentoo.org/692924
Package-Manager: Portage-2.3.73, Repoman-2.3.17
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
a17r committed Aug 27, 2019
1 parent 5f93871 commit af7adfc
Show file tree
Hide file tree
Showing 2 changed files with 110 additions and 0 deletions.
24 changes: 24 additions & 0 deletions app-office/kexi/files/kexi-3.2.0-postgresql-9.12.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,24 @@
From 88ac2b4a1386bc05f0e3965f31949039eaf4d3ff Mon Sep 17 00:00:00 2001
From: Pino Toscano <[email protected]>
Date: Sat, 25 May 2019 07:12:17 +0200
Subject: cmake: find PostgreSQL 12

---
cmake/modules/FindPostgreSQL.cmake | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/cmake/modules/FindPostgreSQL.cmake b/cmake/modules/FindPostgreSQL.cmake
index 56e6e56..1579be0 100644
--- a/cmake/modules/FindPostgreSQL.cmake
+++ b/cmake/modules/FindPostgreSQL.cmake
@@ -86,7 +86,7 @@ set(PostgreSQL_LIBRARY_DIR_MESSAGE "Set the PostgreSQL_LIBRARY_DIR cmake cache e
set(PostgreSQL_ROOT_DIR_MESSAGE "Set the PostgreSQL_ROOT system variable to where PostgreSQL is found on the machine E.g C:/Program Files/PostgreSQL/8.4")

set(PostgreSQL_KNOWN_VERSIONS ${PostgreSQL_ADDITIONAL_VERSIONS}
- "11" "10" "9.6" "9.5" "9.4" "9.3" "9.2" "9.1" "9.0" "8.4" "8.3" "8.2" "8.1" "8.0")
+ "12" "11" "10" "9.6" "9.5" "9.4" "9.3" "9.2" "9.1" "9.0" "8.4" "8.3" "8.2" "8.1" "8.0")

# Define additional search paths for root directories.
foreach (suffix ${PostgreSQL_KNOWN_VERSIONS} )
--
cgit v1.1
86 changes: 86 additions & 0 deletions app-office/kexi/kexi-3.2.0-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,86 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

# KDE_HANDBOOK="true"
KDE_TEST="forceoptional"
inherit kde5

DESCRIPTION="Visual database applications creator"
HOMEPAGE="https://kde.org/applications/office/kexi/ http://www.kexi-project.org/"
[[ ${KDE_BUILD_TYPE} != live ]] && SRC_URI="mirror://kde/stable/${PN}/src/${P}.tar.xz"

KEYWORDS="amd64 x86"
IUSE="debug experimental marble mdb mysql postgres sqlite webkit"

BDEPEND="sys-devel/gettext"
DEPEND="
$(add_frameworks_dep breeze-icons-rcc)
$(add_frameworks_dep karchive)
$(add_frameworks_dep kcodecs)
$(add_frameworks_dep kcompletion)
$(add_frameworks_dep kconfig)
$(add_frameworks_dep kconfigwidgets)
$(add_frameworks_dep kcoreaddons)
$(add_frameworks_dep kcrash)
$(add_frameworks_dep kguiaddons)
$(add_frameworks_dep ki18n)
$(add_frameworks_dep kiconthemes)
$(add_frameworks_dep kio)
$(add_frameworks_dep kitemviews)
$(add_frameworks_dep ktexteditor)
$(add_frameworks_dep ktextwidgets)
$(add_frameworks_dep kwidgetsaddons)
$(add_frameworks_dep kxmlgui)
$(add_qt_dep designer)
$(add_qt_dep qtgui)
$(add_qt_dep qtnetwork)
$(add_qt_dep qtprintsupport)
$(add_qt_dep qtwidgets)
$(add_qt_dep qtxml)
>=dev-db/kdb-3.1.0-r1:5=[debug?,mysql?,postgres?,sqlite?]
>=dev-libs/kproperty-3.1.0:5=
>=dev-libs/kreport-3.1.0:5=[scripting]
marble? ( $(add_kdeapps_dep marble) )
mdb? (
dev-libs/glib:2
virtual/libiconv
)
mysql? ( dev-db/mysql-connector-c:= )
postgres? (
dev-db/postgresql:*
dev-libs/libpqxx
)
webkit? ( >=dev-qt/qtwebkit-5.212.0_pre20180120:5 )
"
RDEPEND="${DEPEND}"

PATCHES=(
"${FILESDIR}"/${P}-missing-header.patch
"${FILESDIR}"/${P}-postgresql-9.12.patch
)

src_prepare() {
if ! use webkit; then
punt_bogus_dep Qt5 WebKit
punt_bogus_dep Qt5 WebKitWidgets
fi

kde5_src_prepare
}

src_configure() {
local mycmakeargs=(
-DKEXI_MIGRATEMANAGER_DEBUG=$(usex debug)
-DKEXI_AUTORISE_TABBED_TOOLBAR=$(usex experimental)
-DKEXI_SCRIPTS_SUPPORT=$(usex experimental)
$(cmake-utils_use_find_package marble KexiMarble)
$(cmake-utils_use_find_package mdb GLIB2)
$(cmake-utils_use_find_package mysql MySQL)
$(cmake-utils_use_find_package postgres PostgreSQL)
)
use experimental && mycmakeargs+=( -DKEXI_SCRIPTING_DEBUG=$(usex debug) )

kde5_src_configure
}

0 comments on commit af7adfc

Please sign in to comment.