Skip to content

Commit

Permalink
games-fps/gzdoom: Backport my local vs system headers fix
Browse files Browse the repository at this point in the history
Signed-off-by: James Le Cuirot <[email protected]>
  • Loading branch information
chewi committed Aug 7, 2023
1 parent 7c37c95 commit afdcd6a
Show file tree
Hide file tree
Showing 2 changed files with 108 additions and 1 deletion.
106 changes: 106 additions & 0 deletions games-fps/gzdoom/files/gzdoom-4.10.0-headers.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,106 @@
From b95dbaf914618cccaeaa95c650e02be669e477f8 Mon Sep 17 00:00:00 2001
From: James Le Cuirot <[email protected]>
Date: Sat, 1 Jul 2023 13:36:48 +0100
Subject: [PATCH] Ensure local headers are used over system headers to avoid
breakage

types.h was being picked up from webp rather than locally due to the
`include_directories` call for GTK (and therefore its -I arguments)
coming before the same call for the local sources. webp can be pulled in
via GTK -> gdk-pixbuf -> tiff -> webp.

This can be avoided by specifying `SYSTEM` or `BEFORE` as appropriate
when calling `include_directories`. I have done both for good measure.
---
src/CMakeLists.txt | 18 ++++++++++--------
tools/zipdir/CMakeLists.txt | 2 +-
2 files changed, 11 insertions(+), 9 deletions(-)

diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index cf254ad6a..b4d06f9ce 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -97,7 +97,7 @@ else()
if( NOT DYN_GTK )
set( PROJECT_LIBRARIES ${PROJECT_LIBRARIES} ${GTK3_LIBRARIES} )
endif()
- include_directories( ${GTK3_INCLUDE_DIRS} )
+ include_directories( SYSTEM ${GTK3_INCLUDE_DIRS} )
link_directories( ${GTK3_LIBRARY_DIRS} )
else()
pkg_check_modules( GTK2 gtk+-2.0 )
@@ -105,7 +105,7 @@ else()
if( NOT DYN_GTK )
set( PROJECT_LIBRARIES ${PROJECT_LIBRARIES} ${GTK2_LIBRARIES} )
endif()
- include_directories( ${GTK2_INCLUDE_DIRS} )
+ include_directories( SYSTEM ${GTK2_INCLUDE_DIRS} )
link_directories( ${GTK2_LIBRARY_DIRS} )
else()
set( NO_GTK ON )
@@ -132,7 +132,7 @@ else()
# Non-Windows version also needs SDL except native OS X backend
if( NOT APPLE OR NOT OSX_COCOA_BACKEND )
find_package( SDL2 REQUIRED )
- include_directories( "${SDL2_INCLUDE_DIR}" )
+ include_directories( SYSTEM "${SDL2_INCLUDE_DIR}" )
set( PROJECT_LIBRARIES ${PROJECT_LIBRARIES} "${SDL2_LIBRARY}" )
endif()

@@ -143,7 +143,7 @@ if( NOT NO_OPENAL )
find_package( OpenAL )
mark_as_advanced(CLEAR OPENAL_INCLUDE_DIR)
if( OPENAL_INCLUDE_DIR )
- include_directories( ${OPENAL_INCLUDE_DIR} )
+ include_directories( SYSTEM ${OPENAL_INCLUDE_DIR} )
mark_as_advanced(CLEAR OPENAL_LIBRARY)
if( OPENAL_LIBRARY )
set( PROJECT_LIBRARIES ${OPENAL_LIBRARY} ${PROJECT_LIBRARIES} )
@@ -373,17 +373,17 @@ endif()

if( VPX_FOUND )
add_definitions( "-DUSE_LIBVPX=1" )
- include_directories( "${VPX_INCLUDE_DIR}" )
+ include_directories( SYSTEM "${VPX_INCLUDE_DIR}" )
set( PROJECT_LIBRARIES ${PROJECT_LIBRARIES} ${VPX_LIBRARIES} )
else()
message( SEND_ERROR "Could not find libvpx" )
endif()

-include_directories( "${ZLIB_INCLUDE_DIR}" "${BZIP2_INCLUDE_DIR}" "${LZMA_INCLUDE_DIR}" "${JPEG_INCLUDE_DIR}" "${ZMUSIC_INCLUDE_DIR}" "${DRPC_INCLUDE_DIR}")
+include_directories( SYSTEM "${ZLIB_INCLUDE_DIR}" "${BZIP2_INCLUDE_DIR}" "${LZMA_INCLUDE_DIR}" "${JPEG_INCLUDE_DIR}" "${ZMUSIC_INCLUDE_DIR}" "${DRPC_INCLUDE_DIR}")

if( ${HAVE_VM_JIT} )
add_definitions( -DHAVE_VM_JIT )
- include_directories( "${ASMJIT_INCLUDE_DIR}" )
+ include_directories( SYSTEM "${ASMJIT_INCLUDE_DIR}" )
set( PROJECT_LIBRARIES ${PROJECT_LIBRARIES} "${ASMJIT_LIBRARIES}")
endif()

@@ -1243,7 +1243,9 @@ endif()

target_link_libraries( zdoom ${PROJECT_LIBRARIES} gdtoa lzma ${ZMUSIC_LIBRARIES} )

-include_directories( .
+include_directories(
+ BEFORE
+ .
common/audio/sound
common/audio/music
common/2d
diff --git a/tools/zipdir/CMakeLists.txt b/tools/zipdir/CMakeLists.txt
index 65eb2fb72..762d9027f 100644
--- a/tools/zipdir/CMakeLists.txt
+++ b/tools/zipdir/CMakeLists.txt
@@ -1,7 +1,7 @@
cmake_minimum_required( VERSION 3.1.0 )

if( NOT CMAKE_CROSSCOMPILING )
- include_directories( "${ZLIB_INCLUDE_DIR}" "${BZIP2_INCLUDE_DIR}" "${LZMA_INCLUDE_DIR}" )
+ include_directories( SYSTEM "${ZLIB_INCLUDE_DIR}" "${BZIP2_INCLUDE_DIR}" "${LZMA_INCLUDE_DIR}" )
add_executable( zipdir
zipdir.c )
target_link_libraries( zipdir ${ZLIB_LIBRARIES} ${BZIP2_LIBRARIES} lzma )
--
2.41.0

3 changes: 2 additions & 1 deletion games-fps/gzdoom/gzdoom-4.10.0.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2022 Gentoo Authors
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8
Expand Down Expand Up @@ -31,6 +31,7 @@ S="${WORKDIR}/${PN}-g${PV}"
PATCHES=(
"${FILESDIR}"/${PN}-4.7.1-Introduce-the-BUILD_NONFREE-option.patch
"${FILESDIR}"/${P}-gcc-13.patch
"${FILESDIR}"/${P}-headers.patch
)

src_prepare() {
Expand Down

0 comments on commit afdcd6a

Please sign in to comment.