Skip to content

Commit

Permalink
media-fonts/terminus-font: bump up to 4.49.1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.19, Repoman-3.0.3
Signed-off-by: Sergei Trofimovich <[email protected]>
  • Loading branch information
Sergei Trofimovich committed Jun 5, 2021
1 parent 2fcc87c commit aff3727
Show file tree
Hide file tree
Showing 2 changed files with 95 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-fonts/terminus-font/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST terminus-font-4.49.1.tar.gz 648345 BLAKE2B 8c2edff7e57572361cf9a4907a165f8af69cbd5a3ae15817d02d43ab5134278ab64b269e6bd8c79d2107e5c8c51b58f07ab45c308891464cbc8e3e15767efadb SHA512 2e3a99960c459a453b5879bebbebeb653f0a22060177bf75c67bbeb7d32cfe1acce9e74a88fdc42e299b6dc402e0708552487abd26e80e985c7d6059b0d445a8
DIST terminus-font-4.49.tar.gz 648477 BLAKE2B 67bddaae88b7411381bce5e8fe5c1b0dab334a33f1371a33038556beffa779afec8706f27b156e5660bfab5b8b7aeda75267c68945e1be3b41dbea7e9345f164 SHA512 27d396e7fe399728b5e9228c901922588eab0b344ea438fcf98f18f80ce816d838a42d5a3da0b5644d895747bcbda0e30bb8dabf342c0439d1f6b51f7acf8496
94 changes: 94 additions & 0 deletions media-fonts/terminus-font/terminus-font-4.49.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,94 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{7,8,9,10} )
inherit font python-any-r1

DESCRIPTION="A clean fixed font for the console and X11"
HOMEPAGE="http://terminus-font.sourceforge.net/"
SRC_URI="mirror://sourceforge/project/${PN}/${PN}-$(ver_cut 1-2)/${P}.tar.gz"

LICENSE="OFL-1.1 GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
IUSE="a-like-o +center-tilde distinct-l otf +pcf +pcf-unicode-only +psf quote
ru-dv +ru-g ru-i ru-k"

DEPEND="app-arch/gzip
${PYTHON_DEPS}
virtual/awk
pcf? ( x11-apps/bdftopcf )"
RDEPEND=""

FONTDIR=/usr/share/fonts/terminus
FONT_CONF=( 75-yes-terminus.conf )
DOCS=( README README-BG AUTHORS CHANGES )

REQUIRED_USE="X? ( pcf )"

pkg_setup() {
python_setup
}

src_prepare() {
default

# Upstream patches. Some of them are suggested to be applied by default
# dv - de NOT like latin g, but like caps greek delta
# ve NOT like greek beta, but like caps latin B
# ge - ge NOT like "mirrored" latin s, but like caps greek gamma
# ka - small ka NOT like minimised caps latin K, but like small latin k
use a-like-o && eapply "${S}"/alt/ao2.diff
use center-tilde && eapply "${S}"/alt/td1.diff
use distinct-l && eapply "${S}"/alt/ll2.diff
use ru-i && eapply "${S}"/alt/ij1.diff
use ru-k && eapply "${S}"/alt/ka2.diff
use ru-dv && eapply "${S}"/alt/dv1.diff
use ru-g && eapply "${S}"/alt/ge2.diff
use quote && eapply "${S}"/alt/gq2.diff
}

src_configure() {
local configure_args=(
--prefix="${EPREFIX}"/usr
--psfdir="${EPREFIX}"/usr/share/consolefonts
--x11dir="${EPREFIX}"/${FONTDIR}
)
# selfwritten configure script
./configure "${configure_args[@]}" || die
}

src_compile() {
local args=(
$(usex psf 'psf psf-vgaw' '')
$(usex pcf 'pcf pcf-8bit' '')
$(usex otf otb '')
)
[[ ${#args[@]} -gt 0 ]] && emake "${args[@]}"
}

src_install() {
local args=(
$(usex psf 'install-psf install-psf-vgaw install-psf-ref' '')
$(usex pcf 'install-pcf' '')
$(usex otf 'install-otb' '')
)
# Set the CHECKDIR to a dummy location so we always get the same set of
# files installed regardless of what is in / or ROOT or wherever.
[[ ${#args[@]} -gt 0 ]] && emake DESTDIR="${D}" CHECKDIR="${D}" "${args[@]}"

# Remove trans files that the kbd package takes care of installing.
rm -f "${ED}"/usr/share/consoletrans/*.trans

if use pcf-unicode-only; then
# Only the ter-x* fonts are unicode (ISO-10646-1) based
rm -f "${ED}"/usr/share/fonts/terminus/ter-[0-9a-wy-z]* || die
fi

use otf && FONT_SUFFIX=otb
font_src_install

einstalldocs
}

0 comments on commit aff3727

Please sign in to comment.