forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-python/pycrdt-websocket: new package, add 0.12.7
This package is replacing the previous ypy-websocket. Signed-off-by: Benda Xu <[email protected]>
- Loading branch information
Showing
3 changed files
with
42 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1 @@ | ||
DIST pycrdt_websocket-0.12.7.tar.gz 16835 BLAKE2B 89df20112120e120dcb4ae827e5cf170853b670f71a4535e2575e013c93fc879dbf7fd1e7554ec455251316c1c79a6f476edf5dbf9e233dc1ec4892f1d5ed376 SHA512 1d3846c437a9d0c463b1bfddd15dea48d7a2d3b8f22b32949e38cb6d80efe6cfd37afda9a8075555298538619e4f3b163735191ac35bc6375470c8bac02a184d |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,12 @@ | ||
<?xml version="1.0" encoding="UTF-8"?> | ||
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd"> | ||
<pkgmetadata> | ||
<maintainer type="project"> | ||
<email>[email protected]</email> | ||
<name>Gentoo Science Project</name> | ||
</maintainer> | ||
<upstream> | ||
<remote-id type="pypi">pycrdt-websocket</remote-id> | ||
<remote-id type="github">jupyter-server/pycrdt-websocket</remote-id> | ||
</upstream> | ||
</pkgmetadata> |
29 changes: 29 additions & 0 deletions
29
dev-python/pycrdt-websocket/pycrdt-websocket-0.12.7.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,29 @@ | ||
# Copyright 1999-2024 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
|
||
DISTUTILS_USE_PEP517=hatchling | ||
PYTHON_COMPAT=( python3_{10..12} ) | ||
|
||
inherit distutils-r1 pypi | ||
|
||
DESCRIPTION="WebSocket connector for pycrdt" | ||
HOMEPAGE="https://github.com/jupyter-server/pycrdt-websocket" | ||
|
||
LICENSE="MIT" | ||
SLOT="0" | ||
KEYWORDS="~amd64" | ||
|
||
RDEPEND=">=dev-python/pycrdt-0.8.7[${PYTHON_USEDEP}] | ||
dev-python/aiosqlite[${PYTHON_USEDEP}]" | ||
BDEPEND="test? ( | ||
dev-python/uvicorn[${PYTHON_USEDEP}] | ||
)" | ||
|
||
# skip tests that depends on yjs not available in Gentoo | ||
EPYTEST_DESELECT=( | ||
tests/test_pycrdt_yjs.py::test_pycrdt_yjs | ||
) | ||
|
||
distutils_enable_tests pytest |