Skip to content

Commit

Permalink
media-libs/kvazaar: EAPI-6 bump and general cleanup
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.52, Repoman-2.3.12
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
a17r committed Nov 30, 2018
1 parent bbfd604 commit b01246d
Show file tree
Hide file tree
Showing 2 changed files with 39 additions and 53 deletions.
45 changes: 19 additions & 26 deletions media-libs/kvazaar/kvazaar-1.2.0.ebuild
Original file line number Diff line number Diff line change
@@ -1,45 +1,40 @@
# Copyright 1999-2018 Gentoo Foundation
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=5

SCM=""
EAPI=6

GREATEST_PV="1.2.1"

if [ "${PV#9999}" != "${PV}" ] ; then
SCM="git-r3"
if [[ ${PV} = *9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/ultravideo/kvazaar"
fi

inherit eutils multilib autotools multilib-minimal toolchain-funcs flag-o-matic ${SCM}

DESCRIPTION="An open-source HEVC encoder"
HOMEPAGE="http://ultravideo.cs.tut.fi/ https://github.com/ultravideo/kvazaar"

if [ "${PV#9999}" = "${PV}" ] ; then
else
SRC_URI="https://github.com/ultravideo/kvazaar/archive/v${PV}.tar.gz -> ${P}.tar.gz
test? ( https://github.com/silentbicycle/greatest/archive/v${GREATEST_PV}.tar.gz -> greatest-${GREATEST_PV}.tar.gz )"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
fi
inherit autotools flag-o-matic multilib-minimal toolchain-funcs

DESCRIPTION="Open-source HEVC encoder"
HOMEPAGE="http://ultravideo.cs.tut.fi/ https://github.com/ultravideo/kvazaar"

LICENSE="LGPL-2.1"
# subslot = libkvazaar major
SLOT="0/4"
IUSE="static-libs test"

DEPEND=""
RDEPEND="${DEPEND}"
REQUIRED_USE="test? ( static-libs )"

ASM_DEP=">=dev-lang/yasm-1.2.0"
DEPEND="${DEPEND}
RDEPEND=""
DEPEND="${RDEPEND}
abi_x86_32? ( ${ASM_DEP} )
abi_x86_64? ( ${ASM_DEP} )"
abi_x86_64? ( ${ASM_DEP} )
"

src_prepare() {
default
eautoreconf
if use test && [ "${PV#9999}" = "${PV}" ]; then
if use test && [[ ${PV} != *9999 ]]; then
# https://bugs.gentoo.org/show_bug.cgi?id=595932
rmdir "${S}/greatest" || die
mv "${WORKDIR}/greatest-${GREATEST_PV}" "${S}/greatest" || die
Expand All @@ -49,13 +44,11 @@ src_prepare() {
}

multilib_src_configure() {
ECONF_SOURCE="${S}" \
econf \
--disable-werror \
--docdir "/usr/share/doc/${PF}" \
$(use_enable static-libs static)
ECONF_SOURCE="${S}" econf \
--disable-werror \
$(use_enable static-libs static)
}

multilib_src_install_all() {
find "${ED}" -name '*.la' -delete
find "${ED}" -name '*.la' -delete || die
}
47 changes: 20 additions & 27 deletions media-libs/kvazaar/kvazaar-9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,45 +1,40 @@
# Copyright 1999-2017 Gentoo Foundation
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=5

SCM=""
EAPI=6

GREATEST_PV="1.2.1"

if [ "${PV#9999}" != "${PV}" ] ; then
SCM="git-r3"
if [[ ${PV} = *9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/ultravideo/kvazaar"
fi

inherit eutils multilib autotools multilib-minimal toolchain-funcs flag-o-matic ${SCM}

DESCRIPTION="An open-source HEVC encoder"
HOMEPAGE="http://ultravideo.cs.tut.fi/ https://github.com/ultravideo/kvazaar"

if [ "${PV#9999}" = "${PV}" ] ; then
else
SRC_URI="https://github.com/ultravideo/kvazaar/archive/v${PV}.tar.gz -> ${P}.tar.gz
test? ( https://github.com/silentbicycle/greatest/archive/v${GREATEST_PV}.tar.gz -> greatest-${GREATEST_PV}.tar.gz )"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
fi
inherit autotools flag-o-matic multilib-minimal toolchain-funcs

DESCRIPTION="Open-source HEVC encoder"
HOMEPAGE="http://ultravideo.cs.tut.fi/ https://github.com/ultravideo/kvazaar"

LICENSE="LGPL-2.1"
# subslot = libkvazaar major
SLOT="0/4"
IUSE="static-libs test"

DEPEND=""
RDEPEND="${DEPEND}"
REQUIRED_USE="test? ( static-libs )"

ASM_DEP=">=dev-lang/yasm-1.2.0"
DEPEND="${DEPEND}
RDEPEND=""
DEPEND="${RDEPEND}
abi_x86_32? ( ${ASM_DEP} )
abi_x86_64? ( ${ASM_DEP} )"
abi_x86_64? ( ${ASM_DEP} )
"

src_prepare() {
default
eautoreconf
if use test && [ "${PV#9999}" = "${PV}" ]; then
if use test && [[ ${PV} != *9999 ]]; then
# https://bugs.gentoo.org/show_bug.cgi?id=595932
rmdir "${S}/greatest" || die
mv "${WORKDIR}/greatest-${GREATEST_PV}" "${S}/greatest" || die
Expand All @@ -49,13 +44,11 @@ src_prepare() {
}

multilib_src_configure() {
ECONF_SOURCE="${S}" \
econf \
--disable-werror \
--docdir "/usr/share/doc/${PF}" \
$(use_enable static-libs static)
ECONF_SOURCE="${S}" econf \
--disable-werror \
$(use_enable static-libs static)
}

multilib_src_install_all() {
find "${ED}" -name '*.la' -delete
find "${ED}" -name '*.la' -delete || die
}

0 comments on commit b01246d

Please sign in to comment.