Skip to content

Commit

Permalink
app-forensics/quickfuzz: tweak for derive-2.6
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.8, Repoman-2.3.3
  • Loading branch information
Sergei Trofimovich committed Aug 20, 2017
1 parent c544957 commit b02ce91
Show file tree
Hide file tree
Showing 2 changed files with 22 additions and 0 deletions.
Original file line number Diff line number Diff line change
@@ -0,0 +1,21 @@
diff --git a/src/DeriveShow.hs b/src/DeriveShow.hs
index c11dd03..40cc205 100644
--- a/src/DeriveShow.hs
+++ b/src/DeriveShow.hs
@@ -1,5 +1,5 @@
{-# LANGUAGE TemplateHaskell #-}
+{-# LANGUAGE StandaloneDeriving #-}
module DeriveShow where

-import Data.Derive.Show
import Data.DeriveTH
@@ -12,3 +12,2 @@ isArbInsName = isinsName ''Show
devShow :: Name -> Q [Dec]
-devShow = megaderive (derive makeShow) isArbInsName
-
+devShow = megaderive (\n -> [d| deriving instance Show $(return (ConT n)) |]) isArbInsName
--- a/QuickFuzz.cabal
+++ b/QuickFuzz.cabal
@@ -75,0 +75,1 @@ executable QuickFuzz
+ default-extensions: StandaloneDeriving

1 change: 1 addition & 0 deletions app-forensics/quickfuzz/quickfuzz-0.1_p20160920.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -98,6 +98,7 @@ DEPEND="${RDEPEND}
PATCHES=(
"${FILESDIR}"/${P}-ghc-8.0.2_rc1.patch
"${FILESDIR}"/${P}-directory-1.3.patch
"${FILESDIR}"/${P}-derive-2.6.patch
)

# $1 - target tarball name (not including extension)
Expand Down

0 comments on commit b02ce91

Please sign in to comment.