Skip to content

Commit

Permalink
dev-python/agate: Bump to 1.7.1
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Jan 5, 2023
1 parent 8257bb6 commit b0baf8c
Show file tree
Hide file tree
Showing 2 changed files with 46 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/agate/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST agate-1.6.3.tar.gz 202102 BLAKE2B b1a5624b4744b8f3ed266470da580cef2f2e1cf6159e1b33fcd461e4abd235c5e3fe0da35408a42c92fd4abf14a1f841a1ab9eb6cd31545d826a5223e85b4904 SHA512 e83a03c5a3e4b7fa9997030ce0d33e7b59b397e2ae07ee6a723eb7fb708a7fa8b8c4322dd034f42bf664bf2911d89731fd060e4ff33a237f83114a83312ac5ed
DIST agate-1.7.0.tar.gz 201944 BLAKE2B 4d3ac4cd0fc9f7e11175524652ba1bc13ee2b07e30115f807745387cde4ae9f49be3885dce93a2c3738d1fd4f6c005cb6db1103068510fe6caef635c04dd03e3 SHA512 75781ed3e46dbe5dd9a541bb3d968081b9776721b1518f232d551cbba8d792c43cab7ffccd9dfebd6303f167132808ccab409d8b92b3fc0c48a6314aec0b8c9d
DIST agate-1.7.1.tar.gz 202018 BLAKE2B 9df0f108f1ac47c1eb199015aedc903d72ce62a7d2c34198f0f287863527a2305c5682ef7dd385d130fd0eb3ce566e98978b9ef438858510e3aeae02a6345318 SHA512 e40df26f1e738b4c386f540d642f4fdb240dac5229032c6074977a67c7fdae7838c770703d93916e10741a9f2569ac9672165f8c8715b2567b2e5b926c7dabd5
45 changes: 45 additions & 0 deletions dev-python/agate/agate-1.7.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,45 @@
# Copyright 2021-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..11} )

inherit distutils-r1

DESCRIPTION="A Python data analysis library that is optimized for humans instead of machines"
HOMEPAGE="
https://github.com/wireservice/agate/
https://pypi.org/project/agate/
"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~riscv"

RDEPEND="
>=dev-python/pytimeparse-1.1.5[${PYTHON_USEDEP}]
>=dev-python/parsedatetime-2.1[${PYTHON_USEDEP}]
>=dev-python/Babel-2.0[${PYTHON_USEDEP}]
>=dev-python/isodate-0.5.4[${PYTHON_USEDEP}]
>=dev-python/pyicu-2.4.2[${PYTHON_USEDEP}]
>=dev-python/python-slugify-1.2.1[${PYTHON_USEDEP}]
>=dev-python/leather-0.3.3-r2[${PYTHON_USEDEP}]
"
BDEPEND="
test? (
dev-python/lxml[${PYTHON_USEDEP}]
)
"

distutils_enable_tests pytest
distutils_enable_sphinx docs \
dev-python/sphinx_rtd_theme

EPYTEST_DESELECT=(
# require specific locales
tests/test_data_types.py::TestDate::test_cast_format_locale
tests/test_data_types.py::TestDateTime::test_cast_format_locale
)

0 comments on commit b0baf8c

Please sign in to comment.