Skip to content

Commit

Permalink
dev-perl/B-OPCheck: -r bump for EAPI7 + CFLAGS love
Browse files Browse the repository at this point in the history
- EAPI7
- Ensure CFLAGS passed to make/compile

Package-Manager: Portage-2.3.100, Repoman-2.3.22
Signed-off-by: Kent Fredric <[email protected]>
  • Loading branch information
kentfredric committed Jul 3, 2020
1 parent f7aeb03 commit b0bc783
Showing 1 changed file with 38 additions and 0 deletions.
38 changes: 38 additions & 0 deletions dev-perl/B-OPCheck/B-OPCheck-0.320.0-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,38 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

DIST_AUTHOR=ETHER
DIST_VERSION=0.32
inherit perl-module

DESCRIPTION="PL_check hacks using Perl callbacks"

SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
RESTRICT="!test? ( test )"

RDEPEND="
>=dev-perl/B-Utils-0.80.0
virtual/perl-Carp
virtual/perl-Scalar-List-Utils
dev-perl/Scope-Guard
virtual/perl-XSLoader
"
BDEPEND="${RDEPEND}
virtual/perl-ExtUtils-MakeMaker
>=dev-perl/ExtUtils-Depends-0.302.0
test? (
virtual/perl-File-Spec
virtual/perl-Module-Metadata
virtual/perl-Test-Simple
)
"
src_compile() {
mymake=(
"OPTIMIZE=${CFLAGS}"
)
perl-module_src_compile
}

0 comments on commit b0bc783

Please sign in to comment.