Skip to content

Commit

Permalink
dev-java/gradle-bin: Bump to version 6.3 and EAPI 7
Browse files Browse the repository at this point in the history
Examples are no longer included but there is more documentation.

Closes: https://bugs.gentoo.org/633546
Bug: https://bugs.gentoo.org/683032
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: James Le Cuirot <[email protected]>
  • Loading branch information
chewi committed Apr 30, 2020
1 parent 6fdb4ad commit b0c814e
Show file tree
Hide file tree
Showing 2 changed files with 50 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-java/gradle-bin/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST gradle-3.3-all.zip 91388147 BLAKE2B 15539ec06cadcdaee9d54928381d5626bf06bae3251eb304fee095e6d0362f23759e99e3841dac2b9a1eed50b6057ecce78230dafb45711bfe764bf107b1f704 SHA512 4b852eaf4030c780516fe9214c289e49fc93fc62672da70b7fd6bbbcd128e6912dd196195ce32570984503ea53b48593a41fbf4ec69b0f18b5e32c2fe9e556b3
DIST gradle-3.4.1-all.zip 91604607 BLAKE2B 1c4aaae4899f3faa94fc3ead84c4fd4bdb6212c0f579a255c7494896fd2a498890c58e853315892c3c9d78635b58da5423b1b2211b991639474d19eca1f2992f SHA512 bdaabf747e60ae1cf2c9fedb0730a2e3deb914609db05ffc7e4cbd5402bc44e84d2c98154f14fdd7f944c2f49eb5dead0f44c119ac5a16bd7491c3369d784f5c
DIST gradle-bin-5.2.1.zip 132549774 BLAKE2B c6d6fa9975bc28030672a99f22f0e9c4c2cb3d667ae3658c1062428d0ab2fd8c3b4df0479f4fde7b2d75b8fcb64c7f5b208e53c5b30a9b3c7afb5ad7e1a4139d SHA512 e2a17072c10d27acbe4a0282dfdfed907ab5c57109668595feaec681ab1d4be017ac0f6090c2c2b64a057d71c1e244bb50f4047509d36c5930e894837a96171b
DIST gradle-bin-6.3.zip 145161013 BLAKE2B f840bda2c1e2a6dd5306b9f7ad6fc8ae8c3d7342de57bd813b8dff64f733fc058af8dc7c9c5a138eac4eef3d5d12074976db81fe7eeb51b52d726502af04d036 SHA512 9796c14f8d4559128b4cb7e676883d83ef99b67242ae8156abebdb38bb7a561e8b3df3f93b24aa53274b7d78a7b04ea51e73268c2465799daa9da53ef73de24d
49 changes: 49 additions & 0 deletions dev-java/gradle-bin/gradle-bin-6.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,49 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

IUSE="doc"
JAVA_PKG_IUSE="source"

inherit java-pkg-2

MY_PN=${PN%%-bin}
MY_P="${MY_PN}-${PV/_rc/-rc-}"

DESCRIPTION="A project automation and build tool with a Groovy based DSL"
SRC_URI="https://services.gradle.org/distributions/${MY_P}-all.zip -> ${P}.zip"
HOMEPAGE="https://www.gradle.org/"

LICENSE="Apache-2.0"
SLOT="${PV}"
KEYWORDS="~amd64 ~x86"

BDEPEND="app-arch/unzip"
DEPEND=">=virtual/jre-1.8"
RDEPEND=">=virtual/jdk-1.8"

S="${WORKDIR}/${MY_P}"

src_install() {
local gradle_dir="${EPREFIX}/usr/share/${PN}-${SLOT}"

insinto "${gradle_dir}"
doins -r lib/

exeinto "${gradle_dir}"/bin
doexe bin/${MY_PN}
dosym "../${gradle_dir##*/usr/}/bin/gradle" "/usr/bin/${MY_PN}-${SLOT}"

docinto html
dodoc -r docs/release-notes.html

if use doc ; then
dodoc -r docs/{dsl,userguide}
java-pkg_dojavadoc docs/javadoc
fi

if use source ; then
java-pkg_dosrc src/*
fi
}

0 comments on commit b0c814e

Please sign in to comment.