Skip to content

Commit

Permalink
dev-ros/ament_cmake_libraries: bump to 1.0.1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.8, Repoman-3.0.1
Signed-off-by: Alexis Ballier <[email protected]>
  • Loading branch information
aballier committed Sep 30, 2020
1 parent c08b555 commit b0da700
Show file tree
Hide file tree
Showing 2 changed files with 47 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ros/ament_cmake_libraries/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST ament_cmake-0.9.6.tar.gz 60800 BLAKE2B 71c4e71c50b7715bb8f1b5b737ce23e30f79459a14a5866801bcb810b8fe82d807b6a4eae11de427f52c618e14ef22b7693905f1a0200cc38f0ffab1d70e80cd SHA512 c923260bbd0142ea57bf3e868e94e76020939e8ec49cbf23f14221d0048f21efed00dcdae9978e00f246725ba216c151f5d53b1cd94297b8731f53dc0e45b554
DIST ament_cmake-1.0.0.tar.gz 63304 BLAKE2B dd0c4bc5b72d9143cfb8ee9caae236a3608981ee8523e879ea9c168d64fd1d0cb84e54679cfc0cfc58ffff34519bb1032afc956c3130c1da8b4f98d60a9191be SHA512 69236015368df29a128eceeb64dd1c683eb32a44188b52120592238f999be8c8c7c5892a36ddcef48b6686bf97eba77e820ca3b8896c64ec1522661fa3ed4fc7
DIST ament_cmake-1.0.1.tar.gz 66465 BLAKE2B cd905b52f4600ccf364ab8d5e4dcf102e1f6034bae7ab020022860fa440ff058a996752cbb0e743b5f66a2b6bc0d1f46cec7c71900be53f035ed8a0642e50b04 SHA512 5f60c933c0ba1eea97f2d0913e19f383e154f26a0625ea4e40c529dd1fa5831109f7cbc0c39a514d37334d61c5d614df0ea546e49ab46202002af09a2adf6288
46 changes: 46 additions & 0 deletions dev-ros/ament_cmake_libraries/ament_cmake_libraries-1.0.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,46 @@
# Copyright 2019-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python{3_6,3_7,3_8} )

inherit cmake python-any-r1

ROS_PN="ament_cmake"
if [ "${PV#9999}" != "${PV}" ] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/ament/ament_cmake"
SRC_URI=""
S=${WORKDIR}/${P}/${PN}
else
SRC_URI="https://github.com/ament/ament_cmake/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
fi

DESCRIPTION="The functionality to deduplicate libraries in the ament buildsystem"
HOMEPAGE="https://github.com/ament/ament_cmake"

LICENSE="Apache-2.0"
SLOT="0"
if [ "${PV#9999}" != "${PV}" ] ; then
KEYWORDS=""
else
KEYWORDS="~amd64"
fi
IUSE=""

RDEPEND="
dev-ros/ament_cmake_core
"
DEPEND="${RDEPEND}"
# Deps here are transitive from ament_cmake_core to have matching python support
BDEPEND="
$(python_gen_any_dep 'dev-python/ament_package[${PYTHON_USEDEP}] dev-python/catkin_pkg[${PYTHON_USEDEP}]')
${PYTHON_DEPS}
"

python_check_deps() {
has_version "dev-python/ament_package[${PYTHON_USEDEP}]" && \
has_version "dev-python/catkin_pkg[${PYTHON_USEDEP}]"
}

0 comments on commit b0da700

Please sign in to comment.