Skip to content

Commit

Permalink
app-admin/keepassxc: Bump to version 2.6.4
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.14, Repoman-3.0.2
Signed-off-by: Lars Wendler <[email protected]>
  • Loading branch information
Lars Wendler committed Feb 1, 2021
1 parent c35f13a commit b0fb6d5
Show file tree
Hide file tree
Showing 2 changed files with 94 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-admin/keepassxc/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST keepassxc-2.6.1-src.tar.xz 5715948 BLAKE2B 5490757fd939b572f2f281dc6ecfcd6afc7f9a5b2ebf3cc0c8ae4a95bb982ad755a9363f6133fb0f4ac2a2b5e0a6c66a7dba954911cb5baf70d447fc8d6089bf SHA512 9fb2d01d80e2b61c847c0544c280c1f3bfca671268e2dbbe78e0f3c1264f38125a3767ceb4591261f3586cd71f4fff47ecc6eacaecf1e707cea5e8907542313a
DIST keepassxc-2.6.2-src.tar.xz 5720788 BLAKE2B c6bcc0af594c3b697d8e74752edb0389c80c72008bd57dcc36d9606462ea4bc9c6012a9f3f31702a9c0f88004fdc66f1ee4fbebd8a501227f4579ea8f3f1078f SHA512 b297edc4fae32b65430802094bd63dc301addae36859365a3009899d5bc20b32934e174ea56bf3fd1ee633a263ab36b577cba5aaa75bf4ad597f44606f7b5fd1
DIST keepassxc-2.6.3-src.tar.xz 7562816 BLAKE2B 1b33850ed996a2f07b1665309bb4680329a0f858d89e9e89f7ca39a84f27f1a4364bd8526d1907b4fc4d5dd586b3dc48d9d9b6235b78b52edc4db08ca72d79fa SHA512 37f97c0851731badffc9c40ed2dcc5c8fc200ea96b32281c21cf199799681abbd74fb191140022ad7872d69ee139e12646e19697010f539690e4e0f0f1c92558
DIST keepassxc-2.6.4-src.tar.xz 7575164 BLAKE2B ca02e59c7355f7f7e14bb4fa318fab66d354e84d1025847b413b7e838dc5a42024b963dea1e3ba2060c51da7daed2ee5b220e5dab72b5813d39c04b49c6ba9ba SHA512 3bde0c8670ba14be80c6f3676bd447b0855a2af2915a395ee236c2d4c6e4b859936351643d679480aae1fcf55ed4315447ae927ac9bdedeb0332593cb4e9fedb
93 changes: 93 additions & 0 deletions app-admin/keepassxc/keepassxc-2.6.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,93 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit cmake flag-o-matic xdg

DESCRIPTION="KeePassXC - KeePass Cross-platform Community Edition"
HOMEPAGE="https://keepassxc.org"

if [[ "${PV}" != 9999 ]] ; then
if [[ "${PV}" == *_beta* ]] ; then
SRC_URI="https://github.com/keepassxreboot/keepassxc/archive/${PV/_/-}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${P/_/-}"
else
#SRC_URI="https://github.com/keepassxreboot/keepassxc/archive/${PV}.tar.gz -> ${P}.tar.gz"
SRC_URI="https://github.com/keepassxreboot/keepassxc/releases/download/${PV}/${P}-src.tar.xz"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
fi
else
inherit git-r3
EGIT_REPO_URI="https://github.com/keepassxreboot/${PN}"
fi

LICENSE="LGPL-2.1 GPL-2 GPL-3"
SLOT="0"
IUSE="autotype browser ccache keeshare +network test yubikey"

RDEPEND="
app-crypt/argon2:=
dev-libs/libgcrypt:=
>=dev-libs/libsodium-1.0.12:=
dev-qt/qtconcurrent:5
dev-qt/qtcore:5
dev-qt/qtdbus:5
dev-qt/qtgui:5
dev-qt/qtnetwork:5
dev-qt/qtsvg:5
dev-qt/qtwidgets:5
media-gfx/qrencode:=
sys-libs/readline:0=
sys-libs/zlib:=
autotype? (
dev-qt/qtx11extras:5
x11-libs/libX11
x11-libs/libXi
x11-libs/libXtst
)
keeshare? ( dev-libs/quazip )
yubikey? ( sys-auth/ykpers )
"

DEPEND="
${RDEPEND}
dev-qt/linguist-tools:5
dev-qt/qttest:5
"
BDEPEND="
ccache? ( dev-util/ccache )
"

RESTRICT="!test? ( test )"

src_prepare() {
use test || \
sed -e "/^find_package(Qt5Test/d" -i CMakeLists.txt || die

cmake_src_prepare
}

src_configure() {
# https://github.com/keepassxreboot/keepassxc/issues/5801
filter-flags -flto*

local mycmakeargs=(
-DWITH_CCACHE="$(usex ccache)"
-DWITH_GUI_TESTS=OFF
-DWITH_TESTS="$(usex test)"
-DWITH_XC_AUTOTYPE="$(usex autotype)"
-DWITH_XC_DOCS=OFF
-DWITH_XC_BROWSER="$(usex browser)"
-DWITH_XC_FDOSECRETS=ON
-DWITH_XC_KEESHARE="$(usex keeshare)"
-DWITH_XC_NETWORKING="$(usex network)"
-DWITH_XC_SSHAGENT=ON
-DWITH_XC_UPDATECHECK=OFF
-DWITH_XC_YUBIKEY="$(usex yubikey)"
)
if [[ "${PV}" == *_beta* ]] ; then
mycmakeargs+=( -DOVERRIDE_VERSION="${PV/_/-}" )
fi
cmake_src_configure
}

0 comments on commit b0fb6d5

Please sign in to comment.