forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-python/mongoengine: version bump, add Python-3 support
Package-Manager: portage-2.3.0_rc1
- Loading branch information
Showing
2 changed files
with
33 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST mongoengine-0.10.6.tar.gz 469469 SHA256 0fa34c2747c987eebe624a794d18ffefbed440e374e3d230b2baed7c98b9513d SHA512 a8d16739892c64ed408afab49c6d33a4b438af83e003844caa101cd51366038ba75121d12b4385a546cf4d946a506bc11f173355f6855e740cef9fddfd6437e7 WHIRLPOOL 58f511cfe80cae44c41fe1f451bd19edfc653e7c885547b16f1cd3436f62273c947c7ce893639d1fe3e1417bc6c4c97034bb84a85cf76886252b426b2e776bf4 | ||
DIST mongoengine-0.8.3.tar.gz 219978 SHA256 e8e8acbffda03d70ab09615135b823b7707bd11a4e6c9327c2fd8cbed145c14a SHA512 b77c36ae008fb31f26a60135fbba3a9cf08375506a760daa3fe9e2558a6c67f4ea769eccf7c472c9ddef900fe50548aca00a81d0e666b007398b31cb4d32e368 WHIRLPOOL 241c0b51a2c9a130ed8416266baa1394d06def7c7b074cec7c6a35da6add251cd0aa05f0350bf9334ee9d3921e6a686c23dbdf5a3120a1459a4adfc134c244e1 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,32 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} ) | ||
|
||
inherit distutils-r1 | ||
|
||
RESTRICT="test" # connects to local DB and other nonsense | ||
|
||
DESCRIPTION="A Python Object-Document-Mapper for working with MongoDB" | ||
HOMEPAGE="https://github.com/MongoEngine/mongoengine/" | ||
SRC_URI="https://github.com/MongoEngine/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz" | ||
|
||
LICENSE="BSD" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="test" | ||
|
||
RDEPEND="" | ||
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}] | ||
dev-python/pymongo[${PYTHON_USEDEP}]" | ||
|
||
python_prepare_all() { | ||
sed -i -e 's/tests/tests*/g' setup.py || die "Failed to fix test removal thingy" | ||
distutils-r1_python_prepare_all | ||
} | ||
|
||
python_test() { | ||
nosetests || die "Testing failed with ${EPYTHON}" | ||
} |