Skip to content

Commit

Permalink
dev-games/libmt_client: build with format-security. Bug #543014
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.24
  • Loading branch information
atupone committed Dec 22, 2015
1 parent fbe947d commit b114988
Show file tree
Hide file tree
Showing 2 changed files with 57 additions and 0 deletions.
50 changes: 50 additions & 0 deletions dev-games/libmt_client/files/libmt_client-0.1.98-format.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,50 @@
--- src/mt_client_game.c.old 2015-12-22 08:51:19.858561807 +0100
+++ src/mt_client_game.c 2015-12-22 08:52:48.934904973 +0100
@@ -56,7 +56,7 @@
}
else
{
- g_printerr (str_err_function[num]);
+ g_printerr ("%s\n", str_err_function[num]);
exit (-1);
}
}
@@ -110,27 +110,27 @@
}

str_err_function[LIBMT_CLIENT_FUNCTION_INIT] =
- _("libmt_client_function INIT : not initialised\n");
+ _("libmt_client_function INIT : not initialised");
str_err_function[LIBMT_CLIENT_FUNCTION_GAME_INIT] =
- _("libmt_client_function GAME_INIT : not initialised\n");
+ _("libmt_client_function GAME_INIT : not initialised");
str_err_function[LIBMT_CLIENT_FUNCTION_MAKE_BID] =
- _("libmt_client_function MAKE_BID : not initialised\n");
+ _("libmt_client_function MAKE_BID : not initialised");
str_err_function[LIBMT_CLIENT_FUNCTION_MAKE_CHIEN] =
- _("libmt_client_function MAKE_CHIEN : not initialised\n");
+ _("libmt_client_function MAKE_CHIEN : not initialised");
str_err_function[LIBMT_CLIENT_FUNCTION_NOT_MAKE_CHIEN] =
- _("libmt_client_function NOT_MAKE_CHIEN : not initialised\n");
+ _("libmt_client_function NOT_MAKE_CHIEN : not initialised");
str_err_function[LIBMT_CLIENT_FUNCTION_CHOOSE_CARD] =
- _("libmt_client_function CHOOSE_CARD : not initialised\n");
+ _("libmt_client_function CHOOSE_CARD : not initialised");
str_err_function[LIBMT_CLIENT_FUNCTION_DRAW] =
- _("libmt_client_function DRAW : not initialised\n");
+ _("libmt_client_function DRAW : not initialised");
str_err_function[LIBMT_CLIENT_FUNCTION_REMOVE_CARD] =
- _("libmt_client_function REMOVE CARD : not initialised\n");
+ _("libmt_client_function REMOVE CARD : not initialised");
str_err_function[LIBMT_CLIENT_FUNCTION_ACK_REPLAY] =
- _("libmt_client_function ACK REPLAY : not initialised\n");
+ _("libmt_client_function ACK REPLAY : not initialised");
str_err_function[LIBMT_CLIENT_FUNCTION_LOST_CONNECTION] =
- _("libmt_client_function LOST CONNECTION : not initialised\n");
+ _("libmt_client_function LOST CONNECTION : not initialised");
str_err_function[LIBMT_CLIENT_FUNCTION_NORMAL_CLOSE] =
- _("libmt_client_function NORMAL CLOSE : not initialised\n");
+ _("libmt_client_function NORMAL CLOSE : not initialised");

return (0);
}
7 changes: 7 additions & 0 deletions dev-games/libmt_client/libmt_client-0.1.98.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -3,6 +3,9 @@
# $Id$

EAPI=5

inherit eutils

DESCRIPTION="backend library for the maitretarot clients"
HOMEPAGE="http://www.nongnu.org/maitretarot/"
SRC_URI="http://savannah.nongnu.org/download/maitretarot/${PN}.pkg/${PV}/${P}.tar.bz2"
Expand All @@ -16,3 +19,7 @@ DEPEND="dev-libs/glib:2
dev-libs/libxml2
dev-games/libmaitretarot"
RDEPEND=${DEPEND}

src_prepare () {
epatch "${FILESDIR}"/${P}-format.patch
}

0 comments on commit b114988

Please sign in to comment.