Skip to content

Commit

Permalink
dev-tcltk/thread: Version bump to 2.8.2
Browse files Browse the repository at this point in the history
Signed-off-by: Alfredo Tupone <[email protected]>
Package-Manager: Portage-2.3.49, Repoman-2.3.11
  • Loading branch information
atupone committed Nov 2, 2018
1 parent 71ea54a commit b139508
Show file tree
Hide file tree
Showing 2 changed files with 40 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-tcltk/thread/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST thread2.7.1.tar.gz 295134 BLAKE2B 785e832f8acf926f550cbffa3e2383eb6ad7fdbb480830e3c0f56d207375053c865d6eb201361acb8ca2df8951a037603b015f85ab4903d80a92f9d957af9dcd SHA512 18ebd9431b6f6bfb1e6a60797af39db0dee29a16cd457ddab2a18cd5dfd9ef2dea9284ab99238fb05b8284fcc855c2ef8011eb3ed02d7e54d715379d133512dc
DIST thread2.7.3.tar.gz 291332 BLAKE2B 96e7b03cf22227e85462994a6f955fd04d2e40384e540e7cbf78f93c661611607312eb1ceb195cecbe672ecb53df464f1cff4e9b9768864cfeef6be82595e17e SHA512 0efe8db04ffb1cbe539d1bbc9f82e52df994cf0cb570a2eeb79b6f821ee5d585e0b034b970e793a54c588b08321e5ea286c7b9173a09a5cc573b11fbf00c2888
DIST thread2.8.2.tar.gz 346222 BLAKE2B 194673b14b3f6b98a46330afa58caaf705feb2d8713606547d0d7e5b18770c5729fd562c81e66b403040622afdbdf62b994bd3ef62678d00915ba48f1eafc786 SHA512 0889f54ba8c76413f0333bdf6f17cca38c4fa8ccfff7e1554a63f38f19471dc72c3afe34d2e38ea00724aa3f0c007051999392a8d188d47265dbf0527dadceea
39 changes: 39 additions & 0 deletions dev-tcltk/thread/thread-2.8.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,39 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit autotools multilib

MY_P="${PN}${PV}"

DESCRIPTION="Tcl Thread extension"
HOMEPAGE="http://www.tcl.tk/"
SRC_URI="mirror://sourceforge/project/tcl/Thread%20Extension/${PV}/${MY_P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
IUSE=""

DEPEND="dev-lang/tcl:0=[threads]"
RDEPEND="${DEPEND}"

S="${WORKDIR}"/${PN}${PV}

src_prepare() {
default

# Search for libs in libdir not just exec_prefix/lib
sed -i -e 's:${exec_prefix}/lib:${libdir}:' \
aclocal.m4 || die "sed failed"

sed -i -e "s/relid'/relid/" tclconfig/tcl.m4 || die

eautoreconf
}

src_configure() {
econf --with-tclinclude="${EPREFIX}/usr/include" \
--with-tcl="${EPREFIX}/usr/$(get_libdir)"
}

0 comments on commit b139508

Please sign in to comment.