Skip to content

Commit

Permalink
dev-ruby/daemons: add 1.3.1
Browse files Browse the repository at this point in the history
Signed-off-by: Hans de Graaff <[email protected]>
Package-Manager: Portage-2.3.51, Repoman-2.3.11
  • Loading branch information
graaff committed Dec 15, 2018
1 parent 608cbf3 commit b150878
Show file tree
Hide file tree
Showing 2 changed files with 35 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/daemons/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST daemons-1.2.6.tar.gz 27557 BLAKE2B 7c08b637ab37f764309fd260c4ea6c11402b89ea327eb47ea0af3860397ece795467a11c4ae5d8577972f5d8e2c6590f4d8112027f06db941b7181e33c158736 SHA512 8276685a684093252bf136c552a613a5208f4ab34f178be9425c62ea59fe1eebe671a7dd6c57d30744187b9ae58d7a7f1ebf58468e988565a30ca4417f2a90ea
DIST daemons-1.3.0.tar.gz 28692 BLAKE2B 63764fdaae20e789ff77ac3a2a6b8d6d6d1548abcc2683a9a52080490166abef507dbe45ec5b3cf4c190abe366f00cac238eb3d7a34e701e7e761fe986fd949e SHA512 110b925c458ee92c2497c924b080297609ad4bec3944926011405c67532b80cd4e1ba0a414919db0a48a158e4fdf6c15d3b17e8db350f1c5d1cdced32f52d198
DIST daemons-1.3.1.tar.gz 28805 BLAKE2B 4ddb9cb9a5a6de5ebeac8ac69c2712500f9dd18c9d194efce3152735533a2aef7a4cf0e034e4c1781e5d89c1be18e7e7c119455bafb0bf4d8cec279b1e8f6308 SHA512 ceeeefbf44727a1ee43b651bbc3f8e5ae83c73388d017d240d95624586b91a3b32602464f4a5ff53a854d6cc6fa1dc47e433a665f0ad7f08e440c0a798743d80
34 changes: 34 additions & 0 deletions dev-ruby/daemons/daemons-1.3.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,34 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
USE_RUBY="ruby23 ruby24 ruby25"

RUBY_FAKEGEM_EXTRADOC="Releases README.md"
RUBY_FAKEGEM_RECIPE_DOC="rdoc"

RUBY_FAKEGEM_RECIPE_TEST="rspec3"

inherit ruby-fakegem

DESCRIPTION="Wrap existing ruby scripts to be run as a daemon"
HOMEPAGE="https://github.com/thuehlinger/daemons"
SRC_URI="https://github.com/thuehlinger/daemons/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
IUSE="examples"

all_ruby_prepare() {
sed -i -e '/\(pry\|simplecov\)/I s:^:#:' spec/spec_helper.rb || die
}

all_ruby_install() {
all_fakegem_install

use examples || return

insinto /usr/share/doc/${PF}/
doins -r examples
}

0 comments on commit b150878

Please sign in to comment.