forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Package-Manager: Portage-2.3.6, Repoman-2.3.2
- Loading branch information
Showing
2 changed files
with
71 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST glueviz-0.10.0.tar.gz 12645658 SHA256 1c3dfbe721a3566f968b388f9806d0e91238ebb9eeefcd3f7eb9abf7b33b8930 SHA512 1b42e600a7aa01320512c38aa40388a39fe93f2efe0bfd668492de13559d6fa2106cabcd755b35346c4dd80099db94cfec5e791a5f53a4258bccd61d1e836ea3 WHIRLPOOL f9c3bc4a1089b3e44ff54f373ecf5ac018b3394f2ca43e810a815f83cff200d4458b860816ef2d2d7fd69b3ec345df4d93ca435d5d3ddb02ae1f6907037a4495 | ||
DIST glueviz-0.10.4.tar.gz 2395 SHA256 8dbe3cca9f2d4a4b8d67da74001d90c43b4a636bd80ceb6e74908e1b7d484481 SHA512 c372e04a52a1e4609a8545f3330d539f0afbbe30b09d4f3c0be28895bab82ab1825cb907297562adaefa11c0c94b25c74ccffc31b5a272eb45724efe6180e8f6 WHIRLPOOL 5956d629f9ebca15ec25379bf9cb0fd7bf49ad074b87122179008bf173871798a15c6cb4292d97caef22dab907b53066572b90f9e611b660d487eddee7150052 | ||
DIST glueviz-0.9.1.tar.gz 12229471 SHA256 b0cd6de792ca5812bae7a033b96acafcf9fa7ab49919c2dc876b8cea877c4fce SHA512 d4b8e476c3ec37a873084cbe1e0c3019aa7bfe7d5d03af4cc1d6d14474200060d0a8a608e90024ab0aaf10d71f85a2c82ae1371e2a5d14f7c91ca5d979c25d30 WHIRLPOOL 220127d131692bceb899a65ca4f3b13720b8eb835c66b6d3b09ee3ff1f70f65cb1c18ba64ba2dfdb791d4d6e83a332d3ba405f7871b3c7f812cb7e0363d7da43 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,70 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} ) | ||
|
||
inherit distutils-r1 eutils virtualx fdo-mime | ||
|
||
DESCRIPTION="Python library to explore relationships within and among related datasets" | ||
HOMEPAGE="http://www.glueviz.org/" | ||
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz" | ||
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux" | ||
|
||
LICENSE="BSD MIT" | ||
SLOT="0" | ||
IUSE="test" | ||
|
||
# as of 0.10.0; broken | ||
#RESTRICT="test" | ||
|
||
DOCS=( README.rst ) | ||
|
||
RDEPEND=" | ||
dev-python/astropy[${PYTHON_USEDEP}] | ||
dev-python/matplotlib[${PYTHON_USEDEP}] | ||
dev-python/numpy[${PYTHON_USEDEP}] | ||
dev-python/pandas[${PYTHON_USEDEP}] | ||
dev-python/QtPy[${PYTHON_USEDEP},designer,gui] | ||
" | ||
|
||
DEPEND="${RDEPEND} | ||
dev-python/astropy-helpers[${PYTHON_USEDEP}] | ||
dev-python/setuptools[${PYTHON_USEDEP}] | ||
test? ( | ||
dev-python/glue-vispy-viewers[${PYTHON_USEDEP}] | ||
dev-python/ipython[${PYTHON_USEDEP}] | ||
dev-python/mock[${PYTHON_USEDEP}] | ||
dev-python/pytest[${PYTHON_USEDEP}] | ||
dev-python/qtconsole[${PYTHON_USEDEP}] | ||
dev-python/QtPy[${PYTHON_USEDEP},designer,gui,testlib] | ||
) | ||
" | ||
|
||
python_test() { | ||
virtx esetup.py test | ||
} | ||
|
||
pkg_postinst() { | ||
optfeature "Interactive Ipython terminal" \ | ||
dev-python/ipython \ | ||
dev-python/ipykernel \ | ||
dev-python/qtconsole \ | ||
dev-python/traitlets \ | ||
dev-python/pygments \ | ||
dev-python/zmq | ||
optfeature "Parse AVM metadata" dev-python/pyavm | ||
optfeature "Save ${PN} sessions" dev-python/dill | ||
optfeature "Support HDF5 files" dev-python/h5py | ||
optfeature "Image processing calculations" sci-libs/scipy | ||
optfeature "Read popular image formats" sci-libs/scikits_image | ||
optfeature "Interact with Ginga viewer" dev-python/ginga | ||
optfeature "Export plots to plot.ly" dev-python/plotly | ||
optfeature "Support Excel reading" dev-python/xlrd | ||
optfeature "Used to read in spectral cubes" dev-python/spectral-cube | ||
optfeature "Support astronomy dendograms" dev-python/astrodendro | ||
|
||
# Update mimedb for the new .desktop file | ||
fdo-mime_desktop_database_update | ||
} |