forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Package-Manager: Portage-2.3.82, Repoman-2.3.20 Signed-off-by: Thomas Deutschmann <[email protected]>
- Loading branch information
Showing
2 changed files
with
78 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST fuse-2.9.8.tar.gz 4610904 BLAKE2B 803eebea510834676379df8c9514050efcf47d83c06ba1f5b5756d27f5c32d3a0cc199d826b0c041118c5d2260ff023f58432a0d7b623807c0a4af4da7c34eff SHA512 0a9b14d96c6f98f5c903baf00114bfff72f9aeb97224702bbed370516b2b582401d5b436fcef979918ffd85d69ba4a82c8f722c0b35ebd50f7aa5f4ddfdcf8ad | ||
DIST fuse-2.9.9.tar.gz 1813177 BLAKE2B 9e9141380bda46eb0bcce325c6fd293fe3844fe884a4952bb38d4b89dc48b728ffcc891038b3a7a861f05acfacce9dd7bb0e11d600609f3ad0ab278ccbe98847 SHA512 3d82fafd04f2924299bb09d2bb144935fa004a43fb9a6568e2e1cc5a60fded2efa1711029a0d7f12b3e6e4501f7217f2ee3545646d89da8dece083cb390f23e2 | ||
DIST fuse-3.8.0.tar.xz 1416716 BLAKE2B f921b739489e8eb8b2a78b719c9761f330de839f151f787a6db37d8d004ef9b90022bfe3c5d24ceab333cde8741340ede0315a5b92cabdaf87fb1b291f72e292 SHA512 46d2b1494c73f8b6b2be4e8969bb9906ea35620fb4081edc3176f7ba34e6ed815d5f9c5c6f06604fb37836460e25d0ce51619853288bb881362f04cba6b31812 | ||
DIST fuse-3.9.0.tar.xz 1523028 BLAKE2B 2fff93431e59e370189fb1527de7bff3863d20e1a62628bb56a6671077a1c919b394ddac66537a1ef7c2991556b1817b2c7f6a92c161ebfffbc804466e19e5e7 SHA512 0c96df5db4d0ceb7885ddb6f6c05b523ee7e179f8f411ad0614caecb9fa0f5fd682ab9bf4dfdaa3aff9d90c18b8947a122ee376328535e49fa6091d784aa0cb7 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,77 @@ | ||
# Copyright 1999-2019 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
PYTHON_COMPAT=( python3_{5,6,7,8} ) | ||
|
||
inherit meson multilib-minimal flag-o-matic udev python-any-r1 | ||
|
||
DESCRIPTION="An interface for filesystems implemented in userspace" | ||
HOMEPAGE="https://github.com/libfuse/libfuse" | ||
SRC_URI="https://github.com/libfuse/libfuse/releases/download/${P}/${P}.tar.xz" | ||
|
||
LICENSE="GPL-2 LGPL-2.1" | ||
SLOT="3" | ||
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86" | ||
IUSE="+suid test" | ||
RESTRICT="!test? ( test )" | ||
|
||
BDEPEND="virtual/pkgconfig | ||
test? ( | ||
${PYTHON_DEPS} | ||
$(python_gen_any_dep 'dev-python/pytest[${PYTHON_USEDEP}]') | ||
)" | ||
RDEPEND=">=sys-fs/fuse-common-3.3.0-r1" | ||
|
||
DOCS=( AUTHORS ChangeLog.rst README.md doc/README.NFS doc/kernel.txt ) | ||
|
||
python_check_deps() { | ||
has_version "dev-python/pytest[${PYTHON_USEDEP}]" | ||
} | ||
|
||
pkg_setup() { | ||
use test && python-any-r1_pkg_setup | ||
} | ||
|
||
src_prepare() { | ||
default | ||
|
||
# lto not supported yet -- https://github.com/libfuse/libfuse/issues/198 | ||
filter-flags '-flto*' | ||
|
||
# passthough_ll is broken on systems with 32-bit pointers | ||
cat /dev/null > example/meson.build || die | ||
} | ||
|
||
multilib_src_configure() { | ||
local emesonargs=( | ||
-Duseroot=false | ||
) | ||
meson_src_configure | ||
} | ||
|
||
multilib_src_compile() { | ||
eninja | ||
} | ||
|
||
multilib_src_test() { | ||
${EPYTHON} -m pytest test || die | ||
} | ||
|
||
multilib_src_install() { | ||
DESTDIR="${D}" eninja install | ||
} | ||
|
||
multilib_src_install_all() { | ||
einstalldocs | ||
|
||
# installed via fuse-common | ||
rm -r "${ED}"/{etc,$(get_udevdir)} || die | ||
|
||
# useroot=false prevents the build system from doing this. | ||
use suid && fperms u+s /usr/bin/fusermount3 | ||
|
||
# manually install man pages to respect compression | ||
rm -r "${ED}"/usr/share/man || die | ||
doman doc/{fusermount3.1,mount.fuse3.8} | ||
} |