Skip to content

Commit

Permalink
dev-ruby/gh: add 0.16.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Hans de Graaff <[email protected]>
  • Loading branch information
graaff committed Apr 9, 2020
1 parent 8a72e90 commit b19ea6f
Show file tree
Hide file tree
Showing 2 changed files with 43 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/gh/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST gh-0.15.1.tar.gz 64076 BLAKE2B 3611d83d9414349284bbaa7618aee2c9b5cb4c6db98e506891f70cf0f21dd7f25ae87e9f8094a90ec4ed4f62ba1e05bd598722a743e32abe54e7eb2a002d9d72 SHA512 6b8a43360253275408ff3d0f6e8cabe3afe399b4ed362f9b4ded72a9d650d18483cf5e3d10877a97c9112b7ccd5add5f2c9999ab1cd5f8102af3a9e49ef39037
DIST gh-0.16.0.tar.gz 129499 BLAKE2B 6dea86bcaa8191b2eb19daed487d80e5b55adadccb1c063320b44e742895cad1956e06a917ff35659834b4cf541892d3cd0b432f03783b4b860cf4c7136c7c49 SHA512 141a432b8d5f43feea6cc86be504e35b5133590466f1a28c5ba60a208cde9d3cc1a6f19702757e132e4255220e1161f6dc9621ec18a789d963738b9801e52da1
42 changes: 42 additions & 0 deletions dev-ruby/gh/gh-0.16.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,42 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

USE_RUBY="ruby24 ruby25 ruby26"
RUBY_FAKEGEM_RECIPE_TEST="rspec3"

RUBY_FAKEGEM_GEMSPEC="gh.gemspec"

inherit ruby-fakegem

DESCRIPTION="multi-layer client for the github api v3"
HOMEPAGE="https://github.com/travis-ci/gh"
SRC_URI="https://github.com/travis-ci/gh/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
IUSE=""

ruby_add_bdepend "
dev-ruby/webmock
"

ruby_add_rdepend "
dev-ruby/activesupport:5.2
>=dev-ruby/addressable-2.4.0:0
>dev-ruby/faraday-0.8
>=dev-ruby/faraday_middleware-0.14:0
>dev-ruby/multi_json-1.0
dev-ruby/net-http-pipeline
dev-ruby/net-http-persistent:*
"

all_ruby_prepare() {
sed -i \
-e '/addressable/ s/2.4.0/2.4/' \
-e '/net-http-persistent/ s/~> 2.9/>= 2.9/' \
-e 's/git ls-files/find/' \
"${RUBY_FAKEGEM_GEMSPEC}" || die
}

0 comments on commit b19ea6f

Please sign in to comment.