Skip to content

Commit

Permalink
dev-php/libvirt-php: version bump to 0.5.2
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.28
  • Loading branch information
tamiko committed Aug 16, 2016
1 parent 9da931e commit b2117fd
Show file tree
Hide file tree
Showing 3 changed files with 54 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-php/libvirt-php/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST libvirt-php-0.4.8.tar.gz 249753 SHA256 75508ab420c45fface8cdd8328053eee2207f8ff2aab572627ba8f30aacaef35 SHA512 2c1cbe914ab73a45b917130224fd803bfb41b0cc470d5480050c6d512dc4509ee96adcaa3ce3735747f17c4748ce66782437009b5445c364800fa308ee5059d1 WHIRLPOOL bdf18892348de1a8984e23a7f3044f3f861956fd4bf28796f0a79c91079081b97fe630adf6073db2bf94534df22becc503dfb81cc0cc5f1ebf39e6804c93d905
DIST libvirt-php-0.5.2.tar.gz 770816 SHA256 f338caab2bebcce60cd62e3982ec4c1a274ecaf49d03cf7080b45f2f16cd516d SHA512 11844fea8507090826acd81fc7c257ecc3ed9cca10fc785e4d54b98ebd1e213310e379e7ca684c6439d9e2c57800a140fdc9953c6bec72da1959f5ed99e9ef31 WHIRLPOOL 19bde6afd0ef824557048d9f00aa1dd34f7138408326653e49c04a25e514575d1c2d92c462a8a9f40048ae2af7b2e46a27b66561cddf21fb8f28c294085700f5
52 changes: 52 additions & 0 deletions dev-php/libvirt-php/libvirt-php-0.5.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,52 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

PHP_EXT_NAME="libvirt-php"
PHP_EXT_SKIP_PHPIZE="yes"
USE_PHP="php5-6 php5-5"

inherit php-ext-source-r2 eutils

DESCRIPTION="PHP 5 bindings for libvirt"
HOMEPAGE="http://libvirt.org/php/"
SRC_URI="http://libvirt.org/sources/php/${P}.tar.gz"

LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64"
IUSE="doc"

RDEPEND="app-emulation/libvirt
dev-libs/libxml2"
DEPEND="${RDEPEND}
dev-libs/libxslt
doc? ( app-text/xhtml1 )"

RESTRICT="test"

src_unpack() {
default

# create the default modules directory to be able
# to use the php-ext-source-r2 eclass to configure/build
ln -s src "${S}/modules"

for slot in $(php_get_slots); do
cp -r "${S}" "${WORKDIR}/${slot}"
done
}

src_install() {
local slot
for slot in $(php_get_slots); do
php_init_slot_env ${slot}
insinto "${EXT_DIR}"
newins "src/.libs/${PHP_EXT_NAME}.so.0.0.0" "${PHP_EXT_NAME}.so"
done
php-ext-source-r2_createinifiles
dodoc AUTHORS ChangeLog NEWS README
use doc && dohtml docs/* docs/graphics/*
}
1 change: 1 addition & 0 deletions dev-php/libvirt-php/libvirt-php-9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -51,6 +51,7 @@ src_prepare() {
}

src_install() {
local slot
for slot in $(php_get_slots); do
php_init_slot_env ${slot}
insinto "${EXT_DIR}"
Expand Down

0 comments on commit b2117fd

Please sign in to comment.