forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-python/python-swiftclient: 3.10.1 bump
Closes: https://bugs.gentoo.org/747220 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Matthew Thode <[email protected]>
- Loading branch information
1 parent
ed72e5a
commit b22ccf5
Showing
2 changed files
with
47 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST python-swiftclient-3.10.1.tar.gz 199466 BLAKE2B 4230f0fbff0e61a8172344df1cfc32f07628ac0b3784f5b8456d1b43b962e1d8561eec55c530ea94c615d46cd9454963fe0e21c54d1f4097016459e1460795c9 SHA512 f47444243f1968fdbba0643bcb4f05fc10a201b38ad83522e842bbad2221d0893a72147f9fbdc13e7f56469b049bbf11479fd9f41a9706119287543e0587f696 | ||
DIST python-swiftclient-3.7.0.tar.gz 190256 BLAKE2B f3e4c462f05a34af8f6b7775b9e238e14a29af0970f4838dbda21c0fe43481a84ad51be1f2f62592109ac6fc5a84931fce154381129fad9e1d7a60333c44c7e9 SHA512 85b762cbc9f5e90c7d4dcbb5f016ee4bdc61fe6c869d24fb9bc5f3a3c3e336b171b0d3f384b51ed7bf0edf38df3936f778be85598e4c6a9bf165f8dde0d3333f |
46 changes: 46 additions & 0 deletions
46
dev-python/python-swiftclient/python-swiftclient-3.10.1.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,46 @@ | ||
# Copyright 1999-2020 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
PYTHON_COMPAT=( python3_{6,7,8} ) | ||
DISTUTILS_USE_SETUPTOOLS=rdepend | ||
|
||
inherit distutils-r1 | ||
|
||
DESCRIPTION="Python bindings to the OpenStack Object Storage API" | ||
HOMEPAGE="https://launchpad.net/python-swiftclient" | ||
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz" | ||
|
||
LICENSE="Apache-2.0" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux" | ||
IUSE="test" | ||
RESTRICT="!test? ( test )" | ||
|
||
DEPEND="dev-python/pbr[${PYTHON_USEDEP}] | ||
test? ( | ||
>=dev-python/coverage-4.0[${PYTHON_USEDEP}] | ||
!~dev-python/coverage-4.4[${PYTHON_USEDEP}] | ||
>=dev-python/keystoneauth-3.4.0[${PYTHON_USEDEP}] | ||
>=dev-python/mock-1.2.0[${PYTHON_USEDEP}] | ||
>=dev-python/stestr-2.0.0[${PYTHON_USEDEP}] | ||
!~dev-python/stestr-3.0.0[${PYTHON_USEDEP}] | ||
>=dev-python/openstacksdk-0.11.0[${PYTHON_USEDEP}] | ||
)" | ||
RDEPEND=" | ||
>=dev-python/requests-1.1.0[${PYTHON_USEDEP}] | ||
>=dev-python/six-1.9.0[${PYTHON_USEDEP}]" | ||
|
||
#PATCHES=( "${FILESDIR}/CVE-2013-6396.patch" ) | ||
|
||
python_prepare_all() { | ||
sed -i '/hacking/d' "${S}/test-requirements.txt" || die "sed failed" | ||
distutils-r1_python_prepare_all | ||
} | ||
|
||
python_test() { | ||
testr init | ||
testr run || die "tests failed under ${EPYTHON}" | ||
flake8 tests && einfo "run of tests folder by flake8 passed" | ||
flake8 bin/swift && einfo "run of ./bin/swift by flake8 passed" | ||
} |