forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
media-libs/avidemux-plugins: Bump avidemux-plugins-2.6.20 and update …
…to EAPI 6 Package-Manager: Portage-2.3.6, Repoman-2.3.2
- Loading branch information
1 parent
c330374
commit b24c9de
Showing
5 changed files
with
278 additions
and
49 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST avidemux_2.6.20.tar.gz 20172362 SHA256 03c6cb7fc9eb74688b4fcd5eb654ed7b9c4ffc717a72cc09b08a2d10cdc7ef9f SHA512 d01d0fc24a3004770bd3923c2debc4fa2752eb71df08cfe423746b9c44a2562ca01d82965ed2563b99572a4bed8034b79487199ce330208b51a3b7f87ccf7103 WHIRLPOOL 2e2dc21bed49eeb0cdfefe75fe51f6a84226e7e8e80b063bc0b3d8711a6b91db710611dc0ec06575be69ec8e24f2f9e5b5eb363b9c095267729e85e162a4ce38 | ||
DIST avidemux_2.6.8.tar.gz 17380534 SHA256 02998c235a89894d184d745c94cac37b78bc20e9eb44b318ee2bb83f2507e682 SHA512 57a4042f1a9d46462850871d36950215c5ffb5b66ce2f2cde09d747e946c05adb7a550ac7763c96f4c1bcb2c39881407d9d88bc64c93053741091751495ba0b0 WHIRLPOOL 29f8a6039d82e686e8dfbfc7b23658921834238a4cc6c4de338afdfdc032a9a7cba1c8236789aa6dbcab318ec14c344c19563f153e6cbd63cd265c5fb15b44b6 |
174 changes: 174 additions & 0 deletions
174
media-libs/avidemux-plugins/avidemux-plugins-2.6.20.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,174 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI="6" | ||
|
||
PYTHON_COMPAT=( python2_7 ) | ||
|
||
inherit cmake-utils python-single-r1 | ||
|
||
DESCRIPTION="Plugins for the video editor media-video/avidemux" | ||
HOMEPAGE="http://fixounet.free.fr/avidemux" | ||
|
||
# Multiple licenses because of all the bundled stuff. | ||
LICENSE="GPL-1 GPL-2 MIT PSF-2 public-domain" | ||
SLOT="2.6" | ||
IUSE="aac aften a52 alsa amr dcaenc debug dts fdk fontconfig fribidi jack lame libsamplerate cpu_flags_x86_mmx opengl nvenc opus oss pulseaudio qt4 qt5 vorbis truetype twolame xv xvid x264 x265 vdpau vpx" | ||
REQUIRED_USE="${PYTHON_REQUIRED_USE}" | ||
|
||
if [[ ${PV} == *9999* ]] ; then | ||
EGIT_REPO_URI="https://github.com/mean00/avidemux2.git" | ||
EGIT_CHECKOUT_DIR=${WORKDIR} | ||
|
||
inherit git-r3 | ||
else | ||
MY_PN="${PN/-plugins/}" | ||
MY_P="${MY_PN}_${PV}" | ||
SRC_URI="mirror://sourceforge/${MY_PN}/${MY_PN}/${PV}/${MY_P}.tar.gz" | ||
KEYWORDS="~amd64 ~x86" | ||
fi | ||
|
||
RDEPEND=" | ||
~media-libs/avidemux-core-${PV}:${SLOT}[vdpau?] | ||
~media-video/avidemux-${PV}:${SLOT}[opengl?,qt4?,qt5?] | ||
>=dev-lang/spidermonkey-1.5-r2:0= | ||
dev-libs/libxml2:2 | ||
media-libs/a52dec:0 | ||
media-libs/libass:0= | ||
media-libs/libmad:0 | ||
media-libs/libmp4v2:0 | ||
media-libs/libpng:0= | ||
virtual/libiconv:0 | ||
aac? ( | ||
media-libs/faac:0 | ||
media-libs/faad2:0 | ||
) | ||
aften? ( media-libs/aften:0 ) | ||
alsa? ( >=media-libs/alsa-lib-1.0.3b-r2:0 ) | ||
amr? ( media-libs/opencore-amr:0 ) | ||
dcaenc? ( media-sound/dcaenc:0 ) | ||
dts? ( media-libs/libdca:0 ) | ||
fdk? ( media-libs/fdk-aac:0 ) | ||
fontconfig? ( media-libs/fontconfig:1.0 ) | ||
fribidi? ( dev-libs/fribidi:0 ) | ||
jack? ( | ||
media-sound/jack-audio-connection-kit:0 | ||
libsamplerate? ( media-libs/libsamplerate:0 ) | ||
) | ||
lame? ( media-sound/lame:0 ) | ||
nvenc? ( amd64? ( media-video/nvidia_video_sdk:0 ) ) | ||
opus? ( media-libs/opus:0 ) | ||
pulseaudio? ( media-sound/pulseaudio:0 ) | ||
truetype? ( media-libs/freetype:2 ) | ||
twolame? ( media-sound/twolame:0 ) | ||
x264? ( media-libs/x264:0= ) | ||
x265? ( media-libs/x265:0= ) | ||
xv? ( | ||
x11-libs/libX11:0 | ||
x11-libs/libXext:0 | ||
x11-libs/libXv:0 | ||
) | ||
xvid? ( media-libs/xvid:0 ) | ||
vorbis? ( media-libs/libvorbis:0 ) | ||
vpx? ( media-libs/libvpx:0 ) | ||
${PYTHON_DEPS} | ||
" | ||
DEPEND="${RDEPEND} | ||
oss? ( virtual/os-headers:0 )" | ||
|
||
S="${WORKDIR}/${MY_P}" | ||
|
||
PATCHES=( "${FILESDIR}"/${PN}-2.6.20-optional-pulse.patch ) | ||
|
||
src_prepare() { | ||
default | ||
|
||
#Don't reapply PATCHES during cmake-utils_src_prepare | ||
unset PATCHES | ||
|
||
processes="buildPluginsCommon:avidemux_plugins | ||
buildPluginsCLI:avidemux_plugins" | ||
use qt4 && processes+=" buildPluginsQt4:avidemux_plugins" | ||
|
||
for process in ${processes} ; do | ||
CMAKE_USE_DIR="${S}"/${process#*:} cmake-utils_src_prepare | ||
done | ||
} | ||
|
||
src_configure() { | ||
# Add lax vector typing for PowerPC. | ||
if use ppc || use ppc64 ; then | ||
append-cflags -flax-vector-conversions | ||
fi | ||
|
||
# See bug 432322. | ||
use x86 && replace-flags -O0 -O1 | ||
|
||
for process in ${processes} ; do | ||
local build="${WORKDIR}/${P}_build/${process%%:*}" | ||
|
||
local mycmakeargs=( | ||
-DAVIDEMUX_SOURCE_DIR='${S}' | ||
-DPLUGIN_UI=$(echo ${build/buildPlugins/} | tr '[:lower:]' '[:upper:]') | ||
-DFAAC="$(usex aac)" | ||
-DFAAD="$(usex aac)" | ||
-DALSA="$(usex alsa)" | ||
-DAFTEN="$(usex aften)" | ||
-DDCAENC="$(usex dcaenc)" | ||
-DFDK_AAC="$(usex fdk)" | ||
-DOPENCORE_AMRWB="$(usex amr)" | ||
-DOPENCORE_AMRNB="$(usex amr)" | ||
-DLIBDCA="$(usex dts)" | ||
-DFONTCONFIG="$(usex fontconfig)" | ||
-DJACK="$(usex jack)" | ||
-DLAME="$(usex lame)" | ||
-DNVENC="$(usex nvenc)" | ||
-DOPUS="$(usex opus)" | ||
-DOSS="$(usex oss)" | ||
-DPULSEAUDIOSIMPLE="$(usex pulseaudio)" | ||
-DQT4="$(usex qt4)" | ||
-DFREETYPE2="$(usex truetype)" | ||
-DTWOLAME="$(usex twolame)" | ||
-DX264="$(usex x264)" | ||
-DX265="$(usex x265)" | ||
-DXVIDEO="$(usex xv)" | ||
-DXVID="$(usex xvid)" | ||
-DVDPAU="$(usex vdpau)" | ||
-DVORBIS="$(usex vorbis)" | ||
-DLIBVORBIS="$(usex vorbis)" | ||
-DVPXDEC="$(usex vpx)" | ||
-DUSE_EXTERNAL_LIBA52=yes | ||
-DUSE_EXTERNAL_LIBASS=yes | ||
-DUSE_EXTERNAL_LIBMAD=yes | ||
-DUSE_EXTERNAL_LIBMP4V2=yes | ||
) | ||
|
||
if use qt5 ; then | ||
mycmakeargs+=( -DENABLE_QT5=True ) | ||
fi | ||
|
||
if use debug ; then | ||
mycmakeargs+=( -DVERBOSE=1 -DADM_DEBUG=1 ) | ||
fi | ||
|
||
CMAKE_USE_DIR="${S}"/${process#*:} BUILD_DIR="${build}" cmake-utils_src_configure | ||
done | ||
} | ||
|
||
src_compile() { | ||
for process in ${processes} ; do | ||
local build="${WORKDIR}/${P}_build/${process%%:*}" | ||
BUILD_DIR="${build}" cmake-utils_src_compile | ||
done | ||
} | ||
|
||
src_install() { | ||
for process in ${processes} ; do | ||
# cmake-utils_src_install doesn't respect BUILD_DIR | ||
# and there sometimes is a preinstall phase present. | ||
pushd "${WORKDIR}/${P}_build/${process%%:*}" > /dev/null || die | ||
grep '^preinstall/fast' Makefile && emake DESTDIR="${D}" preinstall/fast | ||
grep '^install/fast' Makefile && emake DESTDIR="${D}" install/fast | ||
popd > /dev/null || die | ||
done | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Oops, something went wrong.