Skip to content

Commit

Permalink
app-benchmarks/geekbench: New package
Browse files Browse the repository at this point in the history
  • Loading branch information
ConiKost authored and mgorny committed Mar 24, 2018
1 parent 1fc6c76 commit b272f01
Show file tree
Hide file tree
Showing 6 changed files with 188 additions and 0 deletions.
4 changes: 4 additions & 0 deletions app-benchmarks/geekbench/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1,4 @@
DIST Geekbench-2.4.2-LinuxARM.tar.gz 1921401 BLAKE2B 34d86178e35d586b79182b3320303258a5dcc6f169cee0134f1114927ff52745d5f6c0b5d604698e45a464a157454a249cab8e3114b01dad3f7b693ca45a5b0b SHA512 0acc0ce61aa5d2575976c66aeae6ebb88ba895dd89c07daf55e2c7af344858a620336f3e79ccfc5e7b8829caa9d600f97a35a4d6e4da630d19d723dd887fdafe
DIST Geekbench-2.4.3-Linux.tar.gz 3337551 BLAKE2B cb660f3c08cc812cb23374032490a148449a36845fe63320788432493581ec6bd5958bf178d83d68b532ffbe5c7ee13e92b0bb00c0aca968bb2e499453f1b7a7 SHA512 d84e13eb5fd28fb232a5f93aa76f4855adcb9ccffbcd90dacc3e2b45231afd82e78d40c63f729391e5d00e95c14653e83757faca4e543c6306dd913c4e0edb87
DIST Geekbench-3.4.2-Linux.tar.gz 9986039 BLAKE2B 63d7e768d65bc033260a0d99da17df2e518750f19882e63dbc9bbe6ff0b52a8cddb35b9143e85c01838bf5d77a04599578fc0a57a3e6fd89e7aec8c8ffdd4f5b SHA512 a61a5d5481682baefdce64f6054c3373900e8cd585dcbfa2feabbf386032986b40b603619c552102401a83e0b748831d00af5b5b5278e88ef42dee176adf06e9
DIST Geekbench-4.2.2-Linux.tar.gz 71028908 BLAKE2B 640df8bb207ea1a0a8b5c7fc4725b517406826b5d9045eb2970515c4d175be1e9972582544f7088c113e725c067ec119d390c2cef183108dd592005e60740e8a SHA512 616b8eed266407154a3dcf09af5c4047cf0be8f852d6aae663f26a29d4a9df3bcc2b4c233b21614071ee0be3ca7316c5f09bccd4769b6db78a4e6187e281920c
43 changes: 43 additions & 0 deletions app-benchmarks/geekbench/geekbench-2.4.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,43 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

DESCRIPTION="A Cross-Platform Benchmark for Android, iOS, Linux, MacOS and Windows"
HOMEPAGE="https://www.geekbench.com"
SRC_URI="https://cdn.primatelabs.com/Geekbench-${PV}-LinuxARM.tar.gz"

KEYWORDS="-* ~arm"
LICENSE="geekbench"
SLOT="2"

RDEPEND="sys-devel/gcc
sys-libs/glibc"

RESTRICT="bindist fetch mirror strip"

S="${WORKDIR}/dist/Geekbench-${PV}-LinuxARM"

QA_PREBUILT="opt/geekbench2/geekbench opt/geekbench2/geekbench_arm_32"

pkg_nofetch() {
elog "Please download https://cdn.primatelabs.com/${A}"
elog "and place it in your DISTDIR directory."
}

src_install() {
exeinto "/opt/geekbench2"
doexe "geekbench" "geekbench_arm_32"

insinto "/opt/geekbench2"
doins "geekbench.plar"

dodir "/opt/bin"
dosym "../geekbench2/geekbench" "/opt/bin/geekbench2"
}

pkg_postinst() {
elog "If you have purchased a commercial license, you can enter"
elog "your email address and your license key with the following command:"
elog "geekbench2 -r <email address> <license key>"
}
43 changes: 43 additions & 0 deletions app-benchmarks/geekbench/geekbench-2.4.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,43 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

DESCRIPTION="A Cross-Platform Benchmark for Android, iOS, Linux, MacOS and Windows"
HOMEPAGE="https://www.geekbench.com"
SRC_URI="https://cdn.primatelabs.com/Geekbench-${PV}-Linux.tar.gz"

KEYWORDS="-* ~amd64 ~x86"
LICENSE="geekbench"
SLOT="2"

RDEPEND="sys-devel/gcc
sys-libs/glibc"

RESTRICT="bindist fetch mirror strip"

S="${WORKDIR}/dist/Geekbench-${PV}-Linux"

QA_PREBUILT="opt/geekbench2/geekbench opt/geekbench2/geekbench_x86_32 opt/geekbench2/geekbench_x86_64"

pkg_nofetch() {
elog "Please download ${A} from ${HOMEPAGE}/${PN}2/download/linux"
elog "and place it in your DISTDIR directory."
}

src_install() {
exeinto "/opt/geekbench2"
doexe "geekbench" "geekbench_x86_32" "geekbench_x86_64"

insinto "/opt/geekbench2"
doins "geekbench.plar"

dodir "/opt/bin"
dosym "../geekbench2/geekbench" "/opt/bin/geekbench2"
}

pkg_postinst() {
elog "If you have purchased a commercial license, you can enter"
elog "your email address and your license key with the following command:"
elog "geekbench2 -r <email address> <license key>"
}
43 changes: 43 additions & 0 deletions app-benchmarks/geekbench/geekbench-3.4.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,43 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

DESCRIPTION="A Cross-Platform Benchmark for Android, iOS, Linux, MacOS and Windows"
HOMEPAGE="https://www.geekbench.com"
SRC_URI="https://cdn.primatelabs.com/Geekbench-${PV}-Linux.tar.gz"

KEYWORDS="-* ~amd64 ~x86"
LICENSE="geekbench"
SLOT="3"

RDEPEND="sys-devel/gcc
sys-libs/glibc"

RESTRICT="bindist fetch mirror strip"

S="${WORKDIR}/dist/Geekbench-${PV}-Linux"

QA_PREBUILT="opt/geekbench3/geekbench opt/geekbench3/geekbench_x86_32 opt/geekbench3/geekbench_x86_64"

pkg_nofetch() {
elog "Please download ${A} from ${HOMEPAGE}/${PN}3/download/linux"
elog "and place it in your DISTDIR directory."
}

src_install() {
exeinto "/opt/geekbench3"
doexe "geekbench" "geekbench_x86_32" "geekbench_x86_64"

insinto "/opt/geekbench3"
doins "geekbench.plar"

dodir "/opt/bin"
dosym "../geekbench3/geekbench" "/opt/bin/geekbench3"
}

pkg_postinst() {
elog "If you have purchased a commercial license, you can enter"
elog "your email address and your license key with the following command:"
elog "geekbench3 -r <email address> <license key>"
}
43 changes: 43 additions & 0 deletions app-benchmarks/geekbench/geekbench-4.2.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,43 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

DESCRIPTION="A Cross-Platform Benchmark for Android, iOS, Linux, MacOS and Windows"
HOMEPAGE="https://www.geekbench.com"
SRC_URI="https://cdn.geekbench.com/Geekbench-${PV}-Linux.tar.gz"

KEYWORDS="-* ~amd64 ~x86"
LICENSE="geekbench"
SLOT="4"

RDEPEND="sys-devel/gcc
sys-libs/glibc"

RESTRICT="bindist fetch mirror strip"

S="${WORKDIR}/Geekbench-${PV}-Linux"

QA_PREBUILT="opt/geekbench4/geekbench4 opt/geekbench4/geekbench_x86_32 opt/geekbench4/geekbench_x86_64"

pkg_nofetch() {
elog "Please download ${A} from ${HOMEPAGE}/download/linux"
elog "and place it in your DISTDIR directory."
}

src_install() {
exeinto "/opt/geekbench4"
doexe "geekbench4" "geekbench_x86_32" "geekbench_x86_64"

insinto "/opt/geekbench4"
doins "geekbench.plar"

dodir "/opt/bin"
dosym "../geekbench4/geekbench4" "/opt/bin/geekbench4"
}

pkg_postinst() {
elog "If you have purchased a commercial license, you can enter"
elog "your email address and your license key with the following command:"
elog "geekbench4 -r <email address> <license key>"
}
12 changes: 12 additions & 0 deletions app-benchmarks/geekbench/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>[email protected]</email>
<name>Conrad Kostecki</name>
</maintainer>
<maintainer type="project">
<email>[email protected]</email>
<name>Proxy Maintainers</name>
</maintainer>
</pkgmetadata>

0 comments on commit b272f01

Please sign in to comment.