Skip to content

Commit

Permalink
dev-python/docker-py: Version bump to 2.6.1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.14, Repoman-2.3.5
  • Loading branch information
mrueg committed Nov 14, 2017
1 parent c32ea00 commit b28c48f
Show file tree
Hide file tree
Showing 2 changed files with 57 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/docker-py/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -5,3 +5,4 @@ DIST docker-py-2.3.0.tar.gz 177920 SHA256 56ca8acbe7f7e9cffbfc8e1a2a256ec0fbe322
DIST docker-py-2.4.2.tar.gz 180890 SHA256 53f72ae0c3329f48b2301eb64bc63ca0da2cdc9e8e24c87a76dab91da713ca2c SHA512 3367066b2acd96b85bef28aef00c91d752dc25b3055575b4f2f9c0b981eb4bca81a742bc6da5f97cf039cd9c7d818e3f80101997fe3a2e2c6f3a9c42fd3111c2 WHIRLPOOL f32495086c5b3a67bec365033d54b52ed77b156ec262239b10c5115e88e84be1bdd25562df9e04f93c18dbab68c378ef58e17d321ea54a2a0f8472381266b976
DIST docker-py-2.5.1.tar.gz 183413 SHA256 136338dbe7b9d8d1c24a6f968f43566e23b79ce1dfbcd33c6a201985b702c4e0 SHA512 5862589fbb831c6960ce5e6d256c716b64c2ad28d9c3542fd290f80b0deeac3a4985a96f3a9e04f55b184b03498900d8d520085cbda223b54480db4bbf977d1e WHIRLPOOL 52a0338c4df311cc1d01194f2f50fb02fa6aba8dc818f1caffffbd0fe686a2e8ac8b0646c93d7ad5911129b24ade3fb3847eea3609b9aef188e7601596e6fe34
DIST docker-py-2.6.0.tar.gz 191901 SHA256 fc6e4b80c05a9c3cf5010facce3a48a1d87c2f30d234c3799c0a3a94ded5ec1a SHA512 4b574510ad57ec3b9853b42d36fc1870b093872ed02f339cc5de1d7b0687196c00fee3d8b7182d06800e49eaff71b5942537290526590288954c34b7b8ead331 WHIRLPOOL f07bcdb35a8ede05db81b4363b437db6938df519562e2d37f1b224dcf93b49c5e614280f7a6cf4e148af795af380538e9cb409c7923b3125e23a38ed4e20243e
DIST docker-py-2.6.1.tar.gz 191919 SHA256 6cca44a1f8fc449769695d2bc85be2971d1f12e34588e326c54c2593fdff1b01 SHA512 ee5e646e6b45ed9fafd8bd32c4cdeff565988ff77b21303b0c1b4b1ea56a9d51d04c4f8c9595159efff09cfd8962c1a7060c1910d48cbfb4a2024e90b662ae58 WHIRLPOOL 78cf714976128bcf15abd7235768f813f344cf898caf6f5dc46dae117f420262b8d87a57bfe33f7b5a05bc16e41828aa409709b34a7e58a48af1fbc41e416b8f
56 changes: 56 additions & 0 deletions dev-python/docker-py/docker-py-2.6.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,56 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )

inherit distutils-r1

DESCRIPTION="Python client for Docker"
HOMEPAGE="https://github.com/docker/docker-py"
SRC_URI="https://github.com/docker/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~x86"
IUSE="doc test"

RDEPEND="
>=dev-python/docker-pycreds-0.2.1[${PYTHON_USEDEP}]
!~dev-python/requests-2.18.0[${PYTHON_USEDEP}]
!~dev-python/requests-2.12.2[${PYTHON_USEDEP}]
>=dev-python/requests-2.11.1[${PYTHON_USEDEP}]
>=dev-python/six-1.4.0[${PYTHON_USEDEP}]
>=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
$(python_gen_cond_dep '>=dev-python/backports-ssl-match-hostname-3.5[${PYTHON_USEDEP}]' 'python2_7' 'python3_4' )
$(python_gen_cond_dep '>=dev-python/ipaddress-1.0.16[${PYTHON_USEDEP}]' 'python2_7' )
"
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
${RDEPEND}
>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
dev-python/pytest-runner[${PYTHON_USEDEP}]
>=dev-python/pytest-2.9.1[${PYTHON_USEDEP}]
)
doc? (
dev-python/recommonmark[${PYTHON_USEDEP}]
>=dev-python/sphinx-1.4.6[${PYTHON_USEDEP}]
)
"

python_prepare_all() {
sed -i -e "s/import pip//" -e "s/if 'docker-py'.*/if False:/" setup.py || die
distutils-r1_python_prepare_all
}

python_compile_all() {
if use doc; then
sphinx-build docs html || die "docs failed to build"
HTML_DOCS=( html/. )
fi
}

python_test() {
py.test tests/unit/ || die "tests failed under ${EPYTHON}"
}

0 comments on commit b28c48f

Please sign in to comment.