Skip to content

Commit

Permalink
sys-freebsd/freebsd-usbin: tidy up ebuilds.
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.13, Repoman-2.3.4
  • Loading branch information
monsieurp committed Nov 21, 2017
1 parent f43dffd commit b2a5a2d
Show file tree
Hide file tree
Showing 3 changed files with 20 additions and 20 deletions.
14 changes: 7 additions & 7 deletions sys-freebsd/freebsd-usbin/freebsd-usbin-10.3-r1.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2016 Gentoo Foundation
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=5
Expand Down Expand Up @@ -130,9 +130,9 @@ src_install() {

# Most of these now come from openrc.
for util in iscsid nfs nfsuserd rpc.statd rpc.lockd; do
newinitd "${FILESDIR}/"${util}.initd ${util} || die
newinitd "${FILESDIR}/"${util}.initd ${util}
if [[ -e "${FILESDIR}"/${util}.confd ]]; then \
newconfd "${FILESDIR}"/${util}.confd ${util} || die
newconfd "${FILESDIR}"/${util}.confd ${util}
fi
done

Expand All @@ -147,17 +147,17 @@ EOS

# Install the pw.conf file to let pw use Gentoo's skel location
insinto /etc
doins "${FILESDIR}/pw.conf" || die
doins "${FILESDIR}/pw.conf"

cd "${WORKDIR}/etc" || die
doins apmd.conf syslog.conf newsyslog.conf nscd.conf || die
doins apmd.conf syslog.conf newsyslog.conf nscd.conf

insinto /etc/ppp
doins ppp/ppp.conf || die
doins ppp/ppp.conf

if use bluetooth; then
insinto /etc/bluetooth
doins bluetooth/* || die
doins bluetooth/*
rm -f "${D}"/etc/bluetooth/Makefile
fi

Expand Down
14 changes: 7 additions & 7 deletions sys-freebsd/freebsd-usbin/freebsd-usbin-11.0-r1.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2016 Gentoo Foundation
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=5
Expand Down Expand Up @@ -128,9 +128,9 @@ src_install() {

# Most of these now come from openrc.
for util in iscsid nfs nfsuserd rpc.statd rpc.lockd; do
newinitd "${FILESDIR}/"${util}.initd ${util} || die
newinitd "${FILESDIR}/"${util}.initd ${util}
if [[ -e "${FILESDIR}"/${util}.confd ]]; then \
newconfd "${FILESDIR}"/${util}.confd ${util} || die
newconfd "${FILESDIR}"/${util}.confd ${util}
fi
done

Expand All @@ -145,20 +145,20 @@ EOS

# Install the pw.conf file to let pw use Gentoo's skel location
insinto /etc
doins "${FILESDIR}/pw.conf" || die
doins "${FILESDIR}/pw.conf"

cd "${WORKDIR}/etc" || die
doins apmd.conf syslog.conf newsyslog.conf nscd.conf || die
doins apmd.conf syslog.conf newsyslog.conf nscd.conf

if use bluetooth; then
insinto /etc/bluetooth
doins bluetooth/* || die
doins bluetooth/*
rm -f "${D}"/etc/bluetooth/Makefile
fi

cd "${S}"/ppp || die
insinto /etc/ppp
doins ppp.conf || die
doins ppp.conf

# Install the periodic stuff (needs probably to be ported in a more
# gentooish way)
Expand Down
12 changes: 6 additions & 6 deletions sys-freebsd/freebsd-usbin/freebsd-usbin-11.1.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -129,9 +129,9 @@ src_install() {

# Most of these now come from openrc.
for util in iscsid nfs nfsuserd rpc.statd rpc.lockd; do
newinitd "${FILESDIR}/"${util}.initd ${util} || die
newinitd "${FILESDIR}/"${util}.initd ${util}
if [[ -e "${FILESDIR}"/${util}.confd ]]; then \
newconfd "${FILESDIR}"/${util}.confd ${util} || die
newconfd "${FILESDIR}"/${util}.confd ${util}
fi
done

Expand All @@ -146,20 +146,20 @@ EOS

# Install the pw.conf file to let pw use Gentoo's skel location
insinto /etc
doins "${FILESDIR}/pw.conf" || die
doins "${FILESDIR}/pw.conf"

cd "${WORKDIR}/etc" || die
doins apmd.conf syslog.conf newsyslog.conf nscd.conf || die
doins apmd.conf syslog.conf newsyslog.conf nscd.conf

if use bluetooth; then
insinto /etc/bluetooth
doins bluetooth/* || die
doins bluetooth/*
rm -f "${D}"/etc/bluetooth/Makefile
fi

cd "${S}"/ppp || die
insinto /etc/ppp
doins ppp.conf || die
doins ppp.conf

# Install the periodic stuff (needs probably to be ported in a more
# gentooish way)
Expand Down

0 comments on commit b2a5a2d

Please sign in to comment.