Skip to content

Commit

Permalink
mate-extra/caja-dropbox: add 1.26.0
Browse files Browse the repository at this point in the history
Signed-off-by: Oz N Tiram <[email protected]>
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
oz123 authored and thesamesam committed Oct 24, 2022
1 parent 951d754 commit b2a9ca8
Show file tree
Hide file tree
Showing 2 changed files with 91 additions and 0 deletions.
1 change: 1 addition & 0 deletions mate-extra/caja-dropbox/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST caja-dropbox-1.24.0.tar.xz 309024 BLAKE2B 2ae560dcd6e744fe96d9e0fcd876a899c22ad06b8238c2ad9e5394cf80aa8844cd634431dc6bb245396e6d919da857645488214880947e5b90413c254cd4c6a2 SHA512 64d699b4c3957d5996ef69936b4b2746641bc2db4efb7b23535febf5eed3ee767330927aeeda67747c0d72e0f052a2979ae2160ffaaf01e4fd82aff68a5f27bf
DIST caja-dropbox-1.26.0.tar.xz 361352 BLAKE2B 877196d1c6900904314e4ea0f4220821febe123395b1af8eb30e6557beea068ce572621473e733bf41f597a9c72d03ca0b2666cb7c335bbdcaefec06ffd577b9 SHA512 f96e3ddf4434936b04e992044d6cd5797b6ff77ead573e8e9a6493f4308d9716f47871f1fd7f08b0dbf7f2659f107511b6be65e98632a0892ebfff0a9888dbe7
90 changes: 90 additions & 0 deletions mate-extra/caja-dropbox/caja-dropbox-1.26.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,90 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{8,9,10,11} )
MATE_LA_PUNT="yes"

inherit mate python-single-r1 linux-info

if [[ ${PV} != 9999 ]]; then
KEYWORDS="~amd64 ~x86"
fi

DESCRIPTION="Store, Sync and Share Files Online"
LICENSE="CC-BY-ND-3.0 GPL-3+ public-domain"
SLOT="0"

IUSE="debug nls"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"

COMMON_DEPEND="${PYTHON_DEPS}
dev-libs/atk
>=dev-libs/glib-2.50:2
$(python_gen_cond_dep \
dev-python/pygobject:3[${PYTHON_USEDEP}]
)
>=mate-base/caja-1.19.1
mate-extra/caja-extensions
media-libs/fontconfig:1.0
media-libs/freetype:2
x11-libs/cairo
x11-libs/gdk-pixbuf:2
>=x11-libs/gtk+-3.22:3
x11-libs/libXinerama
x11-libs/pango
"

RDEPEND="${COMMON_DEPEND}
net-misc/dropbox
"

BDEPEND="${COMMON_DEPEND}
dev-python/docutils
virtual/pkgconfig
"

CONFIG_CHECK="~INOTIFY_USER"

pkg_setup() {
python-single-r1_pkg_setup
check_extra_config
}

MATE_FORCE_AUTORECONF=true

src_prepare() {
# Use system dropbox.
sed -e "s|~/[.]dropbox-dist|/opt/dropbox|" \
-e 's|\(DROPBOXD_PATH = \).*|\1"/opt/dropbox/dropboxd"|' \
-i caja-dropbox.in || die

sed -e 's|\[rst2man\]|\[rst2man\.py\]|' -i configure.ac || die

mate_src_prepare
}

src_configure() {
mate_src_configure \
$(use_enable debug) \
$(use_enable nls)
}

src_install() {
python_fix_shebang caja-dropbox.in

mate_src_install
}

pkg_postinst() {
mate_pkg_postinst

for v in ${REPLACING_VERSIONS}; do
if ver_test "${v}" "-lt" "1.24.0-r1" || ver_test "${v}" "-eq" "9999"; then
ewarn "Starting with ${CATEGORY}/${PN}-1.24.0-r1, ${PN} now no longer"
ewarn "configures caja-dropbox to use its own group. This brings caja-dropbox in line"
ewarn "with nautilus-dropbox and dolphin-plugins-dropbox. You may remove the 'dropbox' group."
fi
done
}

0 comments on commit b2a9ca8

Please sign in to comment.