Skip to content

Commit

Permalink
app-doc/kicad-doc: Add 4.0.4 and fix missing language dependency
Browse files Browse the repository at this point in the history
Gentoo Bug: #590156

Package-Manager: portage-2.3.2
  • Loading branch information
zpuskas authored and gktrk committed Nov 6, 2016
1 parent 7df9115 commit b2e95b4
Show file tree
Hide file tree
Showing 4 changed files with 75 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-doc/kicad-doc/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST kicad-doc-4.0.1.tar.gz 23365382 SHA256 be8dc4bddb89869996956d3d1421584c5a8197282997902e22fda888a8d433bb SHA512 ae57a9c29f3cd4b3d85d4b7d7bc940957c33b0e1c1404b82c8a9261695c0670866cb4a95ab7ad5c35b1faa6fbd3969f277467fa7d33e38e728a3dd9b65203021 WHIRLPOOL d9834312a0a315bf1d5dca048999d5adcb2ee60c42a41d8266522ad6c0ca49ec7bad5c9bad322b6d73c41c9f24cb1f4088d6889c6a51abf4671271dd7ec8af9d
DIST kicad-doc-4.0.2.tar.gz 23365338 SHA256 4a475b3831f9a54a20dc94631cada3e305ede23345a6b4059077ac6900f3d35a SHA512 8cf2ff11141d3a5319d3b17a13648903518aaf0625802762df875550dd5811515e8a65d7414859624a18402cc6289ec70247a6c1f235081768ee344ec42c3b35 WHIRLPOOL f0279935fd823c62a6545afab6c2916173a72b5c881f71d8118ef897972e2d9de2c567944689a70aeeb4bae9b4938f636e9c526d0fd838bb42b8e2b4b4d23b4f
DIST kicad-doc-4.0.4.tar.gz 33705865 SHA256 5564217076641926a2523d4dc66e78810de2fe4b5bd4d2f0ba40a522203c4d27 SHA512 97a45ebbd11ab7f92eff1409bc03512b7685fb4a85dd1d87675e92742cc6672a1332c5fe8d63577eba93ed976af1bb4acaa461dbada5e4695a161cefa82c9ff4 WHIRLPOOL be03128787fc9461e9220845a42acd6d7a6bac5adfdc3106365e8c46e7bd185b6a25857b66c91d444a13a03184fb3a260d04d156768304bddb577ce8e776676a
1 change: 1 addition & 0 deletions app-doc/kicad-doc/kicad-doc-4.0.1.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -21,6 +21,7 @@ done

DEPEND=">=app-text/asciidoc-8.6.9
app-text/dblatex
app-text/texlive:=[l10n_en?,l10n_fr?,l10n_it?,l10n_ja?,l10n_nl?,l10n_pl?]
>=app-text/po4a-0.45
>=sys-devel/gettext-0.18
dev-util/source-highlight
Expand Down
1 change: 1 addition & 0 deletions app-doc/kicad-doc/kicad-doc-4.0.2.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -21,6 +21,7 @@ done

DEPEND=">=app-text/asciidoc-8.6.9
app-text/dblatex
app-text/texlive:=[l10n_en?,l10n_fr?,l10n_it?,l10n_ja?,l10n_nl?,l10n_pl?]
>=app-text/po4a-0.45
>=sys-devel/gettext-0.18
dev-util/source-highlight
Expand Down
72 changes: 72 additions & 0 deletions app-doc/kicad-doc/kicad-doc-4.0.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,72 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit cmake-utils

DESCRIPTION="Electronic Schematic and PCB design tools manuals"
HOMEPAGE="http://www.kicad-pcb.org/"
SRC_URI="https://github.com/KiCad/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="|| ( GPL-3+ CC-BY-3.0 ) GPL-2"
SLOT="0"
KEYWORDS="~amd64"
IUSE="html pdf"
LANGS="en fr it ja nl pl"
for lang in ${LANGS}; do
IUSE+=" l10n_${lang}"
done

DEPEND=">=app-text/asciidoc-8.6.9
app-text/dblatex
app-text/texlive:=[l10n_en?,l10n_fr?,l10n_it?,l10n_ja?,l10n_nl?,l10n_pl?]
>=app-text/po4a-0.45
>=sys-devel/gettext-0.18
dev-util/source-highlight
dev-perl/Unicode-LineBreak
l10n_ja? ( media-fonts/vlgothic )"
RDEPEND=""

src_prepare() {
DOCPATH="KICAD_DOC_INSTALL_PATH share/doc/kicad"
sed "s|${DOCPATH}|${DOCPATH}-${PV}|g" -i CMakeLists.txt || die "sed failed"
}

src_configure() {
local formats=""
local doclang=""
local format lang

# construct format string
for format in html pdf; do
use ${format} && formats+="${format};"
done
if [[ -z ${formats} ]]; then
formats="html;"
ewarn "Neither \"html\" nor \"pdf\" USE flag set, using html."
fi

# find out which language is requested
for lang in ${LANGS}; do
if use l10n_${lang}; then
if [[ -z ${doclang} ]]; then
doclang="${lang}"
else
ewarn "Only one single language can be enabled." \
"Using \"${doclang}\", ignoring \"${lang}\"."
fi
fi
done
if [[ -z ${doclang} ]]; then
doclang="en"
ewarn "No language flag set, falling back to \"en\"."
fi

local mycmakeargs=(
-DBUILD_FORMATS="${formats}"
-DSINGLE_LANGUAGE="${doclang}"
)
cmake-utils_src_configure
}

0 comments on commit b2e95b4

Please sign in to comment.