forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-libs/ucommon: Bump to version 6.5.7
Package-Manager: portage-2.2.20.1 Signed-off-by: Lars Wendler <[email protected]>
- Loading branch information
Lars Wendler
committed
Aug 28, 2015
1 parent
bd48e08
commit b2ebf83
Showing
2 changed files
with
82 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,81 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI="5" | ||
|
||
AUTOTOOLS_AUTORECONF=1 | ||
|
||
inherit autotools-utils eutils | ||
|
||
DESCRIPTION="Portable C++ runtime for threads and sockets" | ||
HOMEPAGE="https://www.gnu.org/software/commoncpp" | ||
SRC_URI="mirror://gnu/commoncpp/${P}.tar.gz" | ||
|
||
LICENSE="LGPL-3" | ||
SLOT="0/6" | ||
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux" | ||
IUSE="doc static-libs socks +cxx debug ssl gnutls" | ||
|
||
RDEPEND=" | ||
ssl? ( | ||
!gnutls? ( dev-libs/openssl:0= ) | ||
gnutls? ( | ||
net-libs/gnutls:0= | ||
dev-libs/libgcrypt:0= | ||
) | ||
)" | ||
|
||
DEPEND="virtual/pkgconfig | ||
doc? ( app-doc/doxygen ) | ||
${RDEPEND}" | ||
|
||
DOCS=(README NEWS SUPPORT ChangeLog AUTHORS) | ||
PATCHES=( | ||
"${FILESDIR}/6.1/install_gcrypt.m4_file.patch" | ||
"${FILESDIR}/${PN}-6.3.1-gcrypt_autotools.patch" | ||
) | ||
|
||
# Needed for doxygen, bug #526726 | ||
AUTOTOOLS_IN_SOURCE_BUILD=1 | ||
|
||
src_prepare() { | ||
# Aclocal 1.13 deprecated error BGO #467674 | ||
sed -e 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g' -i configure.ac || die | ||
|
||
# don't install latex and rtf documents | ||
sed -e '/^GENERATE_LATEX/s@YES@NO@' -e '/^GENERATE_RTF/s@YES@NO@' \ | ||
-i Doxyfile.in || die | ||
|
||
autotools-utils_src_prepare | ||
} | ||
|
||
src_configure() { | ||
local myconf="" | ||
if use ssl; then | ||
myconf+=" --with-sslstack=$(usex gnutls gnu ssl) " | ||
else | ||
myconf+=" --with-sslstack=nossl "; | ||
fi | ||
|
||
local myeconfargs=( | ||
$(use_enable socks) | ||
$(use_enable cxx stdcpp) | ||
${myconf} | ||
--enable-atomics | ||
--with-pkg-config | ||
) | ||
autotools-utils_src_configure | ||
} | ||
|
||
src_compile() { | ||
autotools-utils_src_compile | ||
use doc && autotools-utils_src_compile doxy | ||
} | ||
|
||
src_install() { | ||
autotools-utils_src_install | ||
if use doc; then | ||
dohtml doc/html/* | ||
fi | ||
} |