Skip to content

Commit

Permalink
app-shells/fish: bump to 3.0.0
Browse files Browse the repository at this point in the history
fish 3 is a major release, which introduces some breaking changes.
Although most existing scripts will continue to work,
they should be reviewed against the list contained below.

Release notes: https://github.com/fish-shell/fish-shell/releases/tag/3.0.0

Package-Manager: Portage-2.3.53, Repoman-2.3.12
Signed-off-by: Georgy Yakovlev <[email protected]>
  • Loading branch information
gyakovlev committed Dec 28, 2018
1 parent 8641e80 commit b2fd53f
Show file tree
Hide file tree
Showing 2 changed files with 73 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-shells/fish/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST fish-2.6.0.tar.gz 3575346 BLAKE2B 8697dc6e50836d93d0ed22663e86016fec8e567cd4e129ea92008f52da6dd629bf11b70719beabe5c08bd3d7ba43d8017441f103d49a82c0faec3bc749e83764 SHA512 d4ded5ce24600e85673a7bb016e9dc36bce999b27f40e6b1ce0b9ca49a421be2d444d9d2b6f178f6eee963e59daa4a65df4c3de2a8086a610486f758fcfb0ed1
DIST fish-2.7.1.tar.gz 5760550 BLAKE2B 71568a3a17f4222b05a314464a61fceb241409a7d42c46249486ca742ef0cf990c46d693bcc22521c18f58a558e6aab35759d0da6eb62ee6611a2a7946fe714d SHA512 45ee3453404c5d6c56d307b4cd19197de862f9f42d7fa06461acec56dea7146db5675cf6419dd5f72e939b3e4b1955d3761098df1de89a8cebe47645eb6f7a4b
DIST fish-3.0.0.tar.gz 6472393 BLAKE2B 9a8226ca4dce40a7bbc62ad5791c5238d1257cebea296cd97a195438d771d7394acb012be6af118bf355a9b6e391ddee1061d83298356f664e0d5dbe3d859012 SHA512 e4159821d4263e5afb67adee82e30cfed0ad30f3772dd95beb0df71423ff52c21354970f64967f2de9fd1d31caa702208cfd9f2ce281bbf33114f3aa7cd539a2
DIST fish-3.0b1.tar.gz 6471932 BLAKE2B d65ed7e7f4de1f967f5f2090b01be86b778a46f8e5c112daf99234bc584e01992c466976d6547814f84730d1092e39bc3f2bfa55592e71bf1a93a42fb8846b34 SHA512 f13c4ca9e62ecdd6afc4961cb4f6ec5d4b7f51b9c3b3ba97f280b7a9ed2cdeb9be193ff58b9f556b01af0815b78ab540f25c473a253651c96db03f8cb1652dde
72 changes: 72 additions & 0 deletions app-shells/fish/fish-3.0.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,72 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit cmake-utils readme.gentoo-r1

DESCRIPTION="Friendly Interactive SHell"
HOMEPAGE="http://fishshell.com/"

MY_PV="${PV/_beta/b}"
MY_P="${PN}-${MY_PV}"

if [[ ${PV} == "9999" ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/${PN}-shell/${PN}-shell.git"
else
SRC_URI="https://github.com/${PN}-shell/${PN}-shell/releases/download/${MY_PV}/${MY_P}.tar.gz"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
fi

LICENSE="GPL-2"
SLOT="0"

IUSE="doc nls test"

RDEPEND="
>=dev-libs/libpcre2-10.21[pcre32]
sys-devel/bc
sys-libs/ncurses:0=
"

DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )
nls? ( sys-devel/gettext )
test? ( dev-tcltk/expect )
"

S="${WORKDIR}/${MY_P}"

src_prepare() {
# workaround for https://github.com/fish-shell/fish-shell/issues/4883
sed -i 's#${TEST_INSTALL_DIR}/${CMAKE_INSTALL_PREFIX}#${TEST_INSTALL_DIR}#' \
cmake/Tests.cmake || die
cmake-utils_src_prepare
}

src_configure() {
local mycmakeargs=(
-DCMAKE_INSTALL_BINDIR="${EPREFIX}/bin"
-DCMAKE_INSTALL_DOCDIR="share/doc/${PF}"
-DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}/etc"
-DINTERNAL_WCWIDTH=OFF
-DBUILD_DOCS="$(usex doc)"
-DWITH_GETTEXT="$(usex nls)"
)
cmake-utils_src_configure
}

src_install() {
cmake-utils_src_install
keepdir /usr/share/fish/vendor_{completions,conf,functions}.d
readme.gentoo_create_doc
}

src_test() {
cmake-utils_src_make -j1 test
}

pkg_postinst() {
readme.gentoo_print_elog
}

0 comments on commit b2fd53f

Please sign in to comment.