Skip to content

Commit

Permalink
dev-ada/gnat_util: Version bump to dev-ada/gnat_util-2018
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.24, Repoman-2.3.6
  • Loading branch information
atupone committed Jun 10, 2018
1 parent f6bdfcf commit b32b7fc
Show file tree
Hide file tree
Showing 3 changed files with 58 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ada/gnat_util/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST gnat_util-gpl-2016-src.tar.gz 1126296 BLAKE2B e1e7c2628b6a012ca3ad5809d4ea785a9fa68ed5e7f67a80475ece80161f53d611eb9a383591167d30f2a1125de48299123cc0c0b4807b6bcb4bca197bda78ed SHA512 1edb67e762637e9e951356c7be402d7b2b903a05abdc93eadaf5ba98bc7bfa936b4fa2a2ae7eb986200dec755020e53d312d42769512fba2e290099f6030bbd0
DIST gnat_util-gpl-2017-src.tar.gz 868496 BLAKE2B d105a59f0533428a4d57b3c81c0818f4d1bd457b113d775fe97f35f7352e03b602ac0e6d7b970e408fb3dd6d30f0d4e60feffccf42dbdc0723a76855b0164ee0 SHA512 d5e48c6fafc870f36094d2dfd5f45f2d5b5729c97596afff7475b7838c1c7c029ef57395ca1011ee74d8a4195597ea1f502732e654a02561a7abc72c8a7d3a6a
DIST gnat_util-gpl-2018-src.tar.gz 883945 BLAKE2B e30ee379f4ea9525337b0794d4fc91c80458b3b1dd3d10cbc455c6f566d4d073b6753c171ffbbabd85995717de249cdee7c094b7ba00d752a13e18d0f54da192 SHA512 490b0fa944f4b9fee2a4e78c1181658eb8f95262314455c41beb3ebe9db5dd540090d1f9840357572969721966fa11085dc680f3498dc539631ef3f4dbf56426
56 changes: 56 additions & 0 deletions dev-ada/gnat_util/gnat_util-2018.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,56 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit toolchain-funcs multiprocessing

MYP=${PN}-gpl-${PV}

DESCRIPTION="Provides access to GNAT compiler internals for AdaCore utilities"
HOMEPAGE="http://libre.adacore.com"
SRC_URI="http://mirrors.cdn.adacore.com/art/5b0819dfc7a447df26c27a6b
-> ${MYP}-src.tar.gz"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="gnat_2016 gnat_2017 +gnat_2018 +shared static-libs static-pic"

RDEPEND="dev-lang/gnat-gpl:7.3.0"
DEPEND="${RDEPEND}
dev-ada/gprbuild[gnat_2018]"
REQUIRED_USE="!gnat_2016 !gnat_2017 gnat_2018"

S="${WORKDIR}"/${MYP}-src

PATCHES=( "${FILESDIR}"/${PN}-2017-gentoo.patch )

src_compile() {
GCC_PV=7.3.0
GCC=${CHOST}-gcc-${GCC_PV}
GNATMAKE=${CHOST}-gnatmake-${GCC_PV}
emake GNATMAKE="${GNATMAKE} ${ADAFLAGS}" \
BUILDER="gprbuild -j$(makeopts_jobs)" generate_sources
if use static-libs; then
emake CC="${GCC}" BUILDER="gprbuild -v -j$(makeopts_jobs)" build-static
fi
for kind in shared static-pic; do
if use ${kind}; then
emake CC="${GCC}" BUILDER="gprbuild -v -j$(makeopts_jobs)" \
build-${kind}
fi
done
}

src_install() {
if use static-libs; then
emake prefix="${D}"/usr install-static
fi
for kind in shared static-pic; do
if use ${kind}; then
emake prefix="${D}"/usr install-${kind}
fi
done
einstalldocs
}
1 change: 1 addition & 0 deletions dev-ada/gnat_util/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -8,6 +8,7 @@
<use>
<flag name="gnat_2016">Compile with dev-lang/gnat-gpl-2016</flag>
<flag name="gnat_2017">Compile with dev-lang/gnat-gpl-2017</flag>
<flag name="gnat_2018">Compile with dev-lang/gnat-gpl-2018</flag>
<flag name="shared">Build gnat_util shared library</flag>
<flag name="static-pic">Build gnat_util static library with pic code</flag>
</use>
Expand Down

0 comments on commit b32b7fc

Please sign in to comment.