Skip to content

Commit

Permalink
app-admin/fleet: add version 0.11.5
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.20.1
  • Loading branch information
Alex Brandt committed Aug 30, 2015
1 parent 6a1c10f commit b3c0845
Show file tree
Hide file tree
Showing 2 changed files with 48 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-admin/fleet/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST fleet-0.11.0.tar.gz 452750 SHA256 475d92eccfa383d5ed7f48ecca69666c597eb67ed53c41ac443e5f7816110ad7 SHA512 050ef3fba52661caa87e04695dc0120b48d9916b2dc466750f3e735738b2de5e39cc343a8526cbdb8cf2966da89696efdc0a98709732e9c2cb6f7ea6875ef2fc WHIRLPOOL 294d46acba60ef8bae28c3e253ca410281918f4f15b5abb692d7a085e7d3846e28c5c890e677bc77487ed14cf4429dbf38beeb5ef7cc6a2746e583f7f825bd9c
DIST fleet-0.11.1.tar.gz 453034 SHA256 65965730f70021988ed869e23d9599a2305f24287f3ac67c2b995b05ef28cbe8 SHA512 28e1fc15f634bb5445a5d011dfccae488a873714d868e8632d928a72728380ee7339619e7c057354a154daff71d7260f04c4911e1b371b05c96099ef1d0d9f8d WHIRLPOOL 476ebe9c72b343ecd7dc3f589eed010b5c98651683ee7aee034427702c2779cc16f7f012fa5e2df6d24af9c98731f8e176c3da7acec4ef6753d088ffbf1b14e5
DIST fleet-0.11.5.tar.gz 456152 SHA256 a6a785099df71645b5fe8755a36baa6c11138749bc02ae4990fd3f52663c0394 SHA512 1d97e386430db948d8730ec26b7d55a1dad00343600400bf21f9a1cb855e068063244ffe55774e72920c210181ff80bd9706ec99fd9eeb2ac28be14bba1dfbf9 WHIRLPOOL 0a9274cc6077eec1790c3fa9ca1ada71723e392cf50f47d17019edc78fe202893053908ba4565beca7f5f6a0bae97d676304df4cd952ff8e06cb0797f41cea89
47 changes: 47 additions & 0 deletions app-admin/fleet/fleet-0.11.5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,47 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

EGO_PN="github.com/coreos/fleet"

inherit systemd vcs-snapshot

DESCRIPTION="A Distributed init System"
HOMEPAGE="https://github.com/coreos/fleet"
SRC_URI="https://github.com/coreos/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64"
IUSE="doc examples test"

DEPEND="
>=dev-lang/go-1.4:=
test? ( dev-go/go-tools )
"
RDEPEND=""

src_compile() {
./build || die 'Build failed'
}

src_test() {
./test || die 'Tests failed'
}

src_install() {
dobin "${S}"/bin/fleetd
dobin "${S}"/bin/fleetctl

systemd_dounit "${FILESDIR}"/fleet.service
systemd_dounit "${FILESDIR}"/fleet.socket

dodoc README.md
use doc && dodoc -r Documentation
use examples && dodoc -r examples

insinto /etc/${PN}
newins "${PN}".conf.sample "${PN}".conf
}

0 comments on commit b3c0845

Please sign in to comment.