Skip to content

Commit

Permalink
Revert "net-misc/networkmanager: Drop old"
Browse files Browse the repository at this point in the history
Old versions still needed by some arches

This reverts commit e9606f0.
  • Loading branch information
pacho2 committed Sep 29, 2016
1 parent c087186 commit b3da92f
Show file tree
Hide file tree
Showing 5 changed files with 772 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-misc/networkmanager/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST NetworkManager-1.0.12.tar.xz 3490836 SHA256 3a470f8c60109b1acb5784ddc2423501706b5fe34c793a6faee87e591eb04a9e SHA512 926c0139dc7ade7bbc512f0d2e386a42a278aceff68996bc3a18fb1940f5d516f0ff2768459d6f50fd5669d72c15202307396bb3cf8b67c3dbac19db484b971c WHIRLPOOL 6178af61fb30a7e8b72cc05296a014a5be5b10fed41cd5385f0bebae1fa22519c83cf8c359479372f063fc2b891715015454c53cd4f1f1516fc03bca76a552ac
DIST NetworkManager-1.2.4.tar.xz 3728788 SHA256 19bfb7306dd472d010443a8027d91f9fd50fe6e0c5aa4ea8083845de0fa38faa SHA512 83fa179c0f360c7f40504cf58275e28638b5a986458c99adc85567595ca170ac3d081ffa0c99e5619c97d4a3228e5318e613330894547ad3438eaa2bfcc1f28b WHIRLPOOL 625cf2a32f5fb1e5ae537f2285f6945ca14f438959fb5556b490a90fe16eddcfb22e84c82f8f0f479f2387ec54ba292b18f28c0676375d729f9bb6a435d9e12b
DIST NetworkManager-1.4.0.tar.xz 3699568 SHA256 c4d5e075998a291074501602a5068a7e54d9e0f2658aba079d58145d65be531d SHA512 2580e885684f6ad464eebdf9e0dab5432d4d45f0f4127af7f8947be16fc5ce84a5cc090e195b68619c14e218d9cffcde1615400c19326e58bdac8fdf7b53fb46 WHIRLPOOL 39607ac0606039c242b2033b9e540c3beb88e7f48fdb8188d942341a57e097dc0e9c7bde248b6d9ae65bd3ac94df83b5e7d7a371baf7f32c8542581c3bdf778c
67 changes: 67 additions & 0 deletions net-misc/networkmanager/files/1.2.4-upower.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,67 @@
From f864c58cfe87533c69dcf00e3ea236809392a8e0 Mon Sep 17 00:00:00 2001
From: Beniamino Galvani <[email protected]>
Date: Thu, 4 Aug 2016 16:25:30 +0200
Subject: build: fix build with '--with-suspend-resume=upower'

Now we have a single file for all suspend APIs and the selection is
done through the preprocessor: remove stale AM_CONDITIONALs and define
SUSPEND_RESUME_UPOWER when needed.

Fixes: c76eb3e8f7a80b69c570b513ee3eb16bea1b34bd
(cherry picked from commit e4b2c989dc51818e52906b5120ea6a0659274631)

diff --git a/configure.ac b/configure.ac
index 46775c3..7869f07 100644
--- a/configure.ac
+++ b/configure.ac
@@ -472,7 +472,9 @@ if test "z$with_suspend_resume" = "z"; then
fi

case $with_suspend_resume in
- upower) ;;
+ upower)
+ AC_DEFINE([SUSPEND_RESUME_UPOWER], 1, [Define to 1 to use UPower suspend api])
+ ;;
systemd)
PKG_CHECK_MODULES(SYSTEMD_INHIBIT, [libsystemd >= 209],,
[PKG_CHECK_MODULES(SYSTEMD_INHIBIT, [libsystemd-login >= 183])])
@@ -485,9 +487,6 @@ case $with_suspend_resume in
AC_MSG_ERROR(--with-suspend-resume must be one of [upower, systemd, consolekit])
;;
esac
-AM_CONDITIONAL(SUSPEND_RESUME_UPOWER, test "x$with_suspend_resume" = "xupower")
-AM_CONDITIONAL(SUSPEND_RESUME_SYSTEMD, test "x$with_suspend_resume" = "xsystemd")
-AM_CONDITIONAL(SUSPEND_RESUME_CONSOLEKIT, test "x$with_suspend_resume" = "xconsolekit")

# SELinux support
AC_ARG_WITH(selinux, AS_HELP_STRING([--with-selinux=yes|no|auto], [Build with SELinux (default: auto)]),,[with_selinux=auto])
--
cgit v0.10.2

--- a/config.h.in
+++ b/config.h.in
@@ -216,6 +216,9 @@
/* Define to 1 to use systemd suspend api */
#undef SUSPEND_RESUME_SYSTEMD

+/* Define to 1 to use UPower suspend api */
+#undef SUSPEND_RESUME_UPOWER
+
/* Define to 1 if libsystemd-journald is available */
#undef SYSTEMD_JOURNAL

--- a/configure
+++ b/configure
@@ -22776,7 +22776,11 @@
fi

case $with_suspend_resume in
- upower) ;;
+ upower)
+
+$as_echo "#define SUSPEND_RESUME_UPOWER 1" >>confdefs.h
+
+ ;;
systemd)

pkg_failed=no
Original file line number Diff line number Diff line change
@@ -0,0 +1,30 @@
From 10ba492047b1ad80adeeb878e7f155a13638da7f Mon Sep 17 00:00:00 2001
From: Michael Olbrich <[email protected]>
Date: Wed, 18 May 2016 10:43:51 +0200
Subject: [PATCH] sleep-monitor-upower: add missing include

Otherwise building fails with:

nm-sleep-monitor-upower.c:132:45: error: expected declaration specifiers or '...' before 'nm_sleep_monitor_get'
nm-sleep-monitor-upower.c:132:67: error: expected declaration specifiers or '...' before '(' token

https://mail.gnome.org/archives/networkmanager-list/2016-May/msg00053.html
---
src/nm-sleep-monitor-upower.c | 1 +
1 file changed, 1 insertion(+)

diff --git a/src/nm-sleep-monitor-upower.c b/src/nm-sleep-monitor-upower.c
index 5f0ff24..8d07190 100644
--- a/src/nm-sleep-monitor-upower.c
+++ b/src/nm-sleep-monitor-upower.c
@@ -24,6 +24,7 @@
#include <sys/stat.h>

#include "nm-core-internal.h"
+#include "NetworkManagerUtils.h"

#include "nm-sleep-monitor.h"

--
2.9.0

Loading

0 comments on commit b3da92f

Please sign in to comment.