Skip to content

Commit

Permalink
dev-python/autobahn: Version bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.6, Repoman-2.3.3
  • Loading branch information
dol-sen committed Sep 20, 2017
1 parent b26b1dd commit b3ecede
Show file tree
Hide file tree
Showing 2 changed files with 66 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/autobahn/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST autobahn-0.16.0.tar.gz 185053 SHA256 a1dcb4315a0914da56ec484659816de72dfad2
DIST autobahn-0.9.4-2.zip 175894 SHA256 5bb64191cfdd1cbdd90d8e359b389ef62c0acdffd2f68d16ec01fa0a287262f0 SHA512 7e0d4246b8b1c552b25c2ae36f1923ed9931e3d3ca684039a422773fecd92ca04734a0b24394a9bbc787f245c72b5552522351a7c1c8e500128e7c46c740a3d5 WHIRLPOOL aa0f06b82acbebb97ca2e3c424429ada7169dca5b39237ce082a17440ec9701a307e9fc7f162f957023cfc4c067f8e8b82b9923cb056ffcab7b3e64a61a4aae8
DIST autobahn-17.5.1.tar.gz 205144 SHA256 2a32fa76a11f8aa8de482e99ad2b7a8acc8f6c0d430c48aebd4666f080e85d5c SHA512 904f8f4c527a6c1c7840ea8634d0c0a47141458500c6d29f4aa1f05ff51f91c65a451b7c447201cbdf5e255c4c2d07509efa106790217b09398e7d50c1d85382 WHIRLPOOL 28b9608110ecfd058b9bfc3a3c587e7d33c7538f62b4ada1969efc2d434dcbcd9b1d3b1711448a09b425016c2622d2135ce789ae1edeaf7f0a1dc96fcdfb7acd
DIST autobahn-17.7.1.tar.gz 211238 SHA256 801a318d5bf6776a60f7a93d715f83f7f12204b470019a339e4e7e14087c17e6 SHA512 592c4e21a7986fc9ac992fdfd24055654c5db7a3b8963fb5814bc32bdfbcdd7e3271bc84ed35faaf50755022a115a5f026de825ba5c35dacad4cfa2cf776d50f WHIRLPOOL 5c521d3e2c65c30ef8e96683d25b1aa4d862461a53f1c59608f3d5065d899f5ad39b58c38048c6cff126af436108093d10f04563ce0a5ef45c27a1f999fd95bf
DIST autobahn-17.9.2.tar.gz 209442 SHA256 15758e1f507d191a0b56dca911eba780d12e603e0a4567bd2ec0ec08bf08cd4c SHA512 de73a4cc99616802d280887ef8a9971c532f974dd43cda933da953d7bcc45da3fd9d0c91763c6a80371f582f0acc9741134b1ba1b98035ef0f63e4971aaff79f WHIRLPOOL cb78970772f770ac732d6d30619f5d18cb24b130566abc741659ffa09ab07ee3f92c4636041d1cfc04c61ac44f02565102954639203ad13d83d69cd68e71e6bf
65 changes: 65 additions & 0 deletions dev-python/autobahn/autobahn-17.9.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,65 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=5

PYTHON_COMPAT=( python2_7 python3_{4,5,6} )

inherit distutils-r1 versionator

MY_P="${PN}-$(replace_version_separator 3 -)"

DESCRIPTION="WebSocket and WAMP for Twisted and Asyncio"
HOMEPAGE="https://pypi.python.org/pypi/autobahn http://autobahn.ws/python/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"

SLOT="0"
LICENSE="MIT"
KEYWORDS="~amd64 ~arm"
IUSE="crypt test"

RDEPEND="
$(python_gen_cond_dep '>=dev-python/trollius-2.0[${PYTHON_USEDEP}]' 'python2_7')
$(python_gen_cond_dep '>=dev-python/futures-3.0.4[${PYTHON_USEDEP}]' 'python2_7')
>=dev-python/cbor-1.0.0[${PYTHON_USEDEP}]
>=dev-python/lz4-0.7.0[${PYTHON_USEDEP}]
>=dev-python/py-ubjson-0.8.4[${PYTHON_USEDEP}]
>=dev-python/six-1.10.0[${PYTHON_USEDEP}]
>=dev-python/snappy-0.5[${PYTHON_USEDEP}]
>=dev-python/twisted-16.6.0-r2[${PYTHON_USEDEP}]
>=dev-python/txaio-2.7.0[${PYTHON_USEDEP}]
>=dev-python/u-msgpack-2.1[${PYTHON_USEDEP}]
>=dev-python/wsaccel-0.6.2[${PYTHON_USEDEP}]
>=dev-python/zope-interface-3.6[${PYTHON_USEDEP}]
crypt? (
>=dev-python/pyopenssl-16.2.0[${PYTHON_USEDEP}]
>=dev-python/pynacl-1.0.1[${PYTHON_USEDEP}]
>=dev-python/pytrie-0.2[${PYTHON_USEDEP}]
>=dev-python/pyqrcode-1.1.0[${PYTHON_USEDEP}]
>=dev-python/service_identity-16.0.0
)
"
DEPEND="${RDEPEND}
test? (
dev-python/mock[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
>=dev-python/pynacl-1.0.1[${PYTHON_USEDEP}]
>=dev-python/pytrie-0.2[${PYTHON_USEDEP}]
>=dev-python/pyqrcode-1.1.0[${PYTHON_USEDEP}]
)"

S="${WORKDIR}"/${MY_P}

python_test() {
#esetup.py test
cd "${BUILD_DIR}"/lib || die
py.test -v || die
}

pkg_postinst() {
python_foreach_impl twisted-regen-cache || die
}

pkg_postrm() {
python_foreach_impl twisted-regen-cache || die
}

0 comments on commit b3ecede

Please sign in to comment.