Skip to content

Commit

Permalink
dev-games/simgear: do not assume libc++ is used for clang
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/735854
Package-Manager: Portage-3.0.8, Repoman-3.0.1
Signed-off-by: Maciej Mrozowski <[email protected]>
  • Loading branch information
reavertm committed Oct 17, 2020
1 parent 101d5e4 commit b3ed56b
Show file tree
Hide file tree
Showing 2 changed files with 13 additions and 0 deletions.
Original file line number Diff line number Diff line change
@@ -0,0 +1,12 @@
diff -ruN simgear-2020.1.2/CMakeLists.txt simgear-my/CMakeLists.txt
--- simgear-2020.1.2/CMakeLists.txt 2020-05-24 17:13:35.000000000 +0200
+++ simgear-my/CMakeLists.txt 2020-10-17 15:48:58.375116913 +0200
@@ -442,8 +442,6 @@
set(WARNING_FLAGS_CXX "-Wall -fPIC -Wno-overloaded-virtual -Wno-redeclared-class-member")
set(WARNING_FLAGS_C "-Wall -fPIC")
set(CMAKE_XCODE_ATTRIBUTE_CLANG_CXX_LIBRARY "libc++")
- # fix Boost compilation :(
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -stdlib=libc++")

# override CMake default RelWithDebInfo flags.
set(CMAKE_CXX_FLAGS_RELWITHDEBINFO "-O3 -g -DNDEBUG")
1 change: 1 addition & 0 deletions dev-games/simgear/simgear-2020.1.2.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -36,6 +36,7 @@ RDEPEND="${COMMON_DEPEND}
PATCHES=(
"${FILESDIR}/${PN}-2019.1.1-gdal3.patch"
"${FILESDIR}/${P}-boost.patch"
"${FILESDIR}/${PN}-2020.1.2-do-not-assume-libc++-clang.patch"
)

pkg_pretend() {
Expand Down

0 comments on commit b3ed56b

Please sign in to comment.