forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-ros/ament_cmake_export_definitions: bump to 1.0.0
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Alexis Ballier <[email protected]>
- Loading branch information
Showing
2 changed files
with
47 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST ament_cmake-0.9.6.tar.gz 60800 BLAKE2B 71c4e71c50b7715bb8f1b5b737ce23e30f79459a14a5866801bcb810b8fe82d807b6a4eae11de427f52c618e14ef22b7693905f1a0200cc38f0ffab1d70e80cd SHA512 c923260bbd0142ea57bf3e868e94e76020939e8ec49cbf23f14221d0048f21efed00dcdae9978e00f246725ba216c151f5d53b1cd94297b8731f53dc0e45b554 | ||
DIST ament_cmake-1.0.0.tar.gz 63304 BLAKE2B dd0c4bc5b72d9143cfb8ee9caae236a3608981ee8523e879ea9c168d64fd1d0cb84e54679cfc0cfc58ffff34519bb1032afc956c3130c1da8b4f98d60a9191be SHA512 69236015368df29a128eceeb64dd1c683eb32a44188b52120592238f999be8c8c7c5892a36ddcef48b6686bf97eba77e820ca3b8896c64ec1522661fa3ed4fc7 |
46 changes: 46 additions & 0 deletions
46
dev-ros/ament_cmake_export_definitions/ament_cmake_export_definitions-1.0.0.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,46 @@ | ||
# Copyright 2019-2020 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
PYTHON_COMPAT=( python{3_6,3_7,3_8} ) | ||
|
||
inherit cmake python-any-r1 | ||
|
||
ROS_PN="ament_cmake" | ||
if [ "${PV#9999}" != "${PV}" ] ; then | ||
inherit git-r3 | ||
EGIT_REPO_URI="https://github.com/ament/ament_cmake" | ||
SRC_URI="" | ||
S=${WORKDIR}/${P}/${PN} | ||
else | ||
SRC_URI="https://github.com/ament/ament_cmake/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz" | ||
S="${WORKDIR}/${ROS_PN}-${PV}/${PN}" | ||
fi | ||
|
||
DESCRIPTION="Export definitions to downstream packages in the ament buildsystem" | ||
HOMEPAGE="https://github.com/ament/ament_cmake" | ||
|
||
LICENSE="Apache-2.0" | ||
SLOT="0" | ||
if [ "${PV#9999}" != "${PV}" ] ; then | ||
KEYWORDS="" | ||
else | ||
KEYWORDS="~amd64" | ||
fi | ||
IUSE="" | ||
|
||
RDEPEND=" | ||
dev-ros/ament_cmake_core | ||
" | ||
DEPEND="${RDEPEND}" | ||
# Deps here are transitive from ament_cmake_core to have matching python support | ||
BDEPEND=" | ||
$(python_gen_any_dep 'dev-python/ament_package[${PYTHON_USEDEP}] dev-python/catkin_pkg[${PYTHON_USEDEP}]') | ||
${PYTHON_DEPS} | ||
" | ||
|
||
python_check_deps() { | ||
has_version "dev-python/ament_package[${PYTHON_USEDEP}]" && \ | ||
has_version "dev-python/catkin_pkg[${PYTHON_USEDEP}]" | ||
} |