Skip to content

Commit

Permalink
dev-python/pyftpdlib: version bump to 1.5.2, add Python 3.6.
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Closes: gentoo#4893
  • Loading branch information
sbraz authored and monsieurp committed Jun 12, 2017
1 parent 181c59e commit b40681e
Show file tree
Hide file tree
Showing 2 changed files with 49 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/pyftpdlib/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST pyftpdlib-1.4.0.tar.gz 116280 SHA256 5fdd1492efe478f4c354f7d65d9308359751c8fb1d0376466b74a76721c5fcf3 SHA512 61cf28d72a3a99bdc9bddcf434275e4edaeff60bf6481c1e854d81a4ea23ae97b73c8da9d0629a705a003ae8a941c529f9b9ed7cfa25759bd5cd6517f9958ff9 WHIRLPOOL 676f58061e07aa8a9dcce9c7076962875866cebca8eacdd624053cab32de3a7bdb0b17337105839b6c997bf2b4263e759c962362930afddaedc1e9a151b855fa
DIST pyftpdlib-1.5.1.tar.gz 127582 SHA256 7bcd7fc825123414a157718c6dcdcb0978208d3c865d4650564acef4acce3354 SHA512 81bb634aef7190d97b5939b998c8dd8caf1ce77c2ca66d085826880590a03e7fe4aeefb5eb67f30f25b984962eaae740c4c8c1d5900909029702e37c36bb2b9b WHIRLPOOL 2b878db9386d3fc81d0e2749facfa4183704f705afb677fdae0031a721a050d246eda80fb8eb7dfb7b5369269f57b7995f201d07f1b54e133e2e7d85277d0615
DIST pyftpdlib-1.5.2.tar.gz 179047 SHA256 bcb1a949848302b4a10623e57966d2bdbcf898bf220b587ea287d14de4b1471e SHA512 b458518eb7a57137d5f677bb4f38f4285f5efed4d8c0b4919c78b42350579407664219f4f289a0d6f307bb33869b73033ee82ad2ae777dc9f5a6d38a1af09a2a WHIRLPOOL 8022e311fb36125a10db6872b05209ebcc62c94b5f5603448ac46d769af1cfcb8517fc30d26b072aca30103530465bba58e953752959abe752f28e707422a452
48 changes: 48 additions & 0 deletions dev-python/pyftpdlib/pyftpdlib-1.5.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,48 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy )
PYTHON_REQ_USE="ssl(+)"

inherit distutils-r1

DESCRIPTION="Python FTP server library"
HOMEPAGE="https://github.com/giampaolo/pyftpdlib https://pypi.python.org/pypi/pyftpdlib"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
IUSE="examples ssl test"

RDEPEND="ssl? ( dev-python/pyopenssl[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}] )"
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
test? ( ${RDEPEND} )
"

python_test() {
# Tests may fail occasionally
# https://github.com/giampaolo/pyftpdlib/issues/420
"${EPYTHON}" ${PN}/test/runner.py || die "Tests failed with ${EPYTHON}"
}

python_install_all() {
if use examples; then
docinto examples
dodoc -r demo/.
docompress -x /usr/share/doc/${PF}/examples
fi
distutils-r1_python_install_all
}

pkg_postinst() {
if [[ -z ${REPLACING_VERSIONS} ]] && \
[[ ${PYTHON_TARGETS} == *python2_7* ]] && \
! has_version dev-python/pysendfile ; then
elog "dev-python/pysendfile is not installed"
elog "It can considerably speed up file transfers for Python 2"
fi
}

0 comments on commit b40681e

Please sign in to comment.