Skip to content

Commit

Permalink
media-libs/gegl: Fix compiling on bigendian.
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.26
  • Loading branch information
Jeroen Roovers committed Dec 5, 2015
1 parent 1f52e73 commit b428d60
Show file tree
Hide file tree
Showing 2 changed files with 13 additions and 0 deletions.
11 changes: 11 additions & 0 deletions media-libs/gegl/files/gegl-0.3.4-endian.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,11 @@
--- a/operations/external/tiff-load.c
+++ b/operations/external/tiff-load.c
@@ -505,7 +505,7 @@
GeglRectangle line = { 0, p->height - row - 1, p->width, 1 };
#if G_BYTE_ORDER != G_LITTLE_ENDIAN
guint row_start = row * p->width;
- guint row end = row * p->width + p->width;
+ guint row_end = row * p->width + p->width;
guint i;

for (i = row_start; i < row_end; i++)
2 changes: 2 additions & 0 deletions media-libs/gegl/gegl-0.3.4.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -77,6 +77,8 @@ pkg_setup() {
}

src_prepare() {
epatch "${FILESDIR}"/${PN}-0.3.4-endian.patch

# FIXME: the following should be proper patch sent to upstream
# fix OSX loadable module filename extension
sed -i -e 's/\.dylib/.bundle/' configure.ac || die
Expand Down

0 comments on commit b428d60

Please sign in to comment.