Skip to content

Commit

Permalink
dev-libs/girara: Version bump (v0.3.1)
Browse files Browse the repository at this point in the history
- switch to meson
- needed for newer zathura packages

Signed-off-by: Mikle Kolyada <[email protected]>
Package-Manager: Portage-2.3.49, Repoman-2.3.11
  • Loading branch information
Zlogene committed Oct 7, 2018
1 parent a2bb18c commit b42d6bb
Show file tree
Hide file tree
Showing 2 changed files with 47 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/girara/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST girara-0.2.7.tar.gz 76723 BLAKE2B 7438709e15b9272260cfa9f5419b40672a2c33b2cdeed1d915b51b4d53b301a4347cb0c051155a9a20b09b61efb0ee13df7eb0fdc3a94d1a428a7cb1e296f0d2 SHA512 4229565b8a5fad1ecbf42e4f3f852644964a7d5c90154dab9b7dcb5ccd5f25731911452472bbeb28927d1e30d4df6ed066926e11c6a73f0fd5740570493a036f
DIST girara-0.2.8.tar.gz 73646 BLAKE2B 08a3fea194922cfb84793d14905f15aac6e73daf3c4304842b88e7f517046daa287deaef770176bc06358b37c52418f1e42204df302c2c7d4f82c2f4a10a44a9 SHA512 d853f8337a63ae2ed319547a2daa2ccd3ce6f31b3dbb52522705c78dbbb94da1dc1efc4ac62d3c2af94531d4dea309323b878619ea0c9778c37960791ca0cb4e
DIST girara-0.3.1.tar.xz 58148 BLAKE2B 7945ca0b417bf09a37f4ce7cc6603adc93cd224d7e449c7f4dae00a4abf254b251230fb40e2f985c293bad95c0bd05ff646418bb5f8e0a1c6d5d2df832900256 SHA512 5c4b2972bfb0296cd1b984c9426b67b50e29e2928fb0e9a3aa3f9bc21aebc28dcc93570e888060e0bb02561022b379cdfcfa3317b52e78cac04e7fc1ba476107
46 changes: 46 additions & 0 deletions dev-libs/girara/girara-0.3.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,46 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit meson virtualx

DESCRIPTION="UI library that focuses on simplicity and minimalism"
HOMEPAGE="https://pwmt.org/projects/girara/"
SRC_URI="https://pwmt.org/projects/girara/download/${P}.tar.xz"

LICENSE="ZLIB"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
IUSE="doc libnotify test"

RDEPEND="dev-libs/glib:2
dev-libs/json-c
>=x11-libs/gtk+-3.20:3
>=x11-libs/pango-1.14
libnotify? ( x11-libs/libnotify )"

DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )
test? ( dev-libs/check )"

BDEPEND="virtual/pkgconfig"

src_prepare() {
default
sed -i -e '/'-Werror.*'/d' meson.build || die "sed failed"
}

src_configure() {
local emesonargs=(
--libdir=/usr/$(get_libdir)
-Denable-json=true
-Denable-docs=$(usex doc true false)
-Denable-notify=$(usex libnotify true false)
)
meson_src_configure
}

src_test() {
virtx default
}

0 comments on commit b42d6bb

Please sign in to comment.