Skip to content

Commit

Permalink
dev-libs/leatherman: bup
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.26
  • Loading branch information
prometheanfire committed Apr 19, 2016
1 parent 24c6e66 commit b43d436
Show file tree
Hide file tree
Showing 2 changed files with 52 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/leatherman/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST leatherman-0.4.2.tar.gz 373142 SHA256 5c1d9af54d803ba8a200004320f55e3ec983265a60f9c8942bf53c745f1f1679 SHA512 c82a3458fe813d0ccd9c5b7539b6d98d28c598be24803062b7a990eadf36fe3b4da70c4253af022bfe9eb4cfdf1d322ed3d04f56021ac09ae10f44fd33467981 WHIRLPOOL afec9a9e773f68d2560f272a5eea11fa601667ccb38bba07f3bdb8e8cb528a6b61ecb35625f633faea6095e63eff172c9018420458d1ed2afeedcb07988962a9
DIST leatherman-0.5.1.tar.gz 384532 SHA256 68eb8ea5d1daa2e395883836a5a616f1fbfc87edaf44f35936102fc5651b6000 SHA512 8a64a9b867713bc93bfee718224040a66fe1b658bd963a758f6ffb1ae5b2e7e82fb33839583b6dafeef4d080fbdf0b71e42febd05086d1ad0ce3bc97ddc5b5ac WHIRLPOOL 0bc5e0574203201ae96d8f3fed70bfde01f476316f56f3f6c00996a7734612714409d5c6781a46918adced5f5d454c954a50677be05763dea52d249eb63236a2
51 changes: 51 additions & 0 deletions dev-libs/leatherman/leatherman-0.5.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,51 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
USE_RUBY="ruby20 ruby21 ruby22"

inherit cmake-utils multilib ruby-ng

DESCRIPTION="A C++ toolkit"
HOMEPAGE="https://github.com/puppetlabs/leatherman"
SRC_URI="https://downloads.puppetlabs.com/facter/${P}.tar.gz"
SRC_URI="https://github.com/puppetlabs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
S="${S}/all/${P}"

LICENSE="Apache-2.0"
SLOT="0"
IUSE="debug test"
KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"

CDEPEND="
>=sys-devel/gcc-4.8:*
>=dev-libs/boost-1.54[nls]
net-misc/curl"

RDEPEND+=" ${CDEPEND}"
DEPEND+=" test? ( ${CDEPEND} )"

src_prepare() {
sed -i 's/\-Werror\ //g' "cmake/cflags.cmake" || die
}

src_configure() {
local mycmakeargs=(
-DCMAKE_VERBOSE_MAKEFILE=ON
-DCMAKE_BUILD_TYPE=None
-DCMAKE_INSTALL_PREFIX=/usr
-DCMAKE_INSTALL_SYSCONFDIR=/etc
-DCMAKE_INSTALL_LOCALSTATEDIR=/var
)
if use debug; then
mycmakeargs+=(
-DCMAKE_BUILD_TYPE=Debug
)
fi
cmake-utils_src_configure
}

src_install() {
cmake-utils_src_install
}

0 comments on commit b43d436

Please sign in to comment.