Skip to content

Commit

Permalink
app-editors/kakoune: bump to 0_pre20160620
Browse files Browse the repository at this point in the history
  • Loading branch information
Hummer12007 authored and gktrk committed Jun 22, 2016
1 parent f875a67 commit b444ce6
Show file tree
Hide file tree
Showing 2 changed files with 43 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-editors/kakoune/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST kakoune-0_pre20160515.tar.gz 369625 SHA256 e826e9225ca2ac13d4b0b5587481aaf59dc2421d93f376b21056199c4f8df9bc SHA512 09651fe485c55c35b878d14044cef565fd5c38c91e658181e051d0034886b30f8dc53a33c79f2d28bb64f51719c4d688a91978020308b01e8a6663eb2b556954 WHIRLPOOL dc403e37399850508135e9a584cc4e49dd7d52b7c573f28cff3346a5c8cca4821361b71da62312bf4d13fe09b7e43c94888159d96fc13cb788ba902353121417
DIST kakoune-0_pre20160620.tar.gz 370523 SHA256 4344bc78a15942c01818c8e8a80f228249557f5d2d20c2fdc845faeef86abe2e SHA512 c186b9024db7956d9bcae925727c3f30dd2c2fb49995e97c56dbdf59c3f17989feb405086957818685a08530da0f2b58b5798687959267da7e9e2a25dd78003c WHIRLPOOL c555754e4fc3456ce7912d60adb72191349692d0465996893ceb1162cc5f7f61b08b0098f13a54d5d44c861aaf3b23eaea343813f055b8ca06f6ce1305a30f4d
42 changes: 42 additions & 0 deletions app-editors/kakoune/kakoune-0_pre20160620.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,42 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit flag-o-matic toolchain-funcs vcs-snapshot

REF="34c8e6a9cf15410a433c8a8c3901703708b85611"

DESCRIPTION="Selection-oriented code editor inspired by vim"
HOMEPAGE="https://github.com/mawww/kakoune"
SRC_URI="https://github.com/mawww/${PN}/tarball/${REF} -> ${P}.tar.gz"

LICENSE="Unlicense"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="debug"

RDEPEND="
sys-libs/ncurses:=[unicode]
dev-libs/boost
"
DEPEND="
app-text/asciidoc
virtual/pkgconfig
${RDEPEND}
"

PATCHES=( "${FILESDIR}/${PN}-makefile.patch" )

src_configure() {
append-cppflags $(pkg-config --cflags ncursesw)
append-libs $(pkg-config --libs ncursesw)
export CXX=$(tc-getCXX)
export debug=$(usex debug)
S="${WORKDIR}/${P}/src"
}

src_install() {
emake DESTDIR="${D}" PREFIX="/usr" docdir="${D}/usr/share/doc/${PF}" install
}

0 comments on commit b444ce6

Please sign in to comment.