forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-editors/juffed: bump snapshot 20200103
Closes: https://bugs.gentoo.org/733130 Signed-off-by: Zamarin Arthur <[email protected]> Signed-off-by: Michał Górny <[email protected]>
- Loading branch information
Showing
2 changed files
with
53 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST juffed-0.10_p20160323.tar.gz 1617451 BLAKE2B 497a117d587fb1d6eb819bdc1cc403a660b808fa07d03fbfa74362c195aafc98733653fa5d7e28803df2bd4d8acb34a3c0d979395c1a6122631cee40d37e2239 SHA512 a49837b199db35c5e7a7580aa4025a2c056b55cef6e98e22f239fc9e455cde3a451d6a0971fb02697c63f3f156d85aaf8021ea13ea3a9e6867ae419f772484b5 | ||
DIST juffed-0.10_p20200103.tar.gz 1628731 BLAKE2B d49e6d8a9eab1edf8b4a74ec0dc9b2e4a4c7e99180c8faf1fdb73d406ee2055626623a72bf00e90f7af7e7380540f625bd9b5c53a662f5334edbebe298e40626 SHA512 6672dc68eb7e40d258dececc9b7389e8417709cad1346e1abb7cf97cf7f59394586c93bc40bb15096c2e5175256385595522dac8714ad5f37946e0bb7a3eb258 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,52 @@ | ||
# Copyright 1999-2021 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
COMMIT=74ab7236a30be17351edc5b83eb3579affd96913 | ||
inherit cmake xdg | ||
|
||
DESCRIPTION="QScintilla-based tabbed text editor with syntax highlighting" | ||
HOMEPAGE="http://juffed.com/en/ https://github.com/Mezomish/juffed" | ||
SRC_URI="https://github.com/Mezomish/juffed/archive/${COMMIT}.tar.gz -> ${P}.tar.gz" | ||
S="${WORKDIR}/${PN}-${COMMIT}" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86" | ||
|
||
RDEPEND=" | ||
app-i18n/enca | ||
dev-qt/qtcore:5 | ||
dev-qt/qtgui:5 | ||
dev-qt/qtprintsupport:5 | ||
dev-qt/qtsingleapplication[X] | ||
dev-qt/qtwidgets:5 | ||
dev-qt/qtxml:5 | ||
x11-libs/qscintilla | ||
" | ||
DEPEND="${RDEPEND}" | ||
BDEPEND="dev-qt/linguist-tools:5" | ||
|
||
DOCS=( ChangeLog README ) | ||
|
||
src_prepare() { | ||
# Upstream version outdated/dysfunctional and CRLF terminated | ||
cp "${FILESDIR}"/FindQtSingleApplication.cmake cmake/ || die | ||
|
||
cmake_src_prepare | ||
|
||
sed -i -e '/set(CMAKE_CXX_FLAGS/d' CMakeLists.txt || die | ||
} | ||
|
||
src_configure() { | ||
local libdir=$(get_libdir) | ||
local mycmakeargs=( | ||
-DUSE_ENCA=ON | ||
-DUSE_QT5=ON | ||
-DUSE_SYSTEM_QTSINGLEAPPLICATION=ON | ||
-DLIB_SUFFIX=${libdir/lib/} | ||
-DQSCINTILLA_NAMES="qscintilla2;libqscintilla2;qscintilla2_qt5;qscintilla2_qt5" | ||
) | ||
cmake_src_configure | ||
} |