Skip to content

Commit

Permalink
app-emulation/reg: Version bump to 0.15.7
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.50, Repoman-2.3.10
  • Loading branch information
mrueg committed Sep 25, 2018
1 parent 01149ef commit b4842c2
Show file tree
Hide file tree
Showing 2 changed files with 49 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-emulation/reg/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST reg-0.15.4.tar.gz 4052737 BLAKE2B 34bc68d3cb161bbea02bfc0ed142cb764f2db64610ac7b2b92130cfc838cfa4fde4794da9fd2d38a9bb73e994cf386ac9f50beaa4435b88cf034a4f4d0b648cc SHA512 d5948b095c310c2697a2f7b80a342af6949e4cb66c521cdb370a6fbead7424d729057fe71952291ee1ed82717cd7bb29141f6a2f85c946e33fd96da1c17912dd
DIST reg-0.15.5.tar.gz 4053475 BLAKE2B 60541d7f02f3ee658fa185206f76df1045975101f0a25a636493a454984a8a2c836b1b74f7b8b6768c66ce0e12b12708b3f42d233e15ba64f0251b02a841bb76 SHA512 c1293868ea30dcdfc5251f95a5f287f8043be3a2372fdd08c0836919f6722c5931eb429f9047769b442bf3fdbb50c476e8509c62cb20b4b45d30793571cce44e
DIST reg-0.15.6.tar.gz 4071110 BLAKE2B 376313ab4aef0f8bce21ddbed8f179aec14755990f6d99e5733c1550c58998f279e3c0beee7b2e11f25167bf7fb717dd731b69571adc410ad7475afcc98baef5 SHA512 1a5635af82f7a7951af325ffbc0d84c2e35ec0ecc040873ff7f0c7037fd2677cea235348c4fb0bf9397f1fd2ccee86e96ca080a1fbc28e60eb985e55e4a8a085
DIST reg-0.15.7.tar.gz 4300839 BLAKE2B 67c9ca344e0a2984559c210cbdb4f5fc42f588f0c50a171c145bc63953b7540cbc166b51a5c209a2ece0c3b5647a34ffc1ac6b439b4e5a243e505c223a1a6fe5 SHA512 4c26aa0a438ac87208c4e269e16a994587ccdab38399a664638dd8c7407cf06f00c43a9c3c71cf4c88fa47a6e4466c8143ee7ee8130a8133518f5017ca34cc2d
48 changes: 48 additions & 0 deletions app-emulation/reg/reg-0.15.7.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,48 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit golang-build golang-vcs-snapshot user

EGO_PN="github.com/genuinetools/reg"
GIT_COMMIT="a761fadc9a1f26a9da8113acc4ea5d8d5fbe5043"
ARCHIVE_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"

DESCRIPTION="Docker registry v2 command line client"
HOMEPAGE="https://github.com/genuinetools/reg"
SRC_URI="${ARCHIVE_URI}"
LICENSE="MIT"
SLOT="0"
IUSE=""

RESTRICT="test"

pkg_setup() {
enewgroup reg
enewuser reg -1 -1 /var/lib/reg reg
}

src_prepare() {
pushd src/${EGO_PN} || die
default
popd || die
}

src_compile() {
pushd src/${EGO_PN} || die
GOPATH="${S}" go build -v -ldflags "-X ${EGO_PN}/version.GITCOMMIT=${GIT_COMMIT} -X ${EGO_PN}/version.VERSION=${PV}" -o "${S}"/bin/reg . || die
popd || die
}

src_install() {
dobin bin/*
dodoc src/${EGO_PN}/README.md
insinto /var/lib/${PN}
doins -r src/${EGO_PN}/server/*
newinitd "${FILESDIR}"/reg.initd reg
newconfd "${FILESDIR}"/reg.confd reg

keepdir /var/log/reg
fowners -R reg:reg /var/log/reg /var/lib/reg/static
}

0 comments on commit b4842c2

Please sign in to comment.